about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorR. RyanTM <ryantm-bot@ryantm.com>2018-12-18 06:11:23 -0800
committerRenaud <c0bw3b@users.noreply.github.com>2018-12-18 15:11:23 +0100
commitfb227af6a079b5ec70e9996237d62850bdb59364 (patch)
tree66a6324b87b04653dca8df9fa7dce892263317f7 /pkgs/servers
parentdb558b31b9af9db59a8000c85c21057c88efcc25 (diff)
downloadnixlib-fb227af6a079b5ec70e9996237d62850bdb59364.tar
nixlib-fb227af6a079b5ec70e9996237d62850bdb59364.tar.gz
nixlib-fb227af6a079b5ec70e9996237d62850bdb59364.tar.bz2
nixlib-fb227af6a079b5ec70e9996237d62850bdb59364.tar.lz
nixlib-fb227af6a079b5ec70e9996237d62850bdb59364.tar.xz
nixlib-fb227af6a079b5ec70e9996237d62850bdb59364.tar.zst
nixlib-fb227af6a079b5ec70e9996237d62850bdb59364.zip
subsonic: 6.1.3 -> 6.1.5
* subsonic: 6.1.3 -> 6.1.5 (#52019)

Semi-automatic update generated by
https://github.com/ryantm/nixpkgs-update tools. This update was made
based on information from
https://repology.org/metapackage/subsonic/versions

* subsonic: license is unfree

Went closed-source since 6.0beta2
See: http://forum.subsonic.org/forum/viewtopic.php?f=4&t=16604#p71128
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/misc/subsonic/default.nix18
1 files changed, 10 insertions, 8 deletions
diff --git a/pkgs/servers/misc/subsonic/default.nix b/pkgs/servers/misc/subsonic/default.nix
index f546b0b075e5..50e754791e6d 100644
--- a/pkgs/servers/misc/subsonic/default.nix
+++ b/pkgs/servers/misc/subsonic/default.nix
@@ -1,14 +1,12 @@
 { stdenv, fetchurl, jre }:
 
-let version = "6.1.3"; in
-
 stdenv.mkDerivation rec {
   name = "subsonic-${version}";
-  inherit version;
+  version = "6.1.5";
 
   src = fetchurl {
     url = "mirror://sourceforge/subsonic/subsonic-${version}-standalone.tar.gz";
-    sha256 = "1v21gfymaqcx6n6d88hvha60q9hgj5z1wsac5gcwq7cjah1893jx";
+    sha256 = "1xz3flxd5hxcvvg1izzxpv5rxwb5zprk92vsgvmcniy7j7r66936";
   };
 
   inherit jre;
@@ -16,20 +14,24 @@ stdenv.mkDerivation rec {
   # Create temporary directory to extract tarball into to satisfy Nix's need
   # for a directory to be created in the unpack phase.
   unpackPhase = ''
+    runHook preUnpack
     mkdir ${name}
     tar -C ${name} -xzf $src
+    runHook postUnpack
   '';
   installPhase = ''
+    runHook preInstall
     mkdir $out
     cp -r ${name}/* $out
+    runHook postInstall
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://subsonic.org;
     description = "Personal media streamer";
-    license = stdenv.lib.licenses.gpl3;
-    maintainers = with stdenv.lib.maintainers; [ telotortium ];
-    platforms = with stdenv.lib.platforms; unix;
+    license = licenses.unfree;
+    maintainers = with maintainers; [ telotortium ];
+    platforms = platforms.unix;
   };
 
   phases = ["unpackPhase" "installPhase"];