about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorAustin Seipp <aseipp@pobox.com>2019-03-05 17:37:47 -0600
committerAustin Seipp <aseipp@pobox.com>2019-03-06 02:22:49 -0600
commitf435d75d79b73e4b820a6436a9a63fff18b6e7c7 (patch)
tree0fe0aceb5f713a3f820deca3bc2668826b6e1c60 /pkgs/servers
parentfeef0893d1441e665f00a35879c1c2b74ae58a96 (diff)
downloadnixlib-f435d75d79b73e4b820a6436a9a63fff18b6e7c7.tar
nixlib-f435d75d79b73e4b820a6436a9a63fff18b6e7c7.tar.gz
nixlib-f435d75d79b73e4b820a6436a9a63fff18b6e7c7.tar.bz2
nixlib-f435d75d79b73e4b820a6436a9a63fff18b6e7c7.tar.lz
nixlib-f435d75d79b73e4b820a6436a9a63fff18b6e7c7.tar.xz
nixlib-f435d75d79b73e4b820a6436a9a63fff18b6e7c7.tar.zst
nixlib-f435d75d79b73e4b820a6436a9a63fff18b6e7c7.zip
ttyd: init at 1.4.2_pre174_6df6ac3e
ttyd hasn't seen a release in a while, but has a few useful bugfixes and
features (such as IPv6) that are good to have. It also seems to fix a
few crashes I encountered (likely due to newer openssl/libwebsockets).
So in an untraditional fashion, we'll adopt this with a _pre tag to
ensure it gets bumped correctly later on.

Signed-off-by: Austin Seipp <aseipp@pobox.com>
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/ttyd/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/pkgs/servers/ttyd/default.nix b/pkgs/servers/ttyd/default.nix
new file mode 100644
index 000000000000..bae43412e784
--- /dev/null
+++ b/pkgs/servers/ttyd/default.nix
@@ -0,0 +1,37 @@
+{ stdenv, fetchFromGitHub
+, pkgconfig, cmake, xxd
+, openssl, libwebsockets, json_c, libuv
+}:
+
+with builtins;
+
+let
+  # ttyd hasn't seen a release in quite a while. remove all this
+  # junk when a new one happens (eventually)
+  revCount = 174;
+  src = fetchFromGitHub {
+    owner  = "tsl0922";
+    repo   = "ttyd";
+    rev    = "6df6ac3e03b705ddd46109c2ac43a1cba439c0df";
+    sha256 = "0g5jlfa7k6qd59ysdagczlhwgjfjspb3sfbd8b790hcil933qrxm";
+  };
+
+in stdenv.mkDerivation rec {
+  name = "ttyd-${version}";
+  version = "1.4.2_pre${toString revCount}_${substring 0 8 src.rev}";
+  inherit src;
+
+  nativeBuildInputs = [ pkgconfig cmake xxd ];
+  buildInputs = [ openssl libwebsockets json_c libuv ];
+  enableParallelBuilding = true;
+
+  outputs = [ "out" "man" ];
+
+  meta = {
+    description = "Share your terminal over the web";
+    homepage    = https://github.com/tsl0922/ttyd;
+    license     = stdenv.lib.licenses.mit;
+    maintainers = [ stdenv.lib.maintainers.thoughtpolice ];
+    platforms   = stdenv.lib.platforms.linux;
+  };
+}