about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorWill Fancher <elvishjerricco@gmail.com>2024-02-02 07:27:40 -0500
committerWill Fancher <elvishjerricco@gmail.com>2024-02-10 13:28:36 -0500
commitf29d66a77f6f5de17158037eef7e52b4f555ce77 (patch)
tree60aaf5279232647c5174616c9d1b74a361080d05 /pkgs/servers
parent8f9789aa7fe8fab4cc1bb41b7c7331cac9a36bbf (diff)
downloadnixlib-f29d66a77f6f5de17158037eef7e52b4f555ce77.tar
nixlib-f29d66a77f6f5de17158037eef7e52b4f555ce77.tar.gz
nixlib-f29d66a77f6f5de17158037eef7e52b4f555ce77.tar.bz2
nixlib-f29d66a77f6f5de17158037eef7e52b4f555ce77.tar.lz
nixlib-f29d66a77f6f5de17158037eef7e52b4f555ce77.tar.xz
nixlib-f29d66a77f6f5de17158037eef7e52b4f555ce77.tar.zst
nixlib-f29d66a77f6f5de17158037eef7e52b4f555ce77.zip
mongodb: Use scons 4
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/nosql/mongodb/mongodb.nix8
1 files changed, 2 insertions, 6 deletions
diff --git a/pkgs/servers/nosql/mongodb/mongodb.nix b/pkgs/servers/nosql/mongodb/mongodb.nix
index c37f06d5e8bd..2b0c1b1aca14 100644
--- a/pkgs/servers/nosql/mongodb/mongodb.nix
+++ b/pkgs/servers/nosql/mongodb/mongodb.nix
@@ -1,7 +1,7 @@
 { lib
 , stdenv
 , fetchurl
-, scons_3_1_2
+, scons
 , boost
 , gperftools
 , pcre-cpp
@@ -44,8 +44,6 @@ let
         pymongo
       ]);
 
-      scons = scons_3_1_2;
-
       mozjsVersion = "60";
       mozjsReplace = "defined(HAVE___SINCOS)";
 
@@ -58,8 +56,6 @@ let
         setuptools
       ]);
 
-      scons = scons_3_1_2;
-
       mozjsVersion = "60";
       mozjsReplace = "defined(HAVE___SINCOS)";
 
@@ -87,7 +83,7 @@ in stdenv.mkDerivation rec {
     inherit sha256;
   };
 
-  nativeBuildInputs = [ variants.scons ]
+  nativeBuildInputs = [ scons ]
                       ++ lib.optionals (versionAtLeast version "4.4") [ xz ];
 
   buildInputs = [