about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorMarco Maggesi <maggesi@math.unifi.it>2010-02-01 16:27:35 +0000
committerMarco Maggesi <maggesi@math.unifi.it>2010-02-01 16:27:35 +0000
commitf278489e980c1a16336974dfd4babfd94c351e9a (patch)
tree3a69d86355e335d0eddc732a31c150ae01eca3fd /pkgs/servers
parent8beaa7ab636051dd0ee1a801bc43f6aecdcc999e (diff)
downloadnixlib-f278489e980c1a16336974dfd4babfd94c351e9a.tar
nixlib-f278489e980c1a16336974dfd4babfd94c351e9a.tar.gz
nixlib-f278489e980c1a16336974dfd4babfd94c351e9a.tar.bz2
nixlib-f278489e980c1a16336974dfd4babfd94c351e9a.tar.lz
nixlib-f278489e980c1a16336974dfd4babfd94c351e9a.tar.xz
nixlib-f278489e980c1a16336974dfd4babfd94c351e9a.tar.zst
nixlib-f278489e980c1a16336974dfd4babfd94c351e9a.zip
Fix bugs and improve pkgs/servers/openafs-client
svn path=/nixpkgs/trunk/; revision=19750
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/openafs-client/default.nix23
1 files changed, 4 insertions, 19 deletions
diff --git a/pkgs/servers/openafs-client/default.nix b/pkgs/servers/openafs-client/default.nix
index 8021f7cf9df6..330bcc2e8635 100644
--- a/pkgs/servers/openafs-client/default.nix
+++ b/pkgs/servers/openafs-client/default.nix
@@ -1,21 +1,20 @@
 { stdenv, fetchurl, autoconf, automake, flex, yacc,
-  kernel_2_6_28, glibc, ncurses, perl, krb5 }:
+  kernel, glibc, ncurses, perl, krb5 }:
 
 assert stdenv.isLinux;
 
 let
   pname = "openafs";
   version = "1.4.11";
-  name = "${pname}-${version}";
+  name = "${pname}-${version}-${kernel.version}";
   webpage = http://www.openafs.org;
-  kernel = kernel_2_6_28;
 in
 
 stdenv.mkDerivation rec {
   inherit name;
 
   src = fetchurl {
-    url = "${webpage}/dl/${pname}/${version}/${name}-src.tar.gz";
+    url = "${webpage}/dl/${pname}/${version}/${pname}-${version}-src.tar.gz";
     sha256 = "ea5377119fd7b5317428644fa427066b9edbde395d997943a448426742d2c5c9";
   };
 
@@ -26,20 +25,6 @@ stdenv.mkDerivation rec {
   replace_usrbinperl = ./replace-usrbinperl;
   replace_usrsrc = ./replace-usrsrc;
 
-/*
-    xargs -IXX -L1 -a ${replace_usrbinenv} \
-      substituteInPlace XX --replace "/usr/bin/env" $(type -tp env)
-
-    xargs -IXX -L1 -a ${replace_usrinclude} \
-      substituteInPlace XX --replace "/usr/include" "${glibc}/include"
-
-    xargs -IXX -L1 -a ${replace_usrbinperl} \
-      substituteInPlace XX --replace "/usr/bin/perl" $(type -tp perl)
-
-    xargs -IXX -L1 -a ${replace_usrsrc} \
-      substituteInPlace XX --replace "/usr/src" "$TMP"
-*/
-
   configurePhase = ''
     ln -s ${kernel}/lib/modules/*/build $TMP/linux
 
@@ -63,9 +48,9 @@ stdenv.mkDerivation rec {
     ./configure \
        --prefix=$out \
        --with-linux-kernel-build=$TMP/linux \
-       --with-afs-sysname=amd64_linux26 \
        --with-krb5-conf=${krb5}/bin/krb5-config \
        --sysconfdir=/etc/static
+       #--with-afs-sysname=amd64_linux26 \
 
     substituteInPlace src/pinstall/install.c --replace "/bin/cp" $(type -tp cp)
   '';