about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-05-18 15:55:55 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-05-18 19:45:19 -0700
commitf0d324c23aaef6475eb6746e55b878696246cd9c (patch)
treef85c52aeac6587a8968856f0d083b3a9357e26cd /pkgs/servers
parent414b3f2909a0a912cb7fb4a5890b7cd31867d8f1 (diff)
downloadnixlib-f0d324c23aaef6475eb6746e55b878696246cd9c.tar
nixlib-f0d324c23aaef6475eb6746e55b878696246cd9c.tar.gz
nixlib-f0d324c23aaef6475eb6746e55b878696246cd9c.tar.bz2
nixlib-f0d324c23aaef6475eb6746e55b878696246cd9c.tar.lz
nixlib-f0d324c23aaef6475eb6746e55b878696246cd9c.tar.xz
nixlib-f0d324c23aaef6475eb6746e55b878696246cd9c.tar.zst
nixlib-f0d324c23aaef6475eb6746e55b878696246cd9c.zip
consul-template: Move to go-packages
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/consul/template.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/pkgs/servers/consul/template.nix b/pkgs/servers/consul/template.nix
deleted file mode 100644
index 59ca524b51e3..000000000000
--- a/pkgs/servers/consul/template.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ stdenv, lib, go, fetchgit, fetchhg, fetchbzr, fetchFromGitHub }:
-
-stdenv.mkDerivation rec {
-  name = "consul-template-${version}";
-  version = "0.7.0";
-
-  src = import ./deps.nix {
-    inherit stdenv lib fetchgit fetchhg fetchbzr fetchFromGitHub;
-  };
-
-  buildInputs = [ go ];
-
-  buildPhase = ''
-    GOPATH=$src go build -v -o consul-template github.com/hashicorp/consul-template
-  '';
-
-  installPhase = ''
-    # Fix references to go-deps in the binary
-    hash=$(echo $src | sed 's,.*/\([^/-]*\).*,\1,g')
-    xs=$(printf 'x%.0s' $(seq 2 $(echo $hash | wc -c)))
-    sed -i "s,$hash,$xs,g" consul-template
-
-    mkdir -p $out/bin
-    cp consul-template $out/bin
-  '';
-
-  meta = with lib; {
-    description = "Generic template rendering and notifications with Consul";
-    homepage = https://github.com/hashicorp/consul-template;
-    license = licenses.mpl20;
-    maintainers = with maintainers; [ puffnfresh wkennington ];
-    platforms = platforms.unix;
-  };
-}