about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authortu-maurice <valentin.gehrke@zom.bi>2022-02-20 00:18:48 +0100
committertu-maurice <valentin.gehrke@zom.bi>2022-02-20 11:57:28 +0100
commitef9d0ba1fc9966da61c2fcaa8fd1ad1e44833538 (patch)
treedf101fd27853f9a65fe855310775c222a4d0781c /pkgs/servers
parent451c27fb70610188d44e9f24b2fd89b390eb4e96 (diff)
downloadnixlib-ef9d0ba1fc9966da61c2fcaa8fd1ad1e44833538.tar
nixlib-ef9d0ba1fc9966da61c2fcaa8fd1ad1e44833538.tar.gz
nixlib-ef9d0ba1fc9966da61c2fcaa8fd1ad1e44833538.tar.bz2
nixlib-ef9d0ba1fc9966da61c2fcaa8fd1ad1e44833538.tar.lz
nixlib-ef9d0ba1fc9966da61c2fcaa8fd1ad1e44833538.tar.xz
nixlib-ef9d0ba1fc9966da61c2fcaa8fd1ad1e44833538.tar.zst
nixlib-ef9d0ba1fc9966da61c2fcaa8fd1ad1e44833538.zip
fishnet: 2.4.0 -> 2.5.1
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/fishnet/Cargo.lock.patch13
-rw-r--r--pkgs/servers/fishnet/default.nix16
2 files changed, 24 insertions, 5 deletions
diff --git a/pkgs/servers/fishnet/Cargo.lock.patch b/pkgs/servers/fishnet/Cargo.lock.patch
new file mode 100644
index 000000000000..7929eeee088e
--- /dev/null
+++ b/pkgs/servers/fishnet/Cargo.lock.patch
@@ -0,0 +1,13 @@
+diff --git a/Cargo.lock b/Cargo.lock
+index 963e40e..fb76d78 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -230,7 +230,7 @@ dependencies = [
+
+ [[package]]
+ name = "fishnet"
+-version = "2.5.1-dev"
++version = "2.5.1"
+ dependencies = [
+  "arrayvec",
+  "atty",
\ No newline at end of file
diff --git a/pkgs/servers/fishnet/default.nix b/pkgs/servers/fishnet/default.nix
index 784a5525133c..10695e54781f 100644
--- a/pkgs/servers/fishnet/default.nix
+++ b/pkgs/servers/fishnet/default.nix
@@ -6,21 +6,21 @@
 }:
 
 let
-  nnueFile = "nn-6762d36ad265.nnue";
+  nnueFile = "nn-13406b1dcbe0.nnue";
   nnue = fetchurl {
     url = "https://tests.stockfishchess.org/api/nn/${nnueFile}";
-    sha256 = "0727dsxfpns9fkyir95fybibqmigk5h45k154b2c5rk5s9md6qk7";
+    sha256 = "sha256-E0BrHcvgo238XgfaUdjbOLekXX2kMHjsJadiTCuDI28=";
   };
 in
 rustPlatform.buildRustPackage rec {
   pname = "fishnet";
-  version = "2.4.0";
+  version = "2.5.1";
 
   src = fetchFromGitHub {
     owner = "niklasf";
     repo = pname;
     rev = "v${version}";
-    sha256 = "sha256-1Gl2vJFn9yVYH62yBJefAOBX/jJaFAdSZj2Lj3imcps=";
+    sha256 = "sha256-nVRG60sSpTqfqhCclvWoeyHR0+oO1Jn1PgftigDGq5c=";
     fetchSubmodules = true;
   };
 
@@ -29,7 +29,13 @@ rustPlatform.buildRustPackage rec {
     cp -v '${nnue}' 'Fairy-Stockfish/src/${nnueFile}'
   '';
 
-  cargoSha256 = "sha256-/s7Yyi2FUh+EDvgaHLgZ/FA6kk2FQrZr3L3B76fqTuc=";
+  cargoSha256 = "sha256-BJK7M/pjHRj74xoeciavhkK2YRpeogkELIuXetX73so=";
+
+  # TODO: Cargo.lock is out of date, so fix it. Likely not necessary anymore in
+  # the next update.
+  cargoPatches = [
+    ./Cargo.lock.patch
+  ];
 
   meta = with lib; {
     description = "Distributed Stockfish analysis for lichess.org";