about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorembr <git@liclac.eu>2021-05-31 10:47:46 +0200
committerembr <git@liclac.eu>2021-05-31 10:47:49 +0200
commitee4b583ae8b11a38065ed7aa3eef01389f44b30f (patch)
tree4f6c0617190a6b49e0bd3f71528ed832c71bc7b3 /pkgs/servers
parentf4f05481e325aa8d5975f11f46340ca04ff729d6 (diff)
downloadnixlib-ee4b583ae8b11a38065ed7aa3eef01389f44b30f.tar
nixlib-ee4b583ae8b11a38065ed7aa3eef01389f44b30f.tar.gz
nixlib-ee4b583ae8b11a38065ed7aa3eef01389f44b30f.tar.bz2
nixlib-ee4b583ae8b11a38065ed7aa3eef01389f44b30f.tar.lz
nixlib-ee4b583ae8b11a38065ed7aa3eef01389f44b30f.tar.xz
nixlib-ee4b583ae8b11a38065ed7aa3eef01389f44b30f.tar.zst
nixlib-ee4b583ae8b11a38065ed7aa3eef01389f44b30f.zip
bozohttpd: minor formatting
The Nix style guide isn't exactly comprehensive, but this at least seems
slightly closer to the examples:

https://nixos.org/manual/nixpkgs/stable/#sec-syntax

I'm annoyed that nixpkgs-fmt as of writing won't accept:

  COPTS = [
    # ...
  ] ++ optional (...) "..."
    ++ optional (...) "...";

...which seems to be the actual convention, looking at eg. pkgs.nginx.
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/bozohttpd/default.nix33
1 files changed, 16 insertions, 17 deletions
diff --git a/pkgs/servers/http/bozohttpd/default.nix b/pkgs/servers/http/bozohttpd/default.nix
index 32a21f842643..9a3526d380e1 100644
--- a/pkgs/servers/http/bozohttpd/default.nix
+++ b/pkgs/servers/http/bozohttpd/default.nix
@@ -45,25 +45,24 @@ stdenv.mkDerivation rec {
   buildInputs = [ openssl ] ++ optional (luaSupport) lua;
   nativeBuildInputs = [ bmake groff ];
 
-  COPTS =
-    [
-      "-D_DEFAULT_SOURCE"
-      "-D_GNU_SOURCE"
+  COPTS = [
+    "-D_DEFAULT_SOURCE"
+    "-D_GNU_SOURCE"
 
-      # Ensure that we can serve >2GB files even on 32-bit systems.
-      "-D_LARGEFILE_SOURCE"
-      "-D_FILE_OFFSET_BITS=64"
+    # ensure that we can serve >2GB files even on 32-bit systems.
+    "-D_LARGEFILE_SOURCE"
+    "-D_FILE_OFFSET_BITS=64"
 
-      # unpackaged dependency: https://man.netbsd.org/blocklist.3
-      "-DNO_BLOCKLIST_SUPPORT"
-    ]
-    ++ optional (!userSupport) "-DNO_USER_SUPPORT"
-    ++ optional (!dirIndexSupport) "-DNO_DIRINDEX_SUPPORT"
-    ++ optional (!dynamicContentSupport) "-DNO_DYNAMIC_CONTENT"
-    ++ optional (!luaSupport) "-DNO_LUA_SUPPORT"
-    ++ optional (!sslSupport) "-DNO_SSL_SUPPORT"
-    ++ optional (!cgiSupport) "-DNO_CGIBIN_SUPPORT"
-    ++ optional (htpasswdSupport) "-DDO_HTPASSWD";
+    # unpackaged dependency: https://man.netbsd.org/blocklist.3
+    "-DNO_BLOCKLIST_SUPPORT"
+  ]
+  ++ optional (!userSupport) "-DNO_USER_SUPPORT"
+  ++ optional (!dirIndexSupport) "-DNO_DIRINDEX_SUPPORT"
+  ++ optional (!dynamicContentSupport) "-DNO_DYNAMIC_CONTENT"
+  ++ optional (!luaSupport) "-DNO_LUA_SUPPORT"
+  ++ optional (!sslSupport) "-DNO_SSL_SUPPORT"
+  ++ optional (!cgiSupport) "-DNO_CGIBIN_SUPPORT"
+  ++ optional (htpasswdSupport) "-DDO_HTPASSWD";
 
   _LDADD = [ "-lcrypt" "-lm" ]
     ++ optional (luaSupport) "-llua"