about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorRoman Volosatovs <rvolosatovs@riseup.net>2019-04-28 19:03:54 +0200
committerRoman Volosatovs <rvolosatovs@riseup.net>2019-09-10 16:01:45 +0200
commite63312ea120e6892626ee380fdee8c1373d41016 (patch)
tree457e23e3f93dbadd2c39659977e7ed3d1f53a8c6 /pkgs/servers
parentd9b290000e94e35e40c55a717ec1ccbd749e7f31 (diff)
downloadnixlib-e63312ea120e6892626ee380fdee8c1373d41016.tar
nixlib-e63312ea120e6892626ee380fdee8c1373d41016.tar.gz
nixlib-e63312ea120e6892626ee380fdee8c1373d41016.tar.bz2
nixlib-e63312ea120e6892626ee380fdee8c1373d41016.tar.lz
nixlib-e63312ea120e6892626ee380fdee8c1373d41016.tar.xz
nixlib-e63312ea120e6892626ee380fdee8c1373d41016.tar.zst
nixlib-e63312ea120e6892626ee380fdee8c1373d41016.zip
echoip: Migrate to buildGoModule
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/echoip/default.nix10
-rw-r--r--pkgs/servers/echoip/deps.nix74
2 files changed, 3 insertions, 81 deletions
diff --git a/pkgs/servers/echoip/default.nix b/pkgs/servers/echoip/default.nix
index d55eb1d0bbdf..83f3945fc9ce 100644
--- a/pkgs/servers/echoip/default.nix
+++ b/pkgs/servers/echoip/default.nix
@@ -1,11 +1,9 @@
-{ lib, buildGoPackage, fetchFromGitHub }:
+{ lib, buildGoModule, fetchFromGitHub }:
 
-buildGoPackage {
+buildGoModule {
   pname = "echoip";
   version = "unstable-2018-11-20";
 
-  goPackagePath = "github.com/mpolden/echoip";
-
   src = fetchFromGitHub {
     owner = "mpolden";
     repo = "echoip";
@@ -13,9 +11,7 @@ buildGoPackage {
     sha256 = "0n5d9i8cc5lqgy5apqd3zhyl3h1xjacf612z8xpvbm75jnllcvxy";
   };
 
-  goDeps = ./deps.nix;
-
-  outputs = [ "bin" "out" ];
+  modSha256 = "025p891klwpid5fw4z39fimgfkwgkcwqpn5276hflzdp1hfv35ly";
 
   postInstall = ''
     mkdir -p $out
diff --git a/pkgs/servers/echoip/deps.nix b/pkgs/servers/echoip/deps.nix
deleted file mode 100644
index 4e4f0799bdae..000000000000
--- a/pkgs/servers/echoip/deps.nix
+++ /dev/null
@@ -1,74 +0,0 @@
-# file generated from go.mod using vgo2nix (https://github.com/adisbladis/vgo2nix)
-[
-
-  {
-    goPackagePath = "github.com/davecgh/go-spew";
-    fetch = {
-      type = "git";
-      url = "https://github.com/davecgh/go-spew";
-      rev = "v1.1.1";
-      sha256 = "0hka6hmyvp701adzag2g26cxdj47g21x6jz4sc6jjz1mn59d474y";
-    };
-  }
-
-  {
-    goPackagePath = "github.com/jessevdk/go-flags";
-    fetch = {
-      type = "git";
-      url = "https://github.com/jessevdk/go-flags";
-      rev = "v1.4.0";
-      sha256 = "0algnnigph27spgn655zm4723yfjxjjvlf4k14z9drj3682df25a";
-    };
-  }
-
-  {
-    goPackagePath = "github.com/oschwald/geoip2-golang";
-    fetch = {
-      type = "FromGitHub";
-      owner = "oschwald";
-      repo = "geoip2-golang";
-      rev = "v1.2.1";
-      sha256 = "0zpgpz577rghvgis6ji9l99pq87z5izbgzmnbyn3dy533bayrgpw";
-    };
-  }
-
-  {
-    goPackagePath = "github.com/oschwald/maxminddb-golang";
-    fetch = {
-      type = "git";
-      url = "https://github.com/oschwald/maxminddb-golang";
-      rev = "v1.2.1";
-      sha256 = "0nlip5a2yiig0sv9y3ky4kn8730236wal3zjcs4yfgnw6nxl3rjr";
-    };
-  }
-
-  {
-    goPackagePath = "github.com/pmezard/go-difflib";
-    fetch = {
-      type = "git";
-      url = "https://github.com/pmezard/go-difflib";
-      rev = "v1.0.0";
-      sha256 = "0c1cn55m4rypmscgf0rrb88pn58j3ysvc2d0432dp3c6fqg6cnzw";
-    };
-  }
-
-  {
-    goPackagePath = "github.com/stretchr/testify";
-    fetch = {
-      type = "git";
-      url = "https://github.com/stretchr/testify";
-      rev = "v1.2.2";
-      sha256 = "0dlszlshlxbmmfxj5hlwgv3r22x0y1af45gn1vd198nvvs3pnvfs";
-    };
-  }
-
-  {
-    goPackagePath = "golang.org/x/sys";
-    fetch = {
-      type = "git";
-      url = "https://go.googlesource.com/sys";
-      rev = "37707fdb30a5";
-      sha256 = "1abrr2507a737hdqv4q7pw7hv6ls9pdiq9crhdi52r3gcz6hvizg";
-    };
-  }
-]