about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorJason \"Don\" O'Conal <lovek323@gmail.com>2013-07-07 19:02:56 +1000
committerRok Garbas <rok@garbas.si>2013-07-07 13:46:43 +0200
commitccb7715de88f3bef875b6e9bae7994e1f72fa910 (patch)
treea850d85c713a5a3278c0b4d870b095104819a952 /pkgs/servers
parent3fe02f7c8b5b06b33ff037466d992aad44c7d817 (diff)
downloadnixlib-ccb7715de88f3bef875b6e9bae7994e1f72fa910.tar
nixlib-ccb7715de88f3bef875b6e9bae7994e1f72fa910.tar.gz
nixlib-ccb7715de88f3bef875b6e9bae7994e1f72fa910.tar.bz2
nixlib-ccb7715de88f3bef875b6e9bae7994e1f72fa910.tar.lz
nixlib-ccb7715de88f3bef875b6e9bae7994e1f72fa910.tar.xz
nixlib-ccb7715de88f3bef875b6e9bae7994e1f72fa910.tar.zst
nixlib-ccb7715de88f3bef875b6e9bae7994e1f72fa910.zip
apacheHttpd_2_4: fix build on darwin
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/apache-httpd/2.4.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/pkgs/servers/http/apache-httpd/2.4.nix b/pkgs/servers/http/apache-httpd/2.4.nix
index da3532126579..bbf84a852b8f 100644
--- a/pkgs/servers/http/apache-httpd/2.4.nix
+++ b/pkgs/servers/http/apache-httpd/2.4.nix
@@ -27,7 +27,7 @@ stdenv.mkDerivation rec {
     optional libxml2Support libxml2;
 
   # Required for ‘pthread_cancel’.
-  NIX_LDFLAGS = "-lgcc_s";
+  NIX_LDFLAGS = stdenv.lib.optionalString (!stdenv.isDarwin) "-lgcc_s";
 
   configureFlags = ''
     --with-apr=${apr}
@@ -58,11 +58,11 @@ stdenv.mkDerivation rec {
     inherit apr aprutil sslSupport proxySupport ldapSupport;
   };
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "Apache HTTPD, the world's most popular web server";
-    homepage = "http://httpd.apache.org/";
-    license = stdenv.lib.licenses.asl20;
-    platforms = stdenv.lib.platforms.unix;
-    maintainers = [ stdenv.lib.maintainers.simons ];
+    homepage    = http://httpd.apache.org/;
+    license     = licenses.asl20;
+    platforms   = stdenv.lib.platforms.unix;
+    maintainers = with maintainers; [ lovek323 simons ];
   };
 }