about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2012-07-07 08:41:21 +0200
committerPeter Simons <simons@cryp.to>2012-07-07 08:47:19 +0200
commitc870b805124ad92642b8b407d1585d967dc3a884 (patch)
tree792a8e95a019dd1ffc08bc0eb12f89078a10b9af /pkgs/servers
parent2659c3be4571a99c576da22d057e1f86a8db4fdf (diff)
downloadnixlib-c870b805124ad92642b8b407d1585d967dc3a884.tar
nixlib-c870b805124ad92642b8b407d1585d967dc3a884.tar.gz
nixlib-c870b805124ad92642b8b407d1585d967dc3a884.tar.bz2
nixlib-c870b805124ad92642b8b407d1585d967dc3a884.tar.lz
nixlib-c870b805124ad92642b8b407d1585d967dc3a884.tar.xz
nixlib-c870b805124ad92642b8b407d1585d967dc3a884.tar.zst
nixlib-c870b805124ad92642b8b407d1585d967dc3a884.zip
apache: add version 2.4
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/apache-httpd/2.2.nix (renamed from pkgs/servers/http/apache-httpd/default.nix)0
-rw-r--r--pkgs/servers/http/apache-httpd/2.4.nix60
2 files changed, 60 insertions, 0 deletions
diff --git a/pkgs/servers/http/apache-httpd/default.nix b/pkgs/servers/http/apache-httpd/2.2.nix
index f2a21ee28be2..f2a21ee28be2 100644
--- a/pkgs/servers/http/apache-httpd/default.nix
+++ b/pkgs/servers/http/apache-httpd/2.2.nix
diff --git a/pkgs/servers/http/apache-httpd/2.4.nix b/pkgs/servers/http/apache-httpd/2.4.nix
new file mode 100644
index 000000000000..043a15a984b4
--- /dev/null
+++ b/pkgs/servers/http/apache-httpd/2.4.nix
@@ -0,0 +1,60 @@
+{ stdenv, fetchurl, perl, zlib, apr, aprutil, pcre
+, proxySupport ? true
+, sslSupport ? true, openssl
+, ldapSupport ? true, openldap
+, libxml2Support ? true, libxml2
+, luaSupport ? false, lua5
+}:
+
+let optional       = stdenv.lib.optional;
+    optionalString = stdenv.lib.optionalString;
+in
+
+assert sslSupport -> aprutil.sslSupport && openssl != null;
+assert ldapSupport -> aprutil.ldapSupport && openldap != null;
+
+stdenv.mkDerivation rec {
+  version = "2.4.2";
+  name = "apache-httpd-${version}";
+
+  src = fetchurl {
+    url = "mirror://apache/httpd/httpd-${version}.tar.bz2";
+    sha1 = "8d391db515edfb6623c0c7c6ce5c1b2e1f7c64c2";
+  };
+
+  buildInputs = [perl] ++
+    optional ldapSupport openldap ++	# there is no --with-ldap flag
+    optional libxml2Support libxml2;	# there is --with-libxml2, but it doesn't work
+
+  configureFlags = ''
+    --with-apr=${apr}
+    --with-apr-util=${aprutil}
+    --with-z=${zlib}
+    --with-pcre=${pcre}
+    --disable-maintainer-mode
+    --disable-debugger-mode
+    --enable-mods-shared=all
+    ${optionalString proxySupport "--enable-proxy"}
+    ${optionalString sslSupport "--enable-ssl --with-ssl=${openssl}"}
+    ${optionalString luaSupport "--enable-lua --with-lua=${lua5}"}
+  '';
+
+  postInstall = ''
+    echo "removing manual"
+    rm -rf $out/manual
+  '';
+
+  enableParallelBuilding = true;
+
+  passthru = {
+    inherit apr aprutil sslSupport proxySupport ldapSupport;
+  };
+
+  meta = {
+    description = "Apache HTTPD, the world's most popular web server";
+    homepage = "http://httpd.apache.org/";
+    license = stdenv.lib.licenses.asl20;
+    platforms = stdenv.lib.platforms.unix;
+    maintainers = [ stdenv.lib.maintainers.simons ];
+  };
+}