about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorElis Hirwing <elis@hirwing.se>2020-03-22 14:31:13 +0100
committerElis Hirwing <elis@hirwing.se>2020-04-03 10:11:07 +0200
commitbe7bf5a18d155b9eb6de3a63ca0943b4c40856ae (patch)
treef623c3d29b74817ed0c907791c0ec9e8c628d750 /pkgs/servers
parent1983417a2f80bf14ea0089817cb20f8025e232b5 (diff)
downloadnixlib-be7bf5a18d155b9eb6de3a63ca0943b4c40856ae.tar
nixlib-be7bf5a18d155b9eb6de3a63ca0943b4c40856ae.tar.gz
nixlib-be7bf5a18d155b9eb6de3a63ca0943b4c40856ae.tar.bz2
nixlib-be7bf5a18d155b9eb6de3a63ca0943b4c40856ae.tar.lz
nixlib-be7bf5a18d155b9eb6de3a63ca0943b4c40856ae.tar.xz
nixlib-be7bf5a18d155b9eb6de3a63ca0943b4c40856ae.tar.zst
nixlib-be7bf5a18d155b9eb6de3a63ca0943b4c40856ae.zip
php-embed: Drop the declaration of the php-embed attributes
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/uwsgi/default.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/pkgs/servers/uwsgi/default.nix b/pkgs/servers/uwsgi/default.nix
index 7669053d2294..0a1ad23c2cef 100644
--- a/pkgs/servers/uwsgi/default.nix
+++ b/pkgs/servers/uwsgi/default.nix
@@ -4,10 +4,15 @@
 , pam, withPAM ? stdenv.isLinux
 , systemd, withSystemd ? stdenv.isLinux
 , python2, python3, ncurses
-, ruby, php-embed, libmysqlclient
+, ruby, php, libmysqlclient
 }:
 
-let pythonPlugin = pkg : lib.nameValuePair "python${if pkg.isPy2 then "2" else "3"}" {
+let php-embed = php.override {
+      config.php.embed = true;
+      config.php.apxs2 = false;
+    };
+
+    pythonPlugin = pkg : lib.nameValuePair "python${if pkg.isPy2 then "2" else "3"}" {
                            interpreter = pkg.interpreter;
                            path = "plugins/python";
                            inputs = [ pkg ncurses ];