about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorBjørn Forsman <bjorn.forsman@gmail.com>2016-06-20 12:53:46 +0200
committerBjørn Forsman <bjorn.forsman@gmail.com>2016-06-20 13:55:52 +0200
commitbd01fad0ed2c0e9f84db55989159f425e82884e6 (patch)
tree43327b5a818c710278c5cd1565072a998a421bdc /pkgs/servers
parent0880f1f335b12cc90cc7b982bf6c028db7e2684d (diff)
downloadnixlib-bd01fad0ed2c0e9f84db55989159f425e82884e6.tar
nixlib-bd01fad0ed2c0e9f84db55989159f425e82884e6.tar.gz
nixlib-bd01fad0ed2c0e9f84db55989159f425e82884e6.tar.bz2
nixlib-bd01fad0ed2c0e9f84db55989159f425e82884e6.tar.lz
nixlib-bd01fad0ed2c0e9f84db55989159f425e82884e6.tar.xz
nixlib-bd01fad0ed2c0e9f84db55989159f425e82884e6.tar.zst
nixlib-bd01fad0ed2c0e9f84db55989159f425e82884e6.zip
Captialize meta.description of all packages
In line with the Nixpkgs manual.

A mechanical change, done with this command:

  find pkgs -name "*.nix" | \
      while read f; do \
          sed -e 's/description\s*=\s*"\([a-z]\)/description = "\u\1/' -i "$f"; \
      done

I manually skipped some:

* Descriptions starting with an abbreviation, a user name or package name
* Frequently generated expressions (haskell-packages.nix)
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/micro-httpd/default.nix2
-rw-r--r--pkgs/servers/http/mini-httpd/default.nix2
-rw-r--r--pkgs/servers/ldap/389/default.nix2
-rw-r--r--pkgs/servers/mail/petidomo/default.nix2
-rw-r--r--pkgs/servers/mail/postfix/pfixtools.nix2
-rw-r--r--pkgs/servers/mail/rspamd/default.nix2
-rw-r--r--pkgs/servers/nosql/mongodb/default.nix2
-rw-r--r--pkgs/servers/nosql/neo4j/default.nix2
-rw-r--r--pkgs/servers/squid/default.nix2
9 files changed, 9 insertions, 9 deletions
diff --git a/pkgs/servers/http/micro-httpd/default.nix b/pkgs/servers/http/micro-httpd/default.nix
index ba7c69ef7dbf..02cf49854ac8 100644
--- a/pkgs/servers/http/micro-httpd/default.nix
+++ b/pkgs/servers/http/micro-httpd/default.nix
@@ -16,7 +16,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     homepage    = "http://acme.com/software/micro_httpd/";
-    description = "a really small HTTP server";
+    description = "A really small HTTP server";
     license     = licenses.bsd2;
     platforms   = platforms.unix;
     maintainers = with maintainers; [ copumpkin ];
diff --git a/pkgs/servers/http/mini-httpd/default.nix b/pkgs/servers/http/mini-httpd/default.nix
index f35497fef8e4..20cea2708895 100644
--- a/pkgs/servers/http/mini-httpd/default.nix
+++ b/pkgs/servers/http/mini-httpd/default.nix
@@ -14,7 +14,7 @@ stdenv.mkDerivation rec {
 
   meta = {
     homepage = "http://mini-httpd.nongnu.org/";
-    description = "a minimalistic high-performance web server";
+    description = "A minimalistic high-performance web server";
     license = stdenv.lib.licenses.gpl3;
     platforms = stdenv.lib.platforms.unix;
     maintainers = [ stdenv.lib.maintainers.peti ];
diff --git a/pkgs/servers/ldap/389/default.nix b/pkgs/servers/ldap/389/default.nix
index 39667c8ba626..c5f7a45cefea 100644
--- a/pkgs/servers/ldap/389/default.nix
+++ b/pkgs/servers/ldap/389/default.nix
@@ -53,7 +53,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     homepage = https://directory.fedoraproject.org/;
-    description = "enterprise-class Open Source LDAP server for Linux";
+    description = "Enterprise-class Open Source LDAP server for Linux";
     license = licenses.gpl2;
     platforms = platforms.linux;
     maintainers = with maintainers; [ wkennington ];
diff --git a/pkgs/servers/mail/petidomo/default.nix b/pkgs/servers/mail/petidomo/default.nix
index cf8aea594325..3ecb00b64fc3 100644
--- a/pkgs/servers/mail/petidomo/default.nix
+++ b/pkgs/servers/mail/petidomo/default.nix
@@ -18,7 +18,7 @@ stdenv.mkDerivation rec {
 
   meta = {
     homepage = "http://petidomo.sourceforge.net/";
-    description = "a simple and easy to administer mailing list server";
+    description = "A simple and easy to administer mailing list server";
     license = stdenv.lib.licenses.gpl3Plus;
 
     platforms = stdenv.lib.platforms.unix;
diff --git a/pkgs/servers/mail/postfix/pfixtools.nix b/pkgs/servers/mail/postfix/pfixtools.nix
index f45dd3b7248a..c8202b35455c 100644
--- a/pkgs/servers/mail/postfix/pfixtools.nix
+++ b/pkgs/servers/mail/postfix/pfixtools.nix
@@ -41,7 +41,7 @@ stdenv.mkDerivation {
   makeFlags = "DESTDIR=$(out) prefix=";
 
   meta = {
-    description = "a collection of postfix-related tools";
+    description = "A collection of postfix-related tools";
     license = with lib.licenses; [ bsd3 ];
     homepage = https://github.com/Fruneau/pfixtools;
   };
diff --git a/pkgs/servers/mail/rspamd/default.nix b/pkgs/servers/mail/rspamd/default.nix
index 0888eb1182a0..92b529fc564c 100644
--- a/pkgs/servers/mail/rspamd/default.nix
+++ b/pkgs/servers/mail/rspamd/default.nix
@@ -33,7 +33,7 @@ stdenv.mkDerivation rec {
   meta = with stdenv.lib; {
     homepage = "https://github.com/vstakhov/rspamd";
     license = licenses.asl20;
-    description = "advanced spam filtering system";
+    description = "Advanced spam filtering system";
     maintainers = with maintainers; [ avnik fpletz ];
   };
 }
diff --git a/pkgs/servers/nosql/mongodb/default.nix b/pkgs/servers/nosql/mongodb/default.nix
index ca7e30e95e3d..127d807133e0 100644
--- a/pkgs/servers/nosql/mongodb/default.nix
+++ b/pkgs/servers/nosql/mongodb/default.nix
@@ -93,7 +93,7 @@ in stdenv.mkDerivation rec {
   enableParallelBuilding = true;
 
   meta = {
-    description = "a scalable, high-performance, open source NoSQL database";
+    description = "A scalable, high-performance, open source NoSQL database";
     homepage = http://www.mongodb.org;
     license = licenses.agpl3;
 
diff --git a/pkgs/servers/nosql/neo4j/default.nix b/pkgs/servers/nosql/neo4j/default.nix
index 91c4472e0492..f94ca52259e6 100644
--- a/pkgs/servers/nosql/neo4j/default.nix
+++ b/pkgs/servers/nosql/neo4j/default.nix
@@ -29,7 +29,7 @@ stdenv.mkDerivation rec {
   '';
 
   meta = with stdenv.lib; {
-    description = "a highly scalable, robust (fully ACID) native graph database";
+    description = "A highly scalable, robust (fully ACID) native graph database";
     homepage = "http://www.neo4j.org/";
     license = licenses.gpl3;
 
diff --git a/pkgs/servers/squid/default.nix b/pkgs/servers/squid/default.nix
index e518d063dd45..7546fe37afe5 100644
--- a/pkgs/servers/squid/default.nix
+++ b/pkgs/servers/squid/default.nix
@@ -17,7 +17,7 @@ stdenv.mkDerivation rec {
   ];
 
   meta = {
-    description = "a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more";
+    description = "A caching proxy for the Web supporting HTTP, HTTPS, FTP, and more";
     homepage = "http://www.squid-cache.org";
     license = stdenv.lib.licenses.gpl2;
   };