about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2013-11-23 10:22:26 +0100
committerVladimír Čunát <vcunat@gmail.com>2013-11-23 10:22:26 +0100
commitb5fba4714713ec2f653f500a341369c4cb339e1d (patch)
treea956208c311014618ffbad535070673c550f5352 /pkgs/servers
parent0d4d1097cbf7f6d58c75c3a1cc6be00aa9de838b (diff)
parenta7675b2aae455f24e828473ea2eb9b32ccb0b824 (diff)
downloadnixlib-b5fba4714713ec2f653f500a341369c4cb339e1d.tar
nixlib-b5fba4714713ec2f653f500a341369c4cb339e1d.tar.gz
nixlib-b5fba4714713ec2f653f500a341369c4cb339e1d.tar.bz2
nixlib-b5fba4714713ec2f653f500a341369c4cb339e1d.tar.lz
nixlib-b5fba4714713ec2f653f500a341369c4cb339e1d.tar.xz
nixlib-b5fba4714713ec2f653f500a341369c4cb339e1d.tar.zst
nixlib-b5fba4714713ec2f653f500a341369c4cb339e1d.zip
Merge branch master into x-updates
Conflicts (not used, deleted):
	pkgs/desktops/xfce/common.nix
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/lighttpd/default.nix10
-rw-r--r--pkgs/servers/http/nginx/default.nix17
-rw-r--r--pkgs/servers/mpd/default.nix6
3 files changed, 22 insertions, 11 deletions
diff --git a/pkgs/servers/http/lighttpd/default.nix b/pkgs/servers/http/lighttpd/default.nix
index 61070ef22b6e..0da9f05901db 100644
--- a/pkgs/servers/http/lighttpd/default.nix
+++ b/pkgs/servers/http/lighttpd/default.nix
@@ -4,12 +4,12 @@
 
 assert enableMagnet -> lua5 != null;
 
-stdenv.mkDerivation {
-  name = "lighttpd-1.4.32";
+stdenv.mkDerivation rec {
+  name = "lighttpd-1.4.33";
 
   src = fetchurl {
-    url = http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-1.4.32.tar.xz;
-    sha256 = "1hgd9bi4mrak732h57na89lqg58b1kkchnddij9gawffd40ghs0k";
+    url = "http://download.lighttpd.net/lighttpd/releases-1.4.x/${name}.tar.xz";
+    sha256 = "0331671snhhf48qb43mfb6l85v2rc3ryd3qvz56s8z454gfax1i8";
   };
 
   buildInputs = [ pkgconfig pcre libxml2 zlib attr bzip2 which file openssl ]
@@ -27,6 +27,6 @@ stdenv.mkDerivation {
     homepage = http://www.lighttpd.net/;
     license = "BSD";
     platforms = platforms.linux;
-    maintainers = [maintainers.bjornfor];
+    maintainers = [ maintainers.bjornfor ];
   };
 }
diff --git a/pkgs/servers/http/nginx/default.nix b/pkgs/servers/http/nginx/default.nix
index 28390aa38da0..f6f4415e806d 100644
--- a/pkgs/servers/http/nginx/default.nix
+++ b/pkgs/servers/http/nginx/default.nix
@@ -1,6 +1,15 @@
-{ stdenv, fetchurl, fetchgit, openssl, zlib, pcre, libxml2, libxslt, expat, fullWebDAV ? false, syslog ? false }:
+{ stdenv, fetchurl, fetchgit, openssl, zlib, pcre, libxml2, libxslt, expat
+, rtmp ? false
+, fullWebDAV ? false
+, syslog ? false}:
 
 let
+  rtmp-ext = fetchgit {
+    url = git://github.com/arut/nginx-rtmp-module.git;
+    rev = "1cfb7aeb582789f3b15a03da5b662d1811e2a3f1";
+    sha256 = "03ikfd2l8mzsjwx896l07rdrw5jn7jjfdiyl572yb9jfrnk48fwi";
+  };
+
   dav-ext = fetchgit {
     url = git://github.com/arut/nginx-dav-ext-module.git;
     rev = "54cebc1f21fc13391aae692c6cce672fa7986f9d";
@@ -22,7 +31,8 @@ stdenv.mkDerivation rec {
     sha256 = "116yfy0k65mwxdkld0w7c3gly77jdqlvga5hpbsw79i3r62kh4mf";
   };
 
-  buildInputs = [ openssl zlib pcre libxml2 libxslt ] ++ stdenv.lib.optional fullWebDAV expat;
+  buildInputs = [ openssl zlib pcre libxml2 libxslt
+    ] ++ stdenv.lib.optional fullWebDAV expat;
 
   patches = if syslog then [ "${syslog-ext}/syslog_1.4.0.patch" ] else [];
 
@@ -35,7 +45,8 @@ stdenv.mkDerivation rec {
     "--with-http_secure_link_module"
     # Install destination problems
     # "--with-http_perl_module"
-  ] ++ stdenv.lib.optional fullWebDAV "--add-module=${dav-ext}"
+  ] ++ stdenv.lib.optional rtmp "--add-module=${rtmp-ext}"
+    ++ stdenv.lib.optional fullWebDAV "--add-module=${dav-ext}"
     ++ stdenv.lib.optional syslog "--add-module=${syslog-ext}";
 
   preConfigure = ''
diff --git a/pkgs/servers/mpd/default.nix b/pkgs/servers/mpd/default.nix
index 238176aadff9..67a11e01651a 100644
--- a/pkgs/servers/mpd/default.nix
+++ b/pkgs/servers/mpd/default.nix
@@ -27,10 +27,10 @@ let
   mkFlag = c: f: if c then "--enable-${f}" else "--disable-${f}";
 
 in stdenv.mkDerivation rec {
-  name = "mpd-0.17.4";
+  name = "mpd-0.18.3";
   src = fetchurl {
-    url = "http://www.musicpd.org/download/mpd/stable/${name}.tar.gz";
-    sha256 = "06diyprg65xx0c0bgxdwlgrc5bhwy6cf39rabwnv9ikhimh94ir3";
+    url    = "http://www.musicpd.org/download/mpd/stable/${name}.tar.gz";
+    sha256 = "177h23vqa59lm1fid883z9y5qn7kfb57yda6p44zva5hh85xczgh";
   };
 
   buildInputs = [ pkgconfig glib ]