about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2014-11-14 14:28:23 +0100
committerVladimír Čunát <vcunat@gmail.com>2014-11-14 14:28:23 +0100
commitb4af993c3f2a2e9808b582eb6dd4500a2847fb2b (patch)
tree6a4d51255f30e0da26fb94d4725b6c19145bb89d /pkgs/servers
parent5ad9db047327b74a4002341f074369ee736e4f9e (diff)
parent961ed7c8b41bb80cdf5f4f0f5e49093ad171393b (diff)
downloadnixlib-b4af993c3f2a2e9808b582eb6dd4500a2847fb2b.tar
nixlib-b4af993c3f2a2e9808b582eb6dd4500a2847fb2b.tar.gz
nixlib-b4af993c3f2a2e9808b582eb6dd4500a2847fb2b.tar.bz2
nixlib-b4af993c3f2a2e9808b582eb6dd4500a2847fb2b.tar.lz
nixlib-b4af993c3f2a2e9808b582eb6dd4500a2847fb2b.tar.xz
nixlib-b4af993c3f2a2e9808b582eb6dd4500a2847fb2b.tar.zst
nixlib-b4af993c3f2a2e9808b582eb6dd4500a2847fb2b.zip
Merge branch 'master' into staging
Conflicts (simple):
	pkgs/development/lisp-modules/clwrapper/setup-hook.sh
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/zeromq/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/servers/zeromq/default.nix b/pkgs/servers/zeromq/default.nix
new file mode 100644
index 000000000000..15d453321fb9
--- /dev/null
+++ b/pkgs/servers/zeromq/default.nix
@@ -0,0 +1,29 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "zeromq";
+  version = "4.1.0-rc1";
+
+  src = fetchurl {
+    url = "http://download.zeromq.org/${name}-${version}.tar.gz";
+    sha256 = "e8e6325abe2ede0a9fb3d1abbe425d8a7911f6ac283652ee49b36afbb0164d60";
+  };
+
+  doCheck = true;
+
+  meta = {
+    description = "0MQ is a lightweight messaging kernel";
+    longDescription = ''
+      The 0MQ lightweight messaging kernel is a library which extends
+      the standard socket interfaces with features traditionally provided
+      by specialised messaging middleware products. 0MQ sockets provide
+      an abstraction of asynchronous message queues, multiple messaging patterns,
+      message filtering (subscriptions), seamless access to multiple transport protocols
+      and more.
+    '';
+    homepage = http://zeromq.org/;
+    license = stdenv.lib.licenses.gpl3;
+    maintainers = [ stdenv.lib.maintainers.gavin ];
+    platforms = stdenv.lib.platforms.all;
+  };
+}