about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorAdam Joseph <adam@westernsemico.com>2022-02-20 23:16:10 -0800
committerAdam Joseph <adam@westernsemico.com>2022-03-31 16:04:49 -0700
commitaeb47faee2a3592b2c75e1a10c21146cfcf61a76 (patch)
tree7737576f456f24dfc0cfb98cda370798c44a6f89 /pkgs/servers
parent6d9ad3ba4a87e0e02acc658440b1647f4b6b1652 (diff)
downloadnixlib-aeb47faee2a3592b2c75e1a10c21146cfcf61a76.tar
nixlib-aeb47faee2a3592b2c75e1a10c21146cfcf61a76.tar.gz
nixlib-aeb47faee2a3592b2c75e1a10c21146cfcf61a76.tar.bz2
nixlib-aeb47faee2a3592b2c75e1a10c21146cfcf61a76.tar.lz
nixlib-aeb47faee2a3592b2c75e1a10c21146cfcf61a76.tar.xz
nixlib-aeb47faee2a3592b2c75e1a10c21146cfcf61a76.tar.zst
nixlib-aeb47faee2a3592b2c75e1a10c21146cfcf61a76.zip
dante: skip configure-time getaddrinfo-too-low check on mips64
This patch allows dante to be compiled (and cross-compiled) for mips64el.

Co-authored-by: John Ericson <git@JohnEricson.me>
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/dante/default.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/pkgs/servers/dante/default.nix b/pkgs/servers/dante/default.nix
index 1ed03f0e3d5a..12ba281d811c 100644
--- a/pkgs/servers/dante/default.nix
+++ b/pkgs/servers/dante/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, fetchurl, pam, libkrb5, cyrus_sasl, miniupnpc }:
+{ lib, stdenv, fetchurl, fetchpatch, pam, libkrb5, cyrus_sasl, miniupnpc, autoreconfHook }:
 
 stdenv.mkDerivation rec {
   pname = "dante";
@@ -9,6 +9,7 @@ stdenv.mkDerivation rec {
     sha256 = "0pbahkj43rx7rmv2x40mf5p3g3x9d6i2sz7pzglarf54w5ghd2j1";
   };
 
+  nativeBuildInputs = lib.optional stdenv.hostPlatform.isMips64 autoreconfHook;
   buildInputs = [ pam libkrb5 cyrus_sasl miniupnpc ];
 
   configureFlags = if !stdenv.isDarwin
@@ -17,6 +18,13 @@ stdenv.mkDerivation rec {
 
   dontAddDisableDepTrack = stdenv.isDarwin;
 
+  patches = lib.optional stdenv.hostPlatform.isMips64 [
+    (fetchpatch {
+      name = "0002-osdep-m4-Remove-getaddrinfo-too-low-checks.patch";
+      url = "https://raw.githubusercontent.com/buildroot/buildroot/master/package/dante/0002-osdep-m4-Remove-getaddrinfo-too-low-checks.patch";
+      sha256 = "sha256-e+qF8lB5tkiA7RlJ+tX5O6KxQrQp33RSPdP1TxU961Y=";
+    }) ];
+
   meta = with lib; {
     description = "A circuit-level SOCKS client/server that can be used to provide convenient and secure network connectivity";
     homepage    = "https://www.inet.no/dante/";