about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2020-12-20 18:19:51 +0000
committerGitHub <noreply@github.com>2020-12-20 18:19:51 +0000
commitab8c2b2b2ca6579104f5692ead859db31030de35 (patch)
tree2fc2406db6786048c8f2a9ad64f205c5544616ae /pkgs/servers
parent92db8d3c2679636849c523d5e5a4a405637731e2 (diff)
parent5f04cf274984c76439ba8ed5998593b2e5a5ef7a (diff)
downloadnixlib-ab8c2b2b2ca6579104f5692ead859db31030de35.tar
nixlib-ab8c2b2b2ca6579104f5692ead859db31030de35.tar.gz
nixlib-ab8c2b2b2ca6579104f5692ead859db31030de35.tar.bz2
nixlib-ab8c2b2b2ca6579104f5692ead859db31030de35.tar.lz
nixlib-ab8c2b2b2ca6579104f5692ead859db31030de35.tar.xz
nixlib-ab8c2b2b2ca6579104f5692ead859db31030de35.tar.zst
nixlib-ab8c2b2b2ca6579104f5692ead859db31030de35.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/monitoring/fusion-inventory/default.nix23
-rw-r--r--pkgs/servers/monitoring/fusion-inventory/remove_software_test.patch67
-rw-r--r--pkgs/servers/sql/postgresql/ext/postgis.nix4
3 files changed, 8 insertions, 86 deletions
diff --git a/pkgs/servers/monitoring/fusion-inventory/default.nix b/pkgs/servers/monitoring/fusion-inventory/default.nix
index 42b07e605a0b..a7d2da6ac570 100644
--- a/pkgs/servers/monitoring/fusion-inventory/default.nix
+++ b/pkgs/servers/monitoring/fusion-inventory/default.nix
@@ -1,32 +1,18 @@
-{ stdenv, lib, fetchurl, perlPackages, nix, dmidecode, pciutils, usbutils, iproute, nettools
+{ stdenv, lib, perlPackages, nix, dmidecode, pciutils, usbutils, iproute, nettools
 , fetchFromGitHub, makeWrapper
 }:
 
 perlPackages.buildPerlPackage rec {
   pname = "FusionInventory-Agent";
-  version = "2.3.21";
+  version = "2.6";
 
   src = fetchFromGitHub {
     owner = "fusioninventory";
     repo = "fusioninventory-agent";
     rev = version;
-    sha256 = "034clffcn0agx85macjgml4lyhvvck7idn94pqd2c77pk6crvw2y";
+    sha256 = "1hbp5a9m03n6a80xc8z640zs71qhqk4ifafr6fp0vvzzvq097ip2";
   };
 
-  patches = [
-    ./remove_software_test.patch
-    # support for os-release file
-    (fetchurl {
-      url = "https://github.com/fusioninventory/fusioninventory-agent/pull/396.diff";
-      sha256 = "0bxrjmff80ab01n23xggci32ajsah6zvcmz5x4hj6ayy6dzwi6jb";
-    })
-    # support for Nix software inventory
-    (fetchurl {
-      url = "https://github.com/fusioninventory/fusioninventory-agent/pull/397.diff";
-      sha256 = "0pyf7mp0zsb3zcqb6yysr1zfp54p9ciwjn1pzayw6s9flmcgrmbw";
-    })
-    ];
-
   postPatch = ''
 
     patchShebangs bin
@@ -68,6 +54,9 @@ perlPackages.buildPerlPackage rec {
     XMLTreePP
   ];
 
+  # Test fails due to "Argument list too long"
+  doCheck = false;
+
   installPhase = ''
     mkdir -p $out
 
diff --git a/pkgs/servers/monitoring/fusion-inventory/remove_software_test.patch b/pkgs/servers/monitoring/fusion-inventory/remove_software_test.patch
deleted file mode 100644
index b360f418aa0b..000000000000
--- a/pkgs/servers/monitoring/fusion-inventory/remove_software_test.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff --git a/t/agent/snmp/live.t b/t/agent/snmp/live.t
-index 8ee7ff02c..bd5551ab3 100755
---- a/t/agent/snmp/live.t
-+++ b/t/agent/snmp/live.t
-@@ -11,7 +11,7 @@ use Test::More;
- use FusionInventory::Agent::XML::Response;
- use FusionInventory::Agent::SNMP::Live;
- 
--plan tests => 12;
-+plan tests => 11;
- 
- my $snmp;
- throws_ok {
-@@ -52,15 +52,6 @@ throws_ok {
- } qr/^Unable to resolve the UDP\/IPv4 address "none"/,
- 'instanciation: unresolvable host';
- 
--throws_ok {
--    $snmp = FusionInventory::Agent::SNMP::Live->new(
--        version   => 1,
--        community => 'public',
--        hostname  => '1.1.1.1'
--    );
--} qr/no response from host 1.1.1.1/,
--'instanciation: unresponding host';
--
- SKIP: {
- skip 'live SNMP test disabled', 6 unless $ENV{TEST_LIVE_SNMP};
- 
-diff --git a/t/apps/agent.t b/t/apps/agent.t
-index c0f6fc52f..c83837d70 100755
---- a/t/apps/agent.t
-+++ b/t/apps/agent.t
-@@ -12,7 +12,7 @@ use XML::TreePP;
- use FusionInventory::Agent::Tools;
- use FusionInventory::Test::Utils;
- 
--plan tests => 34;
-+plan tests => 33;
- 
- my ($content, $out, $err, $rc);
- 
-@@ -71,11 +71,6 @@ subtest "first inventory execution and content" => sub {
-     check_content_ok($out);
- };
- 
--ok(
--    exists $content->{REQUEST}->{CONTENT}->{SOFTWARES},
--    'inventory has software'
--);
--
- ok(
-     exists $content->{REQUEST}->{CONTENT}->{ENVS},
-     'inventory has environment variables'
-diff --git a/t/tasks/inventory/linux/softwares.t b/t/tasks/inventory/linux/softwares.t
-index 72a0e578c..13944f34f 100755
---- a/t/tasks/inventory/linux/softwares.t
-+++ b/t/tasks/inventory/linux/softwares.t
-@@ -89,7 +89,7 @@ my $rpm_packages = [
-         PUBLISHER   => 'Mageia.Org',
-         NAME        => 'xfsprogs',
-         COMMENTS    => 'Utilities for managing the XFS filesystem',
--        INSTALLDATE => '25/03/2012',
-+        INSTALLDATE => '24/03/2012',
-         FILESIZE    => '3628382',
-         FROM        => 'rpm',
-         ARCH        => 'x86_64',
diff --git a/pkgs/servers/sql/postgresql/ext/postgis.nix b/pkgs/servers/sql/postgresql/ext/postgis.nix
index 0d6176d85971..fdf4b40d3b06 100644
--- a/pkgs/servers/sql/postgresql/ext/postgis.nix
+++ b/pkgs/servers/sql/postgresql/ext/postgis.nix
@@ -15,13 +15,13 @@
 }:
 stdenv.mkDerivation rec {
   pname = "postgis";
-  version = "3.0.3";
+  version = "3.1.0";
 
   outputs = [ "out" "doc" ];
 
   src = fetchurl {
     url = "https://download.osgeo.org/postgis/source/postgis-${version}.tar.gz";
-    sha256 = "05s8cx1rlysiq7dd44kf7cid0la61a4p895j9g95bvfb8v8dpzh7";
+    sha256 = "008280ijd6m9h35y9lcpql0fk0h9f3zkc1pfkdm0rkbnd12y41ns";
   };
 
   buildInputs = [ libxml2 postgresql geos proj gdal json_c protobufc ]