about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-12-19 09:00:36 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2018-12-19 09:00:36 +0100
commit9ab61ab8e2c5b7a40f2f0f8a044e6c8d15d10158 (patch)
treeec26979beba499c597f55768464697f20729a96e /pkgs/servers
parentdb0211c6bc16827a7bcc23f807c6b3703b1452a5 (diff)
parent911d1853ca990a7af6725105e7cda8c24cac025f (diff)
downloadnixlib-9ab61ab8e2c5b7a40f2f0f8a044e6c8d15d10158.tar
nixlib-9ab61ab8e2c5b7a40f2f0f8a044e6c8d15d10158.tar.gz
nixlib-9ab61ab8e2c5b7a40f2f0f8a044e6c8d15d10158.tar.bz2
nixlib-9ab61ab8e2c5b7a40f2f0f8a044e6c8d15d10158.tar.lz
nixlib-9ab61ab8e2c5b7a40f2f0f8a044e6c8d15d10158.tar.xz
nixlib-9ab61ab8e2c5b7a40f2f0f8a044e6c8d15d10158.tar.zst
nixlib-9ab61ab8e2c5b7a40f2f0f8a044e6c8d15d10158.zip
Merge staging-next into staging
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/dns/knot-resolver/default.nix4
-rw-r--r--pkgs/servers/home-assistant/component-packages.nix23
-rw-r--r--pkgs/servers/home-assistant/default.nix10
-rw-r--r--pkgs/servers/home-assistant/frontend.nix4
-rw-r--r--pkgs/servers/jackett/default.nix4
-rw-r--r--pkgs/servers/misc/subsonic/default.nix18
-rw-r--r--pkgs/servers/monitoring/cadvisor/default.nix4
-rw-r--r--pkgs/servers/monitoring/prometheus/default.nix4
-rw-r--r--pkgs/servers/osrm-backend/default.nix4
-rw-r--r--pkgs/servers/radarr/default.nix10
-rw-r--r--pkgs/servers/search/groonga/default.nix4
-rw-r--r--pkgs/servers/sip/freeswitch/default.nix9
-rw-r--r--pkgs/servers/sql/postgresql/default.nix2
-rw-r--r--pkgs/servers/xmpp/prosody/default.nix4
14 files changed, 63 insertions, 41 deletions
diff --git a/pkgs/servers/dns/knot-resolver/default.nix b/pkgs/servers/dns/knot-resolver/default.nix
index ceefa542e6a4..b4768f32bf16 100644
--- a/pkgs/servers/dns/knot-resolver/default.nix
+++ b/pkgs/servers/dns/knot-resolver/default.nix
@@ -12,11 +12,11 @@ inherit (stdenv.lib) optional concatStringsSep;
 
 unwrapped = stdenv.mkDerivation rec {
   name = "knot-resolver-${version}";
-  version = "3.1.0";
+  version = "3.2.0";
 
   src = fetchurl {
     url = "https://secure.nic.cz/files/knot-resolver/${name}.tar.xz";
-    sha256 = "8f3deba4695784a666cde317bc6af80ecf42ce1047b01f4b9c582fdc021c7492";
+    sha256 = "924f1aebad04cacbc4545571239914d2c42e9253784c0df0f391dfad97c59f42";
   };
 
   outputs = [ "out" "dev" ];
diff --git a/pkgs/servers/home-assistant/component-packages.nix b/pkgs/servers/home-assistant/component-packages.nix
index 30fe7354f65b..b34355c88b63 100644
--- a/pkgs/servers/home-assistant/component-packages.nix
+++ b/pkgs/servers/home-assistant/component-packages.nix
@@ -2,7 +2,7 @@
 # Do not edit!
 
 {
-  version = "0.83.3";
+  version = "0.84.3";
   components = {
     "abode" = ps: with ps; [  ];
     "ads" = ps: with ps; [  ];
@@ -264,6 +264,8 @@
     "climate.zwave" = ps: with ps; [  ];
     "cloud" = ps: with ps; [ aiohttp-cors warrant ];
     "cloud.auth_api" = ps: with ps; [  ];
+    "cloud.cloud_api" = ps: with ps; [  ];
+    "cloud.cloudhooks" = ps: with ps; [  ];
     "cloud.const" = ps: with ps; [  ];
     "cloud.http_api" = ps: with ps; [  ];
     "cloud.iot" = ps: with ps; [  ];
@@ -438,6 +440,7 @@
     "geo_location.demo" = ps: with ps; [  ];
     "geo_location.geo_json_events" = ps: with ps; [  ];
     "geo_location.nsw_rural_fire_service_feed" = ps: with ps; [  ];
+    "geo_location.usgs_earthquakes_feed" = ps: with ps; [  ];
     "geofency" = ps: with ps; [ aiohttp-cors ];
     "goalfeed" = ps: with ps; [  ];
     "google" = ps: with ps; [ google_api_python_client httplib2 oauth2client ];
@@ -467,6 +470,7 @@
     "history" = ps: with ps; [ aiohttp-cors sqlalchemy ];
     "history_graph" = ps: with ps; [ aiohttp-cors sqlalchemy ];
     "hive" = ps: with ps; [  ];
+    "hlk_sw16" = ps: with ps; [  ];
     "homekit" = ps: with ps; [  ];
     "homekit.const" = ps: with ps; [  ];
     "homekit.util" = ps: with ps; [  ];
@@ -564,6 +568,7 @@
     "light.knx" = ps: with ps; [  ];
     "light.lifx" = ps: with ps; [  ];
     "light.lifx_legacy" = ps: with ps; [  ];
+    "light.lightwave" = ps: with ps; [  ];
     "light.limitlessled" = ps: with ps; [  ];
     "light.litejet" = ps: with ps; [  ];
     "light.lutron" = ps: with ps; [  ];
@@ -571,8 +576,6 @@
     "light.lw12wifi" = ps: with ps; [  ];
     "light.mochad" = ps: with ps; [  ];
     "light.mqtt" = ps: with ps; [ paho-mqtt ];
-    "light.mqtt_json" = ps: with ps; [ paho-mqtt ];
-    "light.mqtt_template" = ps: with ps; [ paho-mqtt ];
     "light.mysensors" = ps: with ps; [  ];
     "light.mystrom" = ps: with ps; [  ];
     "light.nanoleaf_aurora" = ps: with ps; [ nanoleaf ];
@@ -608,6 +611,7 @@
     "light.zha" = ps: with ps; [  ];
     "light.zigbee" = ps: with ps; [  ];
     "light.zwave" = ps: with ps; [  ];
+    "lightwave" = ps: with ps; [  ];
     "linode" = ps: with ps; [ linode-api ];
     "lirc" = ps: with ps; [  ];
     "litejet" = ps: with ps; [  ];
@@ -770,7 +774,6 @@
     "notify.hipchat" = ps: with ps; [  ];
     "notify.homematic" = ps: with ps; [ pyhomematic ];
     "notify.html5" = ps: with ps; [ aiohttp-cors ];
-    "notify.instapush" = ps: with ps; [  ];
     "notify.ios" = ps: with ps; [ aiohttp-cors zeroconf ];
     "notify.joaoapps_join" = ps: with ps; [  ];
     "notify.knx" = ps: with ps; [  ];
@@ -866,6 +869,7 @@
     "scene" = ps: with ps; [  ];
     "scene.deconz" = ps: with ps; [  ];
     "scene.elkm1" = ps: with ps; [  ];
+    "scene.fibaro" = ps: with ps; [  ];
     "scene.homeassistant" = ps: with ps; [  ];
     "scene.hunterdouglas_powerview" = ps: with ps; [  ];
     "scene.knx" = ps: with ps; [  ];
@@ -896,6 +900,7 @@
     "sensor.arlo" = ps: with ps; [  ];
     "sensor.arwn" = ps: with ps; [ paho-mqtt ];
     "sensor.asuswrt" = ps: with ps; [  ];
+    "sensor.awair" = ps: with ps; [  ];
     "sensor.bbox" = ps: with ps; [  ];
     "sensor.bh1750" = ps: with ps; [  ];
     "sensor.bitcoin" = ps: with ps; [  ];
@@ -948,6 +953,7 @@
     "sensor.emoncms" = ps: with ps; [  ];
     "sensor.enocean" = ps: with ps; [  ];
     "sensor.enphase_envoy" = ps: with ps; [  ];
+    "sensor.entur_public_transport" = ps: with ps; [  ];
     "sensor.envirophat" = ps: with ps; [  ];
     "sensor.envisalink" = ps: with ps; [  ];
     "sensor.etherscan" = ps: with ps; [  ];
@@ -1066,6 +1072,7 @@
     "sensor.pushbullet" = ps: with ps; [ pushbullet ];
     "sensor.pvoutput" = ps: with ps; [  ];
     "sensor.pyload" = ps: with ps; [  ];
+    "sensor.qbittorrent" = ps: with ps; [  ];
     "sensor.qnap" = ps: with ps; [  ];
     "sensor.qwikswitch" = ps: with ps; [  ];
     "sensor.radarr" = ps: with ps; [  ];
@@ -1235,6 +1242,7 @@
     "switch.hdmi_cec" = ps: with ps; [  ];
     "switch.hikvisioncam" = ps: with ps; [  ];
     "switch.hive" = ps: with ps; [  ];
+    "switch.hlk_sw16" = ps: with ps; [  ];
     "switch.homekit_controller" = ps: with ps; [  ];
     "switch.homematic" = ps: with ps; [ pyhomematic ];
     "switch.homematicip_cloud" = ps: with ps; [  ];
@@ -1246,6 +1254,7 @@
     "switch.kankun" = ps: with ps; [  ];
     "switch.knx" = ps: with ps; [  ];
     "switch.konnected" = ps: with ps; [ aiohttp-cors netdisco ];
+    "switch.lightwave" = ps: with ps; [  ];
     "switch.linode" = ps: with ps; [ linode-api ];
     "switch.litejet" = ps: with ps; [  ];
     "switch.lupusec" = ps: with ps; [  ];
@@ -1319,6 +1328,8 @@
     "telegram_bot.polling" = ps: with ps; [  ];
     "telegram_bot.webhooks" = ps: with ps; [ aiohttp-cors ];
     "tellduslive" = ps: with ps; [  ];
+    "tellduslive.const" = ps: with ps; [  ];
+    "tellduslive.entry" = ps: with ps; [  ];
     "tellstick" = ps: with ps; [  ];
     "tesla" = ps: with ps; [  ];
     "thethingsnetwork" = ps: with ps; [  ];
@@ -1402,11 +1413,15 @@
     "wemo" = ps: with ps; [  ];
     "wink" = ps: with ps; [  ];
     "wirelesstag" = ps: with ps; [  ];
+    "wunderlist" = ps: with ps; [  ];
     "xiaomi_aqara" = ps: with ps; [  ];
     "zabbix" = ps: with ps; [  ];
     "zeroconf" = ps: with ps; [ aiohttp-cors zeroconf ];
     "zha" = ps: with ps; [  ];
+    "zha.config_flow" = ps: with ps; [  ];
     "zha.const" = ps: with ps; [  ];
+    "zha.entities" = ps: with ps; [  ];
+    "zha.helpers" = ps: with ps; [  ];
     "zigbee" = ps: with ps; [  ];
     "zone" = ps: with ps; [  ];
     "zone.config_flow" = ps: with ps; [  ];
diff --git a/pkgs/servers/home-assistant/default.nix b/pkgs/servers/home-assistant/default.nix
index 88b824530631..68bb42f51fbc 100644
--- a/pkgs/servers/home-assistant/default.nix
+++ b/pkgs/servers/home-assistant/default.nix
@@ -36,8 +36,8 @@ let
       "bf4d9b61dce69c49e830950aa36fad194706463b0b6dfe81425b9e0bc6644d46")
     (mkOverride "requests" "2.20.1"
       "ea881206e59f41dbd0bd445437d792e43906703fff75ca8ff43ccdb11f33f263")
-    (mkOverride "ruamel_yaml" "0.15.78"
-      "85793c5fe321e9202eba521b0bb3e6303bcb61f6e56378f59e874ca36a7e9d5f")
+    (mkOverride "ruamel_yaml" "0.15.80"
+      "4f203351575dba0829c7b1e5d376d08cf5f58e4a2b844e8ce552b3e41cd414e6")
     (mkOverride "voluptuous" "0.11.5"
       "567a56286ef82a9d7ae0628c5842f65f516abcb496e74f3f59f1d7b28df314ef")
     (mkOverride "voluptuous-serialize" "2.0.0"
@@ -85,7 +85,7 @@ let
   extraBuildInputs = extraPackages py.pkgs;
 
   # Don't forget to run parse-requirements.py after updating
-  hassVersion = "0.83.3";
+  hassVersion = "0.84.3";
 
 in with py.pkgs; buildPythonApplication rec {
   pname = "homeassistant";
@@ -100,7 +100,7 @@ in with py.pkgs; buildPythonApplication rec {
     owner = "home-assistant";
     repo = "home-assistant";
     rev = version;
-    sha256 = "1lv9ixv0qd97xpcpb9zzhn82jsgiq4kmcfnfraksq60xwzzqkwar";
+    sha256 = "0b7634niqqmcckhqb7vx1wimibfs4v042bwja7am90jy0hzafbji";
   };
 
   propagatedBuildInputs = [
@@ -111,7 +111,7 @@ in with py.pkgs; buildPythonApplication rec {
   ] ++ componentBuildInputs ++ extraBuildInputs;
 
   checkInputs = [
-    pytest requests-mock pydispatcher pytest-aiohttp
+    asynctest pytest pytest-aiohttp requests-mock pydispatcher
   ];
 
   checkPhase = ''
diff --git a/pkgs/servers/home-assistant/frontend.nix b/pkgs/servers/home-assistant/frontend.nix
index 1695a6eb95d6..0e1b327a2646 100644
--- a/pkgs/servers/home-assistant/frontend.nix
+++ b/pkgs/servers/home-assistant/frontend.nix
@@ -2,11 +2,11 @@
 
 buildPythonPackage rec {
   pname = "home-assistant-frontend";
-  version = "20181121.1";
+  version = "20181211.1";
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "9cedc4dc4258823b084b9d7634995ab038be109fea4c087e38412b9ef1cb6433";
+    sha256 = "c3bb994e8e121d146fedc113b35ced0c007169fd70b489e9344df082f934dbdf";
   };
 
   propagatedBuildInputs = [ user-agents ];
diff --git a/pkgs/servers/jackett/default.nix b/pkgs/servers/jackett/default.nix
index b33285384960..41da87d4065c 100644
--- a/pkgs/servers/jackett/default.nix
+++ b/pkgs/servers/jackett/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "jackett-${version}";
-  version = "0.10.471";
+  version = "0.10.504";
 
   src = fetchurl {
     url = "https://github.com/Jackett/Jackett/releases/download/v${version}/Jackett.Binaries.Mono.tar.gz";
-    sha256 = "0la05akvpvfg9jdgfd39wnc87zi7axzx7499w9m3py7qqqyvgyin";
+    sha256 = "1nqci6a9is0kf0vn8wlbfbynllf0pkndcb1z49d1n3wwc8dhji86";
   };
 
   buildInputs = [ makeWrapper ];
diff --git a/pkgs/servers/misc/subsonic/default.nix b/pkgs/servers/misc/subsonic/default.nix
index f546b0b075e5..50e754791e6d 100644
--- a/pkgs/servers/misc/subsonic/default.nix
+++ b/pkgs/servers/misc/subsonic/default.nix
@@ -1,14 +1,12 @@
 { stdenv, fetchurl, jre }:
 
-let version = "6.1.3"; in
-
 stdenv.mkDerivation rec {
   name = "subsonic-${version}";
-  inherit version;
+  version = "6.1.5";
 
   src = fetchurl {
     url = "mirror://sourceforge/subsonic/subsonic-${version}-standalone.tar.gz";
-    sha256 = "1v21gfymaqcx6n6d88hvha60q9hgj5z1wsac5gcwq7cjah1893jx";
+    sha256 = "1xz3flxd5hxcvvg1izzxpv5rxwb5zprk92vsgvmcniy7j7r66936";
   };
 
   inherit jre;
@@ -16,20 +14,24 @@ stdenv.mkDerivation rec {
   # Create temporary directory to extract tarball into to satisfy Nix's need
   # for a directory to be created in the unpack phase.
   unpackPhase = ''
+    runHook preUnpack
     mkdir ${name}
     tar -C ${name} -xzf $src
+    runHook postUnpack
   '';
   installPhase = ''
+    runHook preInstall
     mkdir $out
     cp -r ${name}/* $out
+    runHook postInstall
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://subsonic.org;
     description = "Personal media streamer";
-    license = stdenv.lib.licenses.gpl3;
-    maintainers = with stdenv.lib.maintainers; [ telotortium ];
-    platforms = with stdenv.lib.platforms; unix;
+    license = licenses.unfree;
+    maintainers = with maintainers; [ telotortium ];
+    platforms = platforms.unix;
   };
 
   phases = ["unpackPhase" "installPhase"];
diff --git a/pkgs/servers/monitoring/cadvisor/default.nix b/pkgs/servers/monitoring/cadvisor/default.nix
index dd56bc89c0d0..ff0c926de595 100644
--- a/pkgs/servers/monitoring/cadvisor/default.nix
+++ b/pkgs/servers/monitoring/cadvisor/default.nix
@@ -2,13 +2,13 @@
 
 stdenv.mkDerivation rec {
   name = "cadvisor-${version}";
-  version = "0.31.0";
+  version = "0.32.0";
 
   src = fetchFromGitHub {
     owner = "google";
     repo = "cadvisor";
     rev = "v${version}";
-    sha256 = "0dnn2vgjbbb82kvbmgrfq0hqwfk0jh5gc3xrcfqwvvq673yf4f2m";
+    sha256 = "1li2qgfi4lfa2i1m7ykjxy1xm9hlq42fgdkb2wh2db9chyg5r4qp";
   };
 
   nativeBuildInputs = [ go ];
diff --git a/pkgs/servers/monitoring/prometheus/default.nix b/pkgs/servers/monitoring/prometheus/default.nix
index 2430a8cf1711..03080376ec2a 100644
--- a/pkgs/servers/monitoring/prometheus/default.nix
+++ b/pkgs/servers/monitoring/prometheus/default.nix
@@ -50,7 +50,7 @@ in rec {
   };
 
   prometheus_2 = generic {
-    version = "2.4.3";
-    sha256 = "1kci2zhh4ixil0b72d138vm8006y117mw51wsyz8j0gyy4180msj";
+    version = "2.6.0";
+    sha256 = "1d9zwzs280pw9zspqwp7xx3ji04lfg2v9l5qhrfy3y633ghcmpxz";
   };
 }
diff --git a/pkgs/servers/osrm-backend/default.nix b/pkgs/servers/osrm-backend/default.nix
index 97612f656cbc..4e43fffb1966 100644
--- a/pkgs/servers/osrm-backend/default.nix
+++ b/pkgs/servers/osrm-backend/default.nix
@@ -2,13 +2,13 @@
 
 stdenv.mkDerivation rec {
   name = "osrm-backend-${version}";
-  version = "5.19.0";
+  version = "5.20.0";
 
   src = fetchFromGitHub {
     rev = "v${version}";
     owner  = "Project-OSRM";
     repo   = "osrm-backend";
-    sha256 = "1y3k2j4c3jparzm9ck1jkw5g12jr6kd9llq50jran2dwikc6hpyz";
+    sha256 = "0frq16p4wms8zfb6mhn7xbxrvf81f1wn37lqlf5p1yjly5fbljhc";
   };
 
   nativeBuildInputs = [ cmake pkgconfig ];
diff --git a/pkgs/servers/radarr/default.nix b/pkgs/servers/radarr/default.nix
index 8d920af654da..62cb2d7f348b 100644
--- a/pkgs/servers/radarr/default.nix
+++ b/pkgs/servers/radarr/default.nix
@@ -2,14 +2,14 @@
 
 stdenv.mkDerivation rec {
   name = "radarr-${version}";
-  version = "0.2.0.1120";
+  version = "0.2.0.1217";
 
   src = fetchurl {
-    url = "https://github.com/Radarr/Radarr/releases/download/v${version}/Radarr.develop.${version}.linux.tar.gz";
-    sha256 = "0vsjaza0k4djb3vnazl2py4qmbxqfyyr0x9p4flq78yn79hp3439";
+    url = "https://github.com/Radarr/Radarr/releases/download/v${version}/Radarr.v${version}.linux.tar.gz";
+    sha256 = "09zzvfqpv58b79a906013pjq42qwbibf16rz24gnqg7wq7az83jy";
   };
 
-  buildInputs = [ makeWrapper ];
+  nativeBuildInputs = [ makeWrapper ];
 
   installPhase = ''
     mkdir -p $out/{bin,share/${name}}
@@ -22,7 +22,7 @@ stdenv.mkDerivation rec {
   '';
 
   meta = with stdenv.lib; {
-    description = "A Usenet/BitTorrent movie downloader.";
+    description = "A Usenet/BitTorrent movie downloader";
     homepage = https://radarr.video/;
     license = licenses.gpl3;
     maintainers = with maintainers; [ edwtjo ];
diff --git a/pkgs/servers/search/groonga/default.nix b/pkgs/servers/search/groonga/default.nix
index c692cee08bd6..fd14a214be50 100644
--- a/pkgs/servers/search/groonga/default.nix
+++ b/pkgs/servers/search/groonga/default.nix
@@ -7,11 +7,11 @@
 stdenv.mkDerivation rec {
 
   name    = "groonga-${version}";
-  version = "8.0.8";
+  version = "8.0.9";
 
   src = fetchurl {
     url    = "https://packages.groonga.org/source/groonga/${name}.tar.gz";
-    sha256 = "1fl5s0a5ncw8lj3ild2qqqxa3h4d3k98dmyki760c54kw6p6bycv";
+    sha256 = "1fd5smhqchnjv0injj3x0zsqzffw1r4gq625znqljg6chny3cq08";
   };
 
   buildInputs = with stdenv.lib;
diff --git a/pkgs/servers/sip/freeswitch/default.nix b/pkgs/servers/sip/freeswitch/default.nix
index 32acba433b12..ab4147230a92 100644
--- a/pkgs/servers/sip/freeswitch/default.nix
+++ b/pkgs/servers/sip/freeswitch/default.nix
@@ -1,6 +1,9 @@
 { fetchurl, stdenv, ncurses, curl, pkgconfig, gnutls, readline
 , openssl, perl, sqlite, libjpeg, speex, pcre
-, ldns, libedit, yasm, which, lua, libopus, libsndfile }:
+, ldns, libedit, yasm, which, lua, libopus, libsndfile
+
+, SystemConfiguration
+}:
 
 stdenv.mkDerivation rec {
   name = "freeswitch-1.6.20";
@@ -20,7 +23,7 @@ stdenv.mkDerivation rec {
     openssl ncurses curl gnutls readline perl libjpeg
     sqlite pcre speex ldns libedit yasm which lua libopus
     libsndfile
-  ];
+  ] ++ stdenv.lib.optionals stdenv.isDarwin [ SystemConfiguration ];
 
   NIX_CFLAGS_COMPILE = "-Wno-error";
 
@@ -31,6 +34,6 @@ stdenv.mkDerivation rec {
     homepage = https://freeswitch.org/;
     license = stdenv.lib.licenses.mpl11;
     maintainers = with stdenv.lib.maintainers; [ ];
-    platforms = with stdenv.lib.platforms; linux;
+    platforms = with stdenv.lib.platforms; unix;
   };
 }
diff --git a/pkgs/servers/sql/postgresql/default.nix b/pkgs/servers/sql/postgresql/default.nix
index 8c82385c1d84..2b56c32d6350 100644
--- a/pkgs/servers/sql/postgresql/default.nix
+++ b/pkgs/servers/sql/postgresql/default.nix
@@ -106,6 +106,8 @@ let
       license     = licenses.postgresql;
       maintainers = with maintainers; [ ocharles thoughtpolice ];
       platforms   = platforms.unix;
+      knownVulnerabilities = optional (!atLeast "9.4")
+        "PostgreSQL versions older than 9.4 are not maintained anymore!";
     };
   });
 
diff --git a/pkgs/servers/xmpp/prosody/default.nix b/pkgs/servers/xmpp/prosody/default.nix
index ed6fef05a263..228c074bf7ea 100644
--- a/pkgs/servers/xmpp/prosody/default.nix
+++ b/pkgs/servers/xmpp/prosody/default.nix
@@ -25,12 +25,12 @@ let
 in
 
 stdenv.mkDerivation rec {
-  version = "0.10.2";
+  version = "0.11.1";
   name = "prosody-${version}";
 
   src = fetchurl {
     url = "https://prosody.im/downloads/source/${name}.tar.gz";
-    sha256 = "13knr7izscw0zx648b9582dx11aap4cq9bzfiqh5ykd7wwsz1dbm";
+    sha256 = "1ak5bkx09kscyifxhzybgp5a73jr8nki6xi05c59wwlq0wzw9gli";
   };
 
   communityModules = fetchhg {