about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorAndreas Rammhold <andreas@rammhold.de>2019-08-06 08:15:50 +0000
committerGitHub <noreply@github.com>2019-08-06 08:15:50 +0000
commit955480e6bf2f01f572cbb245397cbbcc8a4cee4f (patch)
tree9f9d8b8dc61420bb19b3b2a0afda85868c51df38 /pkgs/servers
parent18d7dbe38210155b7c7fbbeb40c1262c1bbe7842 (diff)
parentf1faec8249eb74ee7a8a74e52cbffb50386cab25 (diff)
downloadnixlib-955480e6bf2f01f572cbb245397cbbcc8a4cee4f.tar
nixlib-955480e6bf2f01f572cbb245397cbbcc8a4cee4f.tar.gz
nixlib-955480e6bf2f01f572cbb245397cbbcc8a4cee4f.tar.bz2
nixlib-955480e6bf2f01f572cbb245397cbbcc8a4cee4f.tar.lz
nixlib-955480e6bf2f01f572cbb245397cbbcc8a4cee4f.tar.xz
nixlib-955480e6bf2f01f572cbb245397cbbcc8a4cee4f.tar.zst
nixlib-955480e6bf2f01f572cbb245397cbbcc8a4cee4f.zip
Merge pull request #65950 from aanderse/mysql-update
mysql57: 5.7.25 -> 5.7.27 
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/sql/mysql/5.7.x.nix16
1 files changed, 7 insertions, 9 deletions
diff --git a/pkgs/servers/sql/mysql/5.7.x.nix b/pkgs/servers/sql/mysql/5.7.x.nix
index 249a5af5d480..6636c099e832 100644
--- a/pkgs/servers/sql/mysql/5.7.x.nix
+++ b/pkgs/servers/sql/mysql/5.7.x.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, cmake, bison
+{ stdenv, fetchurl, cmake, bison, pkgconfig
 , boost, libedit, libevent, lz4, ncurses, openssl, protobuf, readline, zlib, perl
 , cctools, CoreServices, developer_cmds }:
 
@@ -6,12 +6,12 @@
 
 let
 self = stdenv.mkDerivation rec {
-  name = "mysql-${version}";
-  version = "5.7.25";
+  pname = "mysql";
+  version = "5.7.27";
 
   src = fetchurl {
-    url = "mirror://mysql/MySQL-5.7/${name}.tar.gz";
-    sha256 = "0gvjcdnba7nf2dx3fbqk1qyg49zclfvaihb78l8h6qc08di1qxak";
+    url = "mirror://mysql/MySQL-5.7/${pname}-${version}.tar.gz";
+    sha256 = "1fhv16zr46pxm1j8vb8x8mh3nwzglg01arz8gnazbmjqldr5idpq";
   };
 
   preConfigure = stdenv.lib.optional stdenv.isDarwin ''
@@ -19,13 +19,11 @@ self = stdenv.mkDerivation rec {
     export PATH=$PATH:$TMPDIR
   '';
 
-  nativeBuildInputs = [ cmake bison ];
+  nativeBuildInputs = [ cmake bison pkgconfig ];
 
   buildInputs = [ boost libedit libevent lz4 ncurses openssl protobuf readline zlib ]
      ++ stdenv.lib.optionals stdenv.isDarwin [ perl cctools CoreServices developer_cmds ];
 
-  enableParallelBuilding = true;
-
   outputs = [ "out" "static" ];
 
   cmakeFlags = [
@@ -76,7 +74,7 @@ self = stdenv.mkDerivation rec {
   };
 
   meta = with stdenv.lib; {
-    homepage = https://www.mysql.com/;
+    homepage = "https://www.mysql.com/";
     description = "The world's most popular open source database";
     platforms = platforms.unix;
     license = with licenses; [