about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2017-07-06 19:02:03 +0200
committerRobin Gloster <mail@glob.in>2017-12-29 02:18:35 +0100
commit9265012de647750d64e40c07bcc5ee6ccc56da6d (patch)
treedd039c24e4499a84c3434b222d443cf10b11493a /pkgs/servers
parenta8df05ee2f766694391034f03fd6bfae2fc43424 (diff)
downloadnixlib-9265012de647750d64e40c07bcc5ee6ccc56da6d.tar
nixlib-9265012de647750d64e40c07bcc5ee6ccc56da6d.tar.gz
nixlib-9265012de647750d64e40c07bcc5ee6ccc56da6d.tar.bz2
nixlib-9265012de647750d64e40c07bcc5ee6ccc56da6d.tar.lz
nixlib-9265012de647750d64e40c07bcc5ee6ccc56da6d.tar.xz
nixlib-9265012de647750d64e40c07bcc5ee6ccc56da6d.tar.zst
nixlib-9265012de647750d64e40c07bcc5ee6ccc56da6d.zip
mariadb: fix lib cycle and hash
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/sql/mariadb/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/servers/sql/mariadb/default.nix b/pkgs/servers/sql/mariadb/default.nix
index 269bd2abb251..707865750722 100644
--- a/pkgs/servers/sql/mariadb/default.nix
+++ b/pkgs/servers/sql/mariadb/default.nix
@@ -18,8 +18,9 @@ common = rec { # attributes common to both builds
   version = "10.2.6";
 
   src = fetchurl {
-    url    = "https://downloads.mariadb.org/interstitial/mariadb-${version}/source/mariadb-${version}.tar.gz";
+    url    = "https://downloads.mariadb.org/f/mariadb-${version}/source/mariadb-${version}.tar.gz/from/http%3A//ftp.hosteurope.de/mirror/archive.mariadb.org/?serve";
     sha256 = "1rd2b1b6s87ymr5qhlggr4q4ljazv82ih0msgrbz1rfn81pcg1f3";
+    name   = "mariadb-${version}.tar.gz";
   };
 
   prePatch = ''
@@ -69,9 +70,10 @@ common = rec { # attributes common to both builds
   postInstall = ''
     rm "$out"/lib/*.a
     find "''${!outputBin}/bin" -name '*test*' -delete
+    moveToOutput bin/mariadb_config "$dev"
   '';
 
-  passthru.mysqlVersion = "5.6";
+  passthru.mysqlVersion = "5.7";
 
   meta = with stdenv.lib; {
     description = "An enhanced, drop-in replacement for MySQL";