about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorstuebinm <stuebinm@disroot.org>2024-02-25 18:51:20 +0100
committerstuebinm <stuebinm@disroot.org>2024-02-25 18:51:20 +0100
commit91df784a3f6673f3e44d8dc0acc7ab94da45f39b (patch)
tree3be92309da367385d1cdb9cd380a21c8d0c2644a /pkgs/servers
parent086388fc15419bd9000378056a4369f63948ab1a (diff)
downloadnixlib-91df784a3f6673f3e44d8dc0acc7ab94da45f39b.tar
nixlib-91df784a3f6673f3e44d8dc0acc7ab94da45f39b.tar.gz
nixlib-91df784a3f6673f3e44d8dc0acc7ab94da45f39b.tar.bz2
nixlib-91df784a3f6673f3e44d8dc0acc7ab94da45f39b.tar.lz
nixlib-91df784a3f6673f3e44d8dc0acc7ab94da45f39b.tar.xz
nixlib-91df784a3f6673f3e44d8dc0acc7ab94da45f39b.tar.zst
nixlib-91df784a3f6673f3e44d8dc0acc7ab94da45f39b.zip
mattermost: add passthru.updateScript
Previously, updates of mattermost tended to lag behind upstream's
released versions by a minor (security-patch) version or two.

This should hopefully make the r-ryantm bot detect future updates
automatically. Thanks to Emily Lange for explaining to me how this
works!
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/mattermost/default.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/pkgs/servers/mattermost/default.nix b/pkgs/servers/mattermost/default.nix
index dbe887ee869d..c76dd152929c 100644
--- a/pkgs/servers/mattermost/default.nix
+++ b/pkgs/servers/mattermost/default.nix
@@ -1,6 +1,7 @@
 { lib
 , buildGoModule
 , fetchFromGitHub
+, nix-update-script
 , fetchurl
 , nixosTests
 }:
@@ -8,6 +9,9 @@
 buildGoModule rec {
   pname = "mattermost";
   # ESR releases only.
+  # See https://docs.mattermost.com/upgrade/extended-support-release.html
+  # When a new ESR version is available (e.g. 8.1.x -> 9.5.x), update
+  # the version regex in passthru.updateScript as well.
   version = "9.5.1";
 
   src = fetchFromGitHub {
@@ -63,7 +67,12 @@ buildGoModule rec {
     find $out/{client,i18n,fonts,templates,config} -type f -exec chmod -x {} \;
   '';
 
-  passthru.tests.mattermost = nixosTests.mattermost;
+  passthru = {
+    updateScript = nix-update-script {
+      extraArgs = [ "--version-regex" "^v(9\.5\.([0-9.]+))" ];
+    };
+    tests.mattermost = nixosTests.mattermost;
+  };
 
   meta = with lib; {
     description = "Mattermost is an open source platform for secure collaboration across the entire software development lifecycle";