about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-05-23 19:02:22 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-05-23 19:07:13 -0700
commit8c99f2e3d65add9bca5df66f7f2f3014ea337c85 (patch)
tree3c866ff4bf03790fc43da79aa0088fb8ea1f8611 /pkgs/servers
parent1bb67e514b2514b9267919784524821952cd73b3 (diff)
downloadnixlib-8c99f2e3d65add9bca5df66f7f2f3014ea337c85.tar
nixlib-8c99f2e3d65add9bca5df66f7f2f3014ea337c85.tar.gz
nixlib-8c99f2e3d65add9bca5df66f7f2f3014ea337c85.tar.bz2
nixlib-8c99f2e3d65add9bca5df66f7f2f3014ea337c85.tar.lz
nixlib-8c99f2e3d65add9bca5df66f7f2f3014ea337c85.tar.xz
nixlib-8c99f2e3d65add9bca5df66f7f2f3014ea337c85.tar.zst
nixlib-8c99f2e3d65add9bca5df66f7f2f3014ea337c85.zip
postgresql: 9.0.19 -> 9.0.20
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/sql/postgresql/9.0.x.nix36
-rw-r--r--pkgs/servers/sql/postgresql/generic.nix56
2 files changed, 34 insertions, 58 deletions
diff --git a/pkgs/servers/sql/postgresql/9.0.x.nix b/pkgs/servers/sql/postgresql/9.0.x.nix
index a27bc012b6ed..6c24e6aa4c45 100644
--- a/pkgs/servers/sql/postgresql/9.0.x.nix
+++ b/pkgs/servers/sql/postgresql/9.0.x.nix
@@ -1,34 +1,10 @@
-{ stdenv, fetchurl, zlib, readline, openssl }:
+{ callPackage, fetchurl, ... } @ args:
 
-let version = "9.0.19"; in
-
-stdenv.mkDerivation rec {
-  name = "postgresql-${version}";
+callPackage ./generic.nix (args // rec {
+  version = "9.0.20";
 
   src = fetchurl {
-    url = "mirror://postgresql/source/v${version}/${name}.tar.bz2";
-    sha256 = "1h45jdbzdcvprdsi9gija81s3ny46h3faf9f007gza4vm6y15bak";
-  };
-
-  buildInputs = [ zlib readline openssl ];
-
-  LC_ALL = "C";
-
-  configureFlags = [ "--with-openssl" ];
-
-  patches = [ ./less-is-more.patch ];
-
-  passthru = {
-    inherit readline;
-    psqlSchema = "9.0";
-  };
-
-  meta = with stdenv.lib; {
-    homepage = http://www.postgresql.org/;
-    description = "A powerful, open source object-relational database system";
-    license = licenses.postgresql;
-    maintainers = with maintaiers; [ ocharles ];
-    platforms = platforms.unix;
-    hydraPlatforms = platforms.linux;
+    url = "mirror://postgresql/source/v${version}/postgresql-${version}.tar.bz2";
+    sha256 = "0vxa90d1ghv6vg4c6kxvm2skypahvlq4sd968q7l9ff3dl145z02";
   };
-}
+})
diff --git a/pkgs/servers/sql/postgresql/generic.nix b/pkgs/servers/sql/postgresql/generic.nix
index d7fd28ccb689..b2af6dd53316 100644
--- a/pkgs/servers/sql/postgresql/generic.nix
+++ b/pkgs/servers/sql/postgresql/generic.nix
@@ -43,34 +43,34 @@ stdenv.mkDerivation rec {
   #LC_ALL = "C";
 
   configureFlags = [
-    (mkOther                        "sysconfdir"        "/etc")
-    (mkOther                        "localstatedir"     "/var")
-    (mkEnable true                  "integer-datetimes" null)
-    (mkEnable true                  "nls"               null)
-    (mkWith   true                  "pgport"            "5432")
-    (mkEnable true                  "shared"            null)
-    (mkEnable true                  "rpath"             null)
-    (mkEnable true                  "spinlocks"         null)
-    (mkEnable false                 "debug"             null)
-    (mkEnable false                 "profiling"         null)
-    (mkEnable false                 "coverage"          null)
-    (mkEnable false                 "dtrace"            null)
-    (mkWith   true                  "blocksize"         (toString blockSizeKB))
-    (mkWith   true                  "segsize"           (toString segmentSizeGB))
-    (mkWith   true                  "wal-blocksize"     (toString walBlockSizeKB))
-    (mkWith   true                  "wal-segsize"       (toString walSegmentSizeMB))
-    (mkEnable true                  "autodepend"        null)
-    (mkEnable false                 "cassert"           null)
-    (mkEnable true                  "thread-safety"     null)
-    (mkWith   false                 "tcl"               null)  # Maybe enable some day
-    (mkWith   false                 "perl"              null)  # Maybe enable some day
-    (mkWith   false                 "python"            null)  # Maybe enable some day
-    (mkWith   (optKerberos != null) "gssapi"            null)
-    (mkWith   false                 "krb5"              null)
-    (mkWith   (optPam != null)      "pam"               null)
-    (mkWith   (optOpenldap != null) "ldap"              null)
-    (mkWith   false                 "bonjour"           null)
-    (mkWith   (optOpenssl != null)       "openssl"           null)
+    (mkOther                            "sysconfdir"        "/etc")
+    (mkOther                            "localstatedir"     "/var")
+    (mkEnable true                      "integer-datetimes" null)
+    (mkEnable true                      "nls"               null)
+    (mkWith   true                      "pgport"            "5432")
+    (mkEnable true                      "shared"            null)
+    (mkEnable true                      "rpath"             null)
+    (mkEnable true                      "spinlocks"         null)
+    (mkEnable false                     "debug"             null)
+    (mkEnable false                     "profiling"         null)
+    (mkEnable false                     "coverage"          null)
+    (mkEnable false                     "dtrace"            null)
+    (mkWith   true                      "blocksize"         (toString blockSizeKB))
+    (mkWith   true                      "segsize"           (toString segmentSizeGB))
+    (mkWith   true                      "wal-blocksize"     (toString walBlockSizeKB))
+    (mkWith   true                      "wal-segsize"       (toString walSegmentSizeMB))
+    (mkEnable true                      "depend"            null)
+    (mkEnable false                     "cassert"           null)
+    (mkEnable true                      "thread-safety"     null)
+    (mkWith   false                     "tcl"               null)  # Maybe enable some day
+    (mkWith   false                     "perl"              null)  # Maybe enable some day
+    (mkWith   false                     "python"            null)  # Maybe enable some day
+    (mkWith   (optKerberos != null)     "gssapi"            null)
+    (mkWith   false                     "krb5"              null)
+    (mkWith   (optPam != null)          "pam"               null)
+    (mkWith   (optOpenldap != null)     "ldap"              null)
+    (mkWith   false                     "bonjour"           null)
+    (mkWith   (optOpenssl != null)      "openssl"           null)
     (mkWith   (optReadline != null)     "readline"          null)
     (mkWith   false                     "libedit-preferred" null)
     (mkWith   (optLibossp_uuid != null) "ossp-uuid"         null)