about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2020-05-31 16:05:30 +0200
committerGitHub <noreply@github.com>2020-05-31 16:05:30 +0200
commit8ae5866152710d26bc4a2346b9b15d692f63a3c7 (patch)
tree879a9617ea2d3a19b46073f12ae45cd5a0f59062 /pkgs/servers
parent21680361ef8a296407c8ab1c2667dcc263462639 (diff)
parenta4bf2cc1666079b0d1d46cb059fe263bd56fd6ec (diff)
downloadnixlib-8ae5866152710d26bc4a2346b9b15d692f63a3c7.tar
nixlib-8ae5866152710d26bc4a2346b9b15d692f63a3c7.tar.gz
nixlib-8ae5866152710d26bc4a2346b9b15d692f63a3c7.tar.bz2
nixlib-8ae5866152710d26bc4a2346b9b15d692f63a3c7.tar.lz
nixlib-8ae5866152710d26bc4a2346b9b15d692f63a3c7.tar.xz
nixlib-8ae5866152710d26bc4a2346b9b15d692f63a3c7.tar.zst
nixlib-8ae5866152710d26bc4a2346b9b15d692f63a3c7.zip
Merge pull request #89224 from etu/fix-unit-php-extensions
unit: Expose PHP expressions used so it can easily be accessed for configs
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/unit/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkgs/servers/http/unit/default.nix b/pkgs/servers/http/unit/default.nix
index 7bd3451e771f..fbb7768dcbae 100644
--- a/pkgs/servers/http/unit/default.nix
+++ b/pkgs/servers/http/unit/default.nix
@@ -67,6 +67,11 @@ in stdenv.mkDerivation rec {
     ++ optional (!withIPv6) "--no-ipv6"
     ++ optional withDebug   "--debug";
 
+  # Optionally add the PHP derivations used so they can be addressed in the configs
+  usedPhp72 = optionals withPHP72 php72-unit;
+  usedPhp73 = optionals withPHP73 php73-unit;
+  usedPhp74 = optionals withPHP74 php74-unit;
+
   postConfigure = ''
     ${optionalString withPython2    "./configure python --module=python2  --config=python2-config  --lib-path=${python2}/lib"}
     ${optionalString withPython3    "./configure python --module=python3  --config=python3-config  --lib-path=${python3}/lib"}