about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorPeter Hoeg <peter@hoeg.com>2018-11-14 09:09:23 +0800
committerGitHub <noreply@github.com>2018-11-14 09:09:23 +0800
commit7c2babf84c415c6cdce1538b0b259007e4e319fc (patch)
treeb6233b7ce5c22cca0b59a5262337f3e599efb6b3 /pkgs/servers
parent695a3d4254545968fc3015142c5299c0da5ca0a9 (diff)
parent195ba2136eee92b7f26e32f4c82ce8feca0cb318 (diff)
downloadnixlib-7c2babf84c415c6cdce1538b0b259007e4e319fc.tar
nixlib-7c2babf84c415c6cdce1538b0b259007e4e319fc.tar.gz
nixlib-7c2babf84c415c6cdce1538b0b259007e4e319fc.tar.bz2
nixlib-7c2babf84c415c6cdce1538b0b259007e4e319fc.tar.lz
nixlib-7c2babf84c415c6cdce1538b0b259007e4e319fc.tar.xz
nixlib-7c2babf84c415c6cdce1538b0b259007e4e319fc.tar.zst
nixlib-7c2babf84c415c6cdce1538b0b259007e4e319fc.zip
Merge pull request #50258 from peterhoeg/f/mqtt
mosquitto: enable websockets support
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/mqtt/mosquitto/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkgs/servers/mqtt/mosquitto/default.nix b/pkgs/servers/mqtt/mosquitto/default.nix
index 231124a42efb..21fe01e8a343 100644
--- a/pkgs/servers/mqtt/mosquitto/default.nix
+++ b/pkgs/servers/mqtt/mosquitto/default.nix
@@ -25,6 +25,10 @@ stdenv.mkDerivation rec {
     substituteInPlace man/manpage.xsl \
       --replace /usr/share/xml/docbook/stylesheet/ ${docbook_xsl}/share/xml/
 
+    for f in {lib,lib/cpp,src}/CMakeLists.txt ; do
+      substituteInPlace $f --replace /sbin/ldconfig ldconfig
+    done
+
     # the manpages are not generated when using cmake
     pushd man
     make
@@ -39,6 +43,7 @@ stdenv.mkDerivation rec {
 
   cmakeFlags = [
     "-DWITH_THREADING=ON"
+    "-DWITH_WEBSOCKETS=ON"
   ];
 
   meta = with stdenv.lib; {