about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2020-03-21 05:59:00 -0500
committerMario Rodas <marsam@users.noreply.github.com>2020-03-21 05:59:00 -0500
commit7a84da8ac8a1931d9f2e59dec8dc09ef3f302759 (patch)
tree29fa0c02b0fb0a77b83bcd23242defa7146c9407 /pkgs/servers
parentb11d54582d467072ff911ee3ceb36672f3c4aae5 (diff)
downloadnixlib-7a84da8ac8a1931d9f2e59dec8dc09ef3f302759.tar
nixlib-7a84da8ac8a1931d9f2e59dec8dc09ef3f302759.tar.gz
nixlib-7a84da8ac8a1931d9f2e59dec8dc09ef3f302759.tar.bz2
nixlib-7a84da8ac8a1931d9f2e59dec8dc09ef3f302759.tar.lz
nixlib-7a84da8ac8a1931d9f2e59dec8dc09ef3f302759.tar.xz
nixlib-7a84da8ac8a1931d9f2e59dec8dc09ef3f302759.tar.zst
nixlib-7a84da8ac8a1931d9f2e59dec8dc09ef3f302759.zip
shiori: fix build on darwin
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/web-apps/shiori/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/pkgs/servers/web-apps/shiori/default.nix b/pkgs/servers/web-apps/shiori/default.nix
index dd4cdc08287b..bd17f2f267c6 100644
--- a/pkgs/servers/web-apps/shiori/default.nix
+++ b/pkgs/servers/web-apps/shiori/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, buildGoModule, fetchFromGitHub }:
+{ stdenv, buildGoModule, fetchFromGitHub, Security }:
 
 buildGoModule rec {
   pname = "shiori";
@@ -13,6 +13,8 @@ buildGoModule rec {
     sha256 = "13and7gh2882khqppwz3wwq44p7az4bfdfjvlnqcpqyi8xa28pmq";
   };
 
+  buildInputs = stdenv.lib.optionals stdenv.isDarwin [ Security ];
+
   meta = with stdenv.lib; {
     description = "Simple bookmark manager built with Go";
     homepage = "https://github.com/go-shiori/shiori";