about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2017-07-22 18:54:41 +0200
committerRobin Gloster <mail@glob.in>2017-12-29 02:18:35 +0100
commit77af1d2000dc4c169f10823d5991f658170cd8fd (patch)
tree2d44d83c09d0c43bcdd81e17e43426914ca7aaf6 /pkgs/servers
parentee1c85aee9ebbfc76c6fed31a868e4082e4bad13 (diff)
downloadnixlib-77af1d2000dc4c169f10823d5991f658170cd8fd.tar
nixlib-77af1d2000dc4c169f10823d5991f658170cd8fd.tar.gz
nixlib-77af1d2000dc4c169f10823d5991f658170cd8fd.tar.bz2
nixlib-77af1d2000dc4c169f10823d5991f658170cd8fd.tar.lz
nixlib-77af1d2000dc4c169f10823d5991f658170cd8fd.tar.xz
nixlib-77af1d2000dc4c169f10823d5991f658170cd8fd.tar.zst
nixlib-77af1d2000dc4c169f10823d5991f658170cd8fd.zip
mysql.server: fix build
That moveToOutput should've been only for the client
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/sql/mariadb/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/servers/sql/mariadb/default.nix b/pkgs/servers/sql/mariadb/default.nix
index 3b48a666132b..a73c870f5395 100644
--- a/pkgs/servers/sql/mariadb/default.nix
+++ b/pkgs/servers/sql/mariadb/default.nix
@@ -70,7 +70,6 @@ common = rec { # attributes common to both builds
   postInstall = ''
     rm "$out"/lib/*.a
     find "''${!outputBin}/bin" -name '*test*' -delete
-    moveToOutput bin/mariadb_config "$dev"
   '';
 
   passthru.mysqlVersion = "5.7";
@@ -107,6 +106,7 @@ client = stdenv.mkDerivation (common // {
   # prevent cycle; it needs to reference $dev
   postInstall = common.postInstall + ''
     moveToOutput bin/mysql_config "$dev"
+    moveToOutput bin/mariadb_config "$dev"
   '';
 
   enableParallelBuilding = true; # the client should be OK