about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authordanbst <abcz2.uprola@gmail.com>2016-09-21 17:39:57 +0000
committerdanbst <abcz2.uprola@gmail.com>2016-09-22 04:02:56 +0000
commit6d05af5f4c80b44694543578586b1860f4028aff (patch)
tree74e61b4990f2a41f7e03e5c13a56f1d8e166965e /pkgs/servers
parent4aafe684d2baad9e657047ab9b3452bc8ef1ebf5 (diff)
downloadnixlib-6d05af5f4c80b44694543578586b1860f4028aff.tar
nixlib-6d05af5f4c80b44694543578586b1860f4028aff.tar.gz
nixlib-6d05af5f4c80b44694543578586b1860f4028aff.tar.bz2
nixlib-6d05af5f4c80b44694543578586b1860f4028aff.tar.lz
nixlib-6d05af5f4c80b44694543578586b1860f4028aff.tar.xz
nixlib-6d05af5f4c80b44694543578586b1860f4028aff.tar.zst
nixlib-6d05af5f4c80b44694543578586b1860f4028aff.zip
pg_repack: init at 1.3.4
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/sql/postgresql/pg_repack/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/servers/sql/postgresql/pg_repack/default.nix b/pkgs/servers/sql/postgresql/pg_repack/default.nix
new file mode 100644
index 000000000000..9a6410490c54
--- /dev/null
+++ b/pkgs/servers/sql/postgresql/pg_repack/default.nix
@@ -0,0 +1,35 @@
+{ stdenv, fetchFromGitHub, postgresql, openssl, zlib, readline }:
+
+stdenv.mkDerivation rec {
+    name = "pg_repack-${version}";
+    version = "1.3.4";
+
+    buildInputs = [ postgresql openssl zlib readline ];
+
+    src = fetchFromGitHub {
+      owner = "reorg";
+      repo = "pg_repack";
+      rev = "ver_${version}";
+      sha256 = "1hig4x8iycchlp42q8565jzi6hkj8gpbhl9kpn73jvk7afl7z0c8";
+    };
+
+    installPhase = ''
+      install -D bin/pg_repack -t $out/bin/
+      install -D lib/pg_repack.so -t $out/lib/
+      install -D lib/{pg_repack--${version}.sql,pg_repack.control} -t $out/share/extension
+    '';
+
+    meta = with stdenv.lib; {
+      description = "Reorganize tables in PostgreSQL databases with minimal locks";
+      longDescription = ''
+        pg_repack is a PostgreSQL extension which lets you remove bloat from tables and indexes, and optionally restore
+        the physical order of clustered indexes. Unlike CLUSTER and VACUUM FULL it works online, without holding an
+        exclusive lock on the processed tables during processing. pg_repack is efficient to boot,
+        with performance comparable to using CLUSTER directly.
+      '';
+      license = licenses.bsd3;
+      maintainers = with maintainers; [ danbst ];
+      inherit (postgresql.meta) platforms;
+      inherit (src.meta) homepage;
+    };
+}