about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2020-01-17 01:57:13 +0000
committerAlyssa Ross <hi@alyssa.is>2020-01-20 14:36:56 +0000
commit6af4de84d3a487ce3c0c00e857958859263acc8c (patch)
tree5d8b44a581c05c73169e8d34f53f0c8bcf72c9d3 /pkgs/servers
parent38f2103de9fd65f4656d50847783a0c5170b4201 (diff)
downloadnixlib-6af4de84d3a487ce3c0c00e857958859263acc8c.tar
nixlib-6af4de84d3a487ce3c0c00e857958859263acc8c.tar.gz
nixlib-6af4de84d3a487ce3c0c00e857958859263acc8c.tar.bz2
nixlib-6af4de84d3a487ce3c0c00e857958859263acc8c.tar.lz
nixlib-6af4de84d3a487ce3c0c00e857958859263acc8c.tar.xz
nixlib-6af4de84d3a487ce3c0c00e857958859263acc8c.tar.zst
nixlib-6af4de84d3a487ce3c0c00e857958859263acc8c.zip
python3.pkgs.hyperkitty: use checkInputs
The previously propagated build inputs are optional, and so are
included in checkInputs so the tests can run, but not propagated so
they aren't included if unneeded.
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/mail/mailman/hyperkitty.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/pkgs/servers/mail/mailman/hyperkitty.nix b/pkgs/servers/mail/mailman/hyperkitty.nix
index 758433ba3a43..7e696f6d27fa 100644
--- a/pkgs/servers/mail/mailman/hyperkitty.nix
+++ b/pkgs/servers/mail/mailman/hyperkitty.nix
@@ -15,14 +15,19 @@ buildPythonPackage rec {
   };
 
   nativeBuildInputs = [ isort ];
-  buildInputs = [ coverage mock ];
   propagatedBuildInputs = [
     robot-detection django_extensions rjsmin cssmin django-mailman3
     django-haystack flufl_lock networkx dateutil defusedxml
     django-paintstore djangorestframework django django-q
-    django_compressor beautifulsoup4 six psycopg2 whoosh isort elasticsearch
+    django_compressor six psycopg2 isort
   ];
 
+  # Some of these are optional runtime dependencies that are not
+  # listed as dependencies in setup.py.  To use these, they should be
+  # dependencies of the Django Python environment, but not of
+  # HyperKitty so they're not included for people who don't need them.
+  checkInputs = [ beautifulsoup4 coverage elasticsearch mock whoosh ];
+
   checkPhase = ''
     cd $NIX_BUILD_TOP/$sourceRoot
     PYTHONPATH=.:$PYTHONPATH python example_project/manage.py test \