about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorBenjamin Staffin <benley@gmail.com>2015-08-30 00:12:09 -0700
committerBenjamin Staffin <benley@gmail.com>2015-08-30 00:12:09 -0700
commit6122488297369518cb2bf1b876f9fdf072a27924 (patch)
tree27d9bb823820df8188854ba8197a468a56aee560 /pkgs/servers
parent4f53847ca2eaf50d1b20f564ac4c7ee9ce2d055d (diff)
downloadnixlib-6122488297369518cb2bf1b876f9fdf072a27924.tar
nixlib-6122488297369518cb2bf1b876f9fdf072a27924.tar.gz
nixlib-6122488297369518cb2bf1b876f9fdf072a27924.tar.bz2
nixlib-6122488297369518cb2bf1b876f9fdf072a27924.tar.lz
nixlib-6122488297369518cb2bf1b876f9fdf072a27924.tar.xz
nixlib-6122488297369518cb2bf1b876f9fdf072a27924.tar.zst
nixlib-6122488297369518cb2bf1b876f9fdf072a27924.zip
prometheus-nginx-exporter: fold into go-packages.nix
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/monitoring/prometheus/nginx_exporter/default.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/pkgs/servers/monitoring/prometheus/nginx_exporter/default.nix b/pkgs/servers/monitoring/prometheus/nginx_exporter/default.nix
deleted file mode 100644
index b716bdd17227..000000000000
--- a/pkgs/servers/monitoring/prometheus/nginx_exporter/default.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ lib, goPackages, fetchFromGitHub }:
-
-let self = goPackages.buildGoPackage rec {
-  name = "prometheus-nginx-exporter-${version}";
-  version = "git-2015-06-01";
-  goPackagePath = "github.com/discordianfish/nginx_exporter";
-
-  src = fetchFromGitHub {
-    owner = "discordianfish";
-    repo = "nginx_exporter";
-    rev = "2cf16441591f6b6e58a8c0439dcaf344057aea2b";
-    sha256 = "0p9j0bbr2lr734980x2p8d67lcify21glwc5k3i3j4ri4vadpxvc";
-  };
-
-  buildInputs = [
-    goPackages.prometheus.client_golang
-    goPackages.prometheus.log
-  ];
-
-  meta = with lib; {
-    description = "Metrics relay from nginx stats to Prometheus";
-    homepage = https://github.com/discordianfish/nginx_exporter;
-    license = licenses.asl20;
-    maintainers = with maintainers; [ benley ];
-    platforms = platforms.unix;
-  };
-};
-
-in self.bin