about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorLéo Gaspard <github@leo.gaspard.ninja>2019-02-24 17:11:41 +0100
committerGitHub <noreply@github.com>2019-02-24 17:11:41 +0100
commit5fa2c13696a749850d562aa73465cb5d80b57d07 (patch)
tree53bd86ecbe67276afa3f8ec2d84fc481d731ba60 /pkgs/servers
parenta13f0a1dcd58d34abeb41d671a78b7cb8efc70e8 (diff)
parentcb15d762f4984d09ff7b5c1716d3660a51e1509a (diff)
downloadnixlib-5fa2c13696a749850d562aa73465cb5d80b57d07.tar
nixlib-5fa2c13696a749850d562aa73465cb5d80b57d07.tar.gz
nixlib-5fa2c13696a749850d562aa73465cb5d80b57d07.tar.bz2
nixlib-5fa2c13696a749850d562aa73465cb5d80b57d07.tar.lz
nixlib-5fa2c13696a749850d562aa73465cb5d80b57d07.tar.xz
nixlib-5fa2c13696a749850d562aa73465cb5d80b57d07.tar.zst
nixlib-5fa2c13696a749850d562aa73465cb5d80b57d07.zip
Merge pull request #56257 from pacien/synapse-0.99.1.1-homeserverscript
matrix-synapse: restore service wrapper script
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/matrix-synapse/default.nix7
-rw-r--r--pkgs/servers/matrix-synapse/homeserver-script.patch21
2 files changed, 27 insertions, 1 deletions
diff --git a/pkgs/servers/matrix-synapse/default.nix b/pkgs/servers/matrix-synapse/default.nix
index 46d74c06013d..1b97e0049ed5 100644
--- a/pkgs/servers/matrix-synapse/default.nix
+++ b/pkgs/servers/matrix-synapse/default.nix
@@ -30,6 +30,11 @@ in buildPythonApplication rec {
     sha256 = "1ych13x3c2cam7af4q2ariwvzwvr65g3j2x8ajjn33ydwxxbqbg6";
   };
 
+  patches = [
+    # adds an entry point for the service
+    ./homeserver-script.patch
+  ];
+
   propagatedBuildInputs = [
     bcrypt
     bleach
@@ -77,6 +82,6 @@ in buildPythonApplication rec {
     homepage = https://matrix.org;
     description = "Matrix reference homeserver";
     license = licenses.asl20;
-    maintainers = with maintainers; [ ralith roblabla ekleog ];
+    maintainers = with maintainers; [ ralith roblabla ekleog pacien ];
   };
 }
diff --git a/pkgs/servers/matrix-synapse/homeserver-script.patch b/pkgs/servers/matrix-synapse/homeserver-script.patch
new file mode 100644
index 000000000000..95e28196a229
--- /dev/null
+++ b/pkgs/servers/matrix-synapse/homeserver-script.patch
@@ -0,0 +1,21 @@
+diff --git a/homeserver b/homeserver
+new file mode 120000
+index 0000000..2f1d413
+--- /dev/null
++++ b/homeserver
+@@ -0,0 +1,1 @@
++synapse/app/homeserver.py
+\ No newline at end of file
+diff --git a/setup.py b/setup.py
+index b00c2af..c7f6e0a 100755
+--- a/setup.py
++++ b/setup.py
+@@ -92,6 +92,6 @@ setup(
+     include_package_data=True,
+     zip_safe=False,
+     long_description=long_description,
+-    scripts=["synctl"] + glob.glob("scripts/*"),
++    scripts=["synctl", "homeserver"] + glob.glob("scripts/*"),
+     cmdclass={'test': TestCommand},
+ )
+