about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorRobert Schütz <rschuetz17@gmail.com>2019-01-30 09:18:24 +0100
committerGitHub <noreply@github.com>2019-01-30 09:18:24 +0100
commit5acb21453fb37ee1608f219a39eae36ed65d3998 (patch)
treeed406f048eab48d042433bec0e40c65e029f1d1d /pkgs/servers
parentb35cee11605f1e45a66863f411295496b0db4c4b (diff)
parentc3b01eed801ff4eb74a8c2637866d16ee26db2c7 (diff)
downloadnixlib-5acb21453fb37ee1608f219a39eae36ed65d3998.tar
nixlib-5acb21453fb37ee1608f219a39eae36ed65d3998.tar.gz
nixlib-5acb21453fb37ee1608f219a39eae36ed65d3998.tar.bz2
nixlib-5acb21453fb37ee1608f219a39eae36ed65d3998.tar.lz
nixlib-5acb21453fb37ee1608f219a39eae36ed65d3998.tar.xz
nixlib-5acb21453fb37ee1608f219a39eae36ed65d3998.tar.zst
nixlib-5acb21453fb37ee1608f219a39eae36ed65d3998.zip
Merge pull request #54904 from dotlambda/home-assistant-cli-0.4.2
home-assistant-cli: 0.3.0 -> 0.4.2
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/home-assistant/cli.nix23
1 files changed, 12 insertions, 11 deletions
diff --git a/pkgs/servers/home-assistant/cli.nix b/pkgs/servers/home-assistant/cli.nix
index c889610963d6..c1b6c9ceb9cc 100644
--- a/pkgs/servers/home-assistant/cli.nix
+++ b/pkgs/servers/home-assistant/cli.nix
@@ -1,29 +1,30 @@
-{ lib, python3 }:
+# dateparser tests fail on pyton37: https://github.com/NixOS/nixpkgs/issues/52766
+{ lib, python36, glibcLocales }:
 
-python3.pkgs.buildPythonApplication rec {
+python36.pkgs.buildPythonApplication rec {
   pname = "homeassistant-cli";
-  version = "0.3.0";
+  version = "0.4.2";
 
-  src = python3.pkgs.fetchPypi {
+  src = python36.pkgs.fetchPypi {
     inherit pname version;
-    sha256 = "42d7cb008801d7a448b62aed1fc46dd450ee67397bf16faabb02f691417db4b2";
+    sha256 = "e0b05af9e49baf88a44f1b36c3446a106223016dceefd5f9910e204af5901f44";
   };
 
   postPatch = ''
     # Ignore pinned versions
-    sed -i "s/'\(.*\)==.*'/'\1'/g" setup.py
+    sed -i "s/'\(.*\)\(==\|>=\).*'/'\1'/g" setup.py
   '';
 
-  propagatedBuildInputs = with python3.pkgs; [
-    requests pyyaml netdisco click click-log tabulate idna jsonpath_rw jinja2
+  propagatedBuildInputs = with python36.pkgs; [
+    requests pyyaml netdisco click click-log tabulate idna jsonpath_rw jinja2 dateparser
   ];
 
-  checkInputs = with python3.pkgs; [
-    pytest requests-mock
+  checkInputs = with python36.pkgs; [
+    pytest requests-mock glibcLocales
   ];
 
   checkPhase = ''
-    pytest
+    LC_ALL=en_US.UTF-8 pytest
   '';
 
   meta = with lib; {