about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-03-22 16:08:22 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-03-22 16:08:22 -0400
commit568b37384adbfad594bb90abcab8677fec1ffa42 (patch)
treefcc00109b3f4b62570fca0253e6351f1682e632f /pkgs/servers
parent92a5b1b055a568cd42a56e3d3bdd55108aa820a1 (diff)
parent40aabe9d483001762bd1a28d494df1d1f871c642 (diff)
downloadnixlib-568b37384adbfad594bb90abcab8677fec1ffa42.tar
nixlib-568b37384adbfad594bb90abcab8677fec1ffa42.tar.gz
nixlib-568b37384adbfad594bb90abcab8677fec1ffa42.tar.bz2
nixlib-568b37384adbfad594bb90abcab8677fec1ffa42.tar.lz
nixlib-568b37384adbfad594bb90abcab8677fec1ffa42.tar.xz
nixlib-568b37384adbfad594bb90abcab8677fec1ffa42.tar.zst
nixlib-568b37384adbfad594bb90abcab8677fec1ffa42.zip
Merge remote-tracking branch 'upstream/master' into staging
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/dns/bind/default.nix4
-rw-r--r--pkgs/servers/nextcloud/news-updater.nix4
-rw-r--r--pkgs/servers/openpts/bugs.patch12
-rw-r--r--pkgs/servers/openpts/default.nix54
-rw-r--r--pkgs/servers/openpts/ptsc.patch28
-rw-r--r--pkgs/servers/openpts/tboot.patch21
-rw-r--r--pkgs/servers/openpts/zlib.patch12
-rw-r--r--pkgs/servers/serviio/default.nix30
-rw-r--r--pkgs/servers/xmpp/prosody/default.nix23
9 files changed, 46 insertions, 142 deletions
diff --git a/pkgs/servers/dns/bind/default.nix b/pkgs/servers/dns/bind/default.nix
index 55368ac9a4dc..86e756a0db37 100644
--- a/pkgs/servers/dns/bind/default.nix
+++ b/pkgs/servers/dns/bind/default.nix
@@ -4,14 +4,14 @@
 
 assert enableSeccomp -> libseccomp != null;
 
-let version = "9.12.0"; in
+let version = "9.12.1"; in
 
 stdenv.mkDerivation rec {
   name = "bind-${version}";
 
   src = fetchurl {
     url = "http://ftp.isc.org/isc/bind9/${version}/${name}.tar.gz";
-    sha256 = "10iwkghl5g50b7wc17bsb9wa0dh2gd57bjlk6ynixhywz6dhx1r9";
+    sha256 = "043mjcw405qa0ghm5dkhfsq35gsy279724fz3mjqpr1mbi14dr0n";
   };
 
   outputs = [ "out" "lib" "dev" "man" "dnsutils" "host" ];
diff --git a/pkgs/servers/nextcloud/news-updater.nix b/pkgs/servers/nextcloud/news-updater.nix
index a78b3d59095e..0fcb5047549d 100644
--- a/pkgs/servers/nextcloud/news-updater.nix
+++ b/pkgs/servers/nextcloud/news-updater.nix
@@ -2,11 +2,11 @@
 
 python3Packages.buildPythonApplication rec {
   name = "nextcloud-news-updater-${version}";
-  version = "10.0.0";
+  version = "10.0.1";
 
   src = fetchurl {
     url = "mirror://pypi/n/nextcloud_news_updater/nextcloud_news_updater-${version}.tar.gz";
-    sha256 = "00pscz0p4s10y1ymb6sm0gx4a5wdbhimn30582x8i28n58nnl8j0";
+    sha256 = "14jj3w417wfsm1ki34d980b0s6vfn8i29g4c66qb2fizdq1d0z6q";
   };
 
   doCheck = false;
diff --git a/pkgs/servers/openpts/bugs.patch b/pkgs/servers/openpts/bugs.patch
deleted file mode 100644
index d818bafbc9f3..000000000000
--- a/pkgs/servers/openpts/bugs.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urNp openpts-0.2.6-cvs-patched/src/fsm.c openpts-0.2.6-current/src/fsm.c
---- openpts-0.2.6-cvs-patched/src/fsm.c	2012-01-05 03:49:15.000000000 -0500
-+++ openpts-0.2.6-current/src/fsm.c	2012-01-09 12:11:17.338706205 -0500
-@@ -934,7 +934,7 @@ char *getEventString(OPENPTS_PCR_EVENT_W
-     /* event */
-     event = eventWrapper->event;
-     if (event != NULL) {
--        // len = snprintf(buf, size, "PCR[%d],TYPE=%d", (int)event->ulPcrIndex, event->eventType);
-+        snprintf(buf, size, "PCR[%d],TYPE=%d", (int)event->ulPcrIndex, event->eventType);
-     } else {
-         LOG(LOG_ERR, "NULL event\n");  // TODO(munetoh)
-         xfree(buf);
diff --git a/pkgs/servers/openpts/default.nix b/pkgs/servers/openpts/default.nix
deleted file mode 100644
index 27731af3803e..000000000000
--- a/pkgs/servers/openpts/default.nix
+++ /dev/null
@@ -1,54 +0,0 @@
-{ stdenv, fetchurl, autoconf, automake, pkgconfig, libtool, trousers, openssl, libxml2, libuuid, gettext, perl }:
-
-stdenv.mkDerivation rec {
-  name = "openpts-${version}";
-  version = "0.2.6";
-
-  src = fetchurl {
-    url = "http://jaist.dl.osdn.jp/openpts/54410/openpts-${version}.tar.gz";
-    sha256 = "1b5phshl49fxr5y3g5zz75gm0n4cw8i7n29x5f1a95xkwrjpazi0";
-  };
-
-  # patches from https://apps.fedoraproject.org/packages/openpts/sources/patches/
-  patches = [ ./bugs.patch ./zlib.patch ./tboot.patch ./ptsc.patch ];
-
-  nativeBuildInputs = [ pkgconfig ];
-  buildInputs = [ autoconf automake libtool trousers openssl libxml2 libuuid gettext ];
-
-  preConfigure = ''
-    substituteInPlace include/Makefile.am --replace "./cvs2msg.pl" "${perl}/bin/perl cvs2msg.pl";
-    $SHELL bootstrap.sh
-    '';
-
-  configureFlags = [ "--with-tss" "--with-aru" "--with-tboot" "--enable-tnc" "--with-aide" ];
-
-  NIX_CFLAGS_COMPILE = "-I${trousers}/include/trousers -I${trousers}/include/tss -Wno-deprecated-declarations";
-
-  preInstall = ''
-    mkdir -p $out
-    mkdir -p $out/etc
-    cp -p dist/ptsc.conf.in $out/etc/ptsc.conf
-    cp -p dist/ptsv.conf.in $out/etc/ptsv.conf
-    mkdir -p $out/share/openpts/models
-    cp -p models/*.uml $out/share/openpts/models/
-
-    mkdir -p $out/share/openpts/tpm_emulator
-    cp dist/tpm_emulator/README.rhel $out/share/openpts/tpm_emulator/README
-    cp dist/tpm_emulator/binary_bios_measurements $out/share/openpts/tpm_emulator/
-    cp dist/tpm_emulator/tcsd $out/share/openpts/tpm_emulator/
-
-    mkdir -p $out/share/openpts/tboot
-    cp dist/tboot/README.fedora15 $out/share/openpts/tboot/README
-    cp dist/tboot/ptsc.conf.fedora15 $out/share/openpts/tboot/ptsc.conf
-    cp dist/tboot/tcsd.conf.fedora15 $out/share/openpts/tboot/tcsd.conf
-    cp dist/tboot/tcsd.fedora15 $out/share/openpts/tboot/tcsd
-    '';
-
-  meta = {
-    description = "TCG Platform Trust Service (PTS)";
-    homepage = http://sourceforge.jp/projects/openpts;
-    license = stdenv.lib.licenses.cpl10;
-    platforms = stdenv.lib.platforms.linux;
-    maintainers = with stdenv.lib.maintainers; [ tstrobel ];
-  };
-}
diff --git a/pkgs/servers/openpts/ptsc.patch b/pkgs/servers/openpts/ptsc.patch
deleted file mode 100644
index b6fcde740744..000000000000
--- a/pkgs/servers/openpts/ptsc.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -urNp openpts-0.2.6-patched/src/ptsc.c openpts-0.2.6-current/src/ptsc.c
---- openpts-0.2.6-patched/src/ptsc.c	2012-08-21 15:57:07.733841433 -0400
-+++ openpts-0.2.6-current/src/ptsc.c	2012-08-21 16:13:26.479732504 -0400
-@@ -457,7 +457,10 @@ void ptsc_lock(void) {
-             exit(1);
-         }
-         oldgrp = getegid();
--        setegid(grp.gr_gid);
-+        if(setegid(grp.gr_gid) != 0){
-+		LOG(LOG_ERR, "setegid fail");
-+		exit(1);
-+	}
-     }
- 
-     oldmask = umask(0);
-@@ -467,7 +470,10 @@ void ptsc_lock(void) {
-     }
-     if (grpent) {
-         chmod(LOCK_DIR, 02775);
--        setegid(oldgrp);
-+	if(setegid(oldgrp) != 0){
-+		LOG(LOG_ERR, "setegid fail");
-+		exit(1);
-+        }
-     }
-     fd = open(LOCK_FILE, O_RDWR | O_CREAT | O_TRUNC, 0660);
-     if (fd < 0) {
-
diff --git a/pkgs/servers/openpts/tboot.patch b/pkgs/servers/openpts/tboot.patch
deleted file mode 100644
index 6ecee5839202..000000000000
--- a/pkgs/servers/openpts/tboot.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -urNp openpts-0.2.6-patched/src/tboot2iml.c openpts-0.2.6-current/src/tboot2iml.c
---- openpts-0.2.6-patched/src/tboot2iml.c	2012-07-23 16:30:12.381361421 -0400
-+++ openpts-0.2.6-current/src/tboot2iml.c	2012-07-23 17:25:59.053945778 -0400
-@@ -531,7 +531,7 @@ int sinit_acm_hash(char *filename, int s
- 
- 
- int sha1sum_unzip(char *filename, int *filesize, BYTE *digest) {
--    FILE *fp;
-+    gzFile fp;
-     char buf[2048];
-     SHA_CTX sha_ctx;
-     int len;
-@@ -541,7 +541,7 @@ int sha1sum_unzip(char *filename, int *f
- 
-     /* open */
-     fp = gzopen(filename, "rb");
--    if (fp == NULL) {
-+    if (fp == Z_NULL) {
-         LOG(LOG_ERR, "File %s does not exist\n", filename);
-         return 0;
-     }
diff --git a/pkgs/servers/openpts/zlib.patch b/pkgs/servers/openpts/zlib.patch
deleted file mode 100644
index 7fa3fce10fe9..000000000000
--- a/pkgs/servers/openpts/zlib.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urNp openpts-0.2.6-cvs-patched/src/Makefile.am openpts-0.2.6-current/src/Makefile.am
---- openpts-0.2.6-cvs-patched/src/Makefile.am	2012-01-05 03:49:15.000000000 -0500
-+++ openpts-0.2.6-current/src/Makefile.am	2012-01-09 14:12:02.507361732 -0500
-@@ -30,7 +30,7 @@ localedir = $(datadir)/locale
- 
- 
- AM_CPPFLAGS = -I$(top_srcdir)/include $(LIBXML2_CFLAGS) $(TSS_CFLAGS) -I../include -DLOCALEDIR=\"$(localedir)\"
--AM_LDFLAGS = $(LIBXML2_LIBS) $(LIBCRYPTO_LIBS) $(TSS_LIBS) -lopenpts
-+AM_LDFLAGS = $(LIBXML2_LIBS) $(LIBCRYPTO_LIBS) $(TSS_LIBS) -lz -lopenpts
- # $(LIBINTL) -lopenpts
- 
- if HAVE_LIBUUID
diff --git a/pkgs/servers/serviio/default.nix b/pkgs/servers/serviio/default.nix
new file mode 100644
index 000000000000..876cc01592e9
--- /dev/null
+++ b/pkgs/servers/serviio/default.nix
@@ -0,0 +1,30 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "serviio-${version}";
+  version = "1.9";
+
+  src = fetchurl {
+    url = "http://download.serviio.org/releases/${name}-linux.tar.gz";
+    sha256 = "0vi9dwpdrk087gpi0xib0hwpvdmaf9g99nfdfx2r3wmmdzw7wysl";
+  };
+
+  phases = ["unpackPhase" "installPhase"];
+
+  installPhase = ''
+    mkdir -p $out
+    cp -R config legal lib library plugins LICENCE.txt NOTICE.txt README.txt RELEASE_NOTES.txt $out
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = http://serviio.org;
+    description = "UPnP Media Streaming Server";
+    longDescription = ''
+      Serviio is a free media server. It allows you to stream your media files (music, video or images)
+      to any DLNA-certified renderer device (e.g. a TV set, Bluray player, games console) on your home network.
+    '';
+    license = licenses.unfree;
+    maintainers = [ maintainers.thpham ];
+    platforms = platforms.linux;
+  };
+}
\ No newline at end of file
diff --git a/pkgs/servers/xmpp/prosody/default.nix b/pkgs/servers/xmpp/prosody/default.nix
index b0e3492c0da1..2d0e1a529dac 100644
--- a/pkgs/servers/xmpp/prosody/default.nix
+++ b/pkgs/servers/xmpp/prosody/default.nix
@@ -1,14 +1,13 @@
 { stdenv, fetchurl, libidn, openssl, makeWrapper, fetchhg
 , lua5, luasocket, luasec, luaexpat, luafilesystem, luabitop
 , withLibevent ? true, luaevent ? null
-, withZlib ? true, luazlib ? null
 , withDBI ? true, luadbi ? null
 # use withExtraLibs to add additional dependencies of community modules
 , withExtraLibs ? [ ]
+, withOnlyInstalledCommunityModules ? [ ]
 , withCommunityModules ? [ ] }:
 
 assert withLibevent -> luaevent != null;
-assert withZlib -> luazlib != null;
 assert withDBI -> luadbi != null;
 
 with stdenv.lib;
@@ -16,7 +15,6 @@ with stdenv.lib;
 let
   libs        = [ luasocket luasec luaexpat luafilesystem luabitop ]
                 ++ optional withLibevent luaevent
-                ++ optional withZlib luazlib
                 ++ optional withDBI luadbi
                 ++ withExtraLibs;
   getPath     = lib : type : "${lib}/lib/lua/${lua5.luaversion}/?.${type};${lib}/share/lua/${lua5.luaversion}/?.${type}";
@@ -27,21 +25,22 @@ let
 in
 
 stdenv.mkDerivation rec {
-  version = "0.9.12";
+  version = "0.10.0";
   name = "prosody-${version}";
 
   src = fetchurl {
     url = "http://prosody.im/downloads/source/${name}.tar.gz";
-    sha256 = "139yxqpinajl32ryrybvilh54ddb1q6s0ajjhlcs4a0rnwia6n8s";
+    sha256 = "1644jy5dk46vahmh6nna36s79k8k668sbi3qamjb4q3c4m3y853l";
   };
 
   communityModules = fetchhg {
     url = "https://hg.prosody.im/prosody-modules";
-    rev = "9a3e51f348fe";
-    sha256 = "09g4vi52rv0r3jzcm0bsgp4ngqq6iapfbxfh0l7qj36qnajp4vm6";
+    rev = "150a7bd59043";
+    sha256 = "0nfx3lngcy88nd81gb7v4kh3nz1bzsm67bxgpd2lprk54diqcrz1";
   };
 
-  buildInputs = [ lua5 makeWrapper libidn openssl ];
+  buildInputs = [ lua5 makeWrapper libidn openssl ]
+    ++ optional withDBI luadbi;
 
   configureFlags = [
     "--ostype=linux"
@@ -52,7 +51,7 @@ stdenv.mkDerivation rec {
   postInstall = ''
       ${concatMapStringsSep "\n" (module: ''
         cp -r $communityModules/mod_${module} $out/lib/prosody/modules/
-      '') withCommunityModules}
+      '') (withCommunityModules ++ withOnlyInstalledCommunityModules)}
       wrapProgram $out/bin/prosody \
         --set LUA_PATH '${luaPath};' \
         --set LUA_CPATH '${luaCPath};'
@@ -62,11 +61,13 @@ stdenv.mkDerivation rec {
         --set LUA_CPATH '${luaCPath};'
     '';
 
+  passthru.communityModules = withCommunityModules;
+
   meta = {
     description = "Open-source XMPP application server written in Lua";
     license = licenses.mit;
-    homepage = http://www.prosody.im;
+    homepage = https://prosody.im;
     platforms = platforms.linux;
-    maintainers = [ ];
+    maintainers = with maintainers; [ fpletz globin ];
   };
 }