about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorOrivej Desh <orivej@gmx.fr>2018-05-31 00:12:23 +0000
committerOrivej Desh <orivej@gmx.fr>2018-06-01 06:03:05 +0000
commit5662c243026bf5b14e8696fa4fe961589470d199 (patch)
tree1da0c7ab8ce99506c8be0deeb171be3725f3d305 /pkgs/servers
parentc97fcb4d2b08f31078459f113fd53fd89c107cd9 (diff)
downloadnixlib-5662c243026bf5b14e8696fa4fe961589470d199.tar
nixlib-5662c243026bf5b14e8696fa4fe961589470d199.tar.gz
nixlib-5662c243026bf5b14e8696fa4fe961589470d199.tar.bz2
nixlib-5662c243026bf5b14e8696fa4fe961589470d199.tar.lz
nixlib-5662c243026bf5b14e8696fa4fe961589470d199.tar.xz
nixlib-5662c243026bf5b14e8696fa4fe961589470d199.tar.zst
nixlib-5662c243026bf5b14e8696fa4fe961589470d199.zip
qpid-cpp: fix build after #28029
When -O2 from hardening does not redefine -O3 from CMake, the build fails with:

     src/qpid/broker/SelectorExpression.cpp: In member function ‘qpid::broker::Expression* qpid::broker::Parse::orExpression(qpid::broker::Tokeniser&)’:
     src/qpid/broker/SelectorExpression.cpp:1041:13: error: ‘*((void*)& s +17)’ may be used uninitialized in this function [-Werror=maybe-uninitialized]
          if (s[1]=='b' || s[1]=='B') {
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/amqp/qpid-cpp/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/servers/amqp/qpid-cpp/default.nix b/pkgs/servers/amqp/qpid-cpp/default.nix
index a838fa3b904c..8446578507d8 100644
--- a/pkgs/servers/amqp/qpid-cpp/default.nix
+++ b/pkgs/servers/amqp/qpid-cpp/default.nix
@@ -35,8 +35,9 @@ let
 
     NIX_CFLAGS_COMPILE = [
       "-Wno-error=deprecated-declarations"
-      "-Wno-error=unused-function"
       "-Wno-error=int-in-bool-context"
+      "-Wno-error=maybe-uninitialized"
+      "-Wno-error=unused-function"
     ];
   };