about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorPeter Hoeg <peter@hoeg.com>2020-04-20 14:06:40 +0800
committerGitHub <noreply@github.com>2020-04-20 14:06:40 +0800
commit53c14c4e65cc5d58525fc9ec310d2e49d16d0283 (patch)
treeb03181bf6283331b7f4fddc27390e8ba08c3770d /pkgs/servers
parent32029f3c7f901e3da4665f031f874c93422bbd39 (diff)
parent93df15d79ae293b19a3945af7302052205480804 (diff)
downloadnixlib-53c14c4e65cc5d58525fc9ec310d2e49d16d0283.tar
nixlib-53c14c4e65cc5d58525fc9ec310d2e49d16d0283.tar.gz
nixlib-53c14c4e65cc5d58525fc9ec310d2e49d16d0283.tar.bz2
nixlib-53c14c4e65cc5d58525fc9ec310d2e49d16d0283.tar.lz
nixlib-53c14c4e65cc5d58525fc9ec310d2e49d16d0283.tar.xz
nixlib-53c14c4e65cc5d58525fc9ec310d2e49d16d0283.tar.zst
nixlib-53c14c4e65cc5d58525fc9ec310d2e49d16d0283.zip
Merge pull request #81365 from peterhoeg/p/https-dns
https-dns-proxy: init at unstable-20200419
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/dns/https-dns-proxy/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/pkgs/servers/dns/https-dns-proxy/default.nix b/pkgs/servers/dns/https-dns-proxy/default.nix
new file mode 100644
index 000000000000..6f2cb5048034
--- /dev/null
+++ b/pkgs/servers/dns/https-dns-proxy/default.nix
@@ -0,0 +1,34 @@
+{ stdenv, fetchFromGitHub, cmake, gtest, c-ares, curl, libev }:
+
+stdenv.mkDerivation rec {
+  pname = "https-dns-proxy";
+  # there are no stable releases (yet?)
+  version = "unstable-20200419";
+
+  src = fetchFromGitHub {
+    owner = "aarond10";
+    repo = "https_dns_proxy";
+    rev = "79fc7b085e3b1ad64c8332f7115dfe2bf5f1f3e4";
+    sha256 = "1cdfswfjby4alp6gy7yyjm76kfyclh5ax0zadnqs2pyigg9plh0b";
+  };
+
+  nativeBuildInputs = [ cmake gtest ];
+
+  buildInputs = [ c-ares curl libev ];
+
+  installPhase = ''
+    install -Dm555 -t $out/bin https_dns_proxy
+    install -Dm444 -t $out/share/doc/${pname} ../{LICENSE,README}.*
+  '';
+
+  # upstream wants to add tests and the gtest framework is in place, so be ready
+  # for when that happens despite there being none as of right now
+  doCheck = true;
+
+  meta = with stdenv.lib; {
+    description = "DNS to DNS over HTTPS (DoH) proxy";
+    license = licenses.mit;
+    maintainers = with maintainers; [ peterhoeg ];
+    platforms = platforms.linux;
+  };
+}