about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2016-01-17 23:04:40 +0000
committerVladimír Čunát <vcunat@gmail.com>2016-01-18 10:45:31 +0100
commit53b389327e34de319dc0dbda2b6bcab1a69db69d (patch)
tree04dece6a1e346ccb4563f61ec206cf03dc46e77f /pkgs/servers
parent620c147ccee09d7d068fa21b2b5b94b6695993a5 (diff)
downloadnixlib-53b389327e34de319dc0dbda2b6bcab1a69db69d.tar
nixlib-53b389327e34de319dc0dbda2b6bcab1a69db69d.tar.gz
nixlib-53b389327e34de319dc0dbda2b6bcab1a69db69d.tar.bz2
nixlib-53b389327e34de319dc0dbda2b6bcab1a69db69d.tar.lz
nixlib-53b389327e34de319dc0dbda2b6bcab1a69db69d.tar.xz
nixlib-53b389327e34de319dc0dbda2b6bcab1a69db69d.tar.zst
nixlib-53b389327e34de319dc0dbda2b6bcab1a69db69d.zip
refactor to use autoreconfHook where possible
Close #12446.
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/nosql/hyperdex/busybee.nix9
-rw-r--r--pkgs/servers/nosql/hyperdex/default.nix11
-rw-r--r--pkgs/servers/nosql/hyperdex/hyperleveldb.nix6
-rw-r--r--pkgs/servers/nosql/hyperdex/libe.nix6
-rw-r--r--pkgs/servers/nosql/hyperdex/libmacaroons.nix10
-rw-r--r--pkgs/servers/nosql/hyperdex/libpo6.nix6
-rw-r--r--pkgs/servers/nosql/hyperdex/replicant.nix10
-rw-r--r--pkgs/servers/shellinabox/default.nix5
8 files changed, 27 insertions, 36 deletions
diff --git a/pkgs/servers/nosql/hyperdex/busybee.nix b/pkgs/servers/nosql/hyperdex/busybee.nix
index 653c74bdabe4..e71fb608260d 100644
--- a/pkgs/servers/nosql/hyperdex/busybee.nix
+++ b/pkgs/servers/nosql/hyperdex/busybee.nix
@@ -1,5 +1,4 @@
-{ stdenv, fetchurl, unzip, autoconf, automake, libtool,
-  libpo6, libe, pkgconfig }:
+{ stdenv, fetchurl, unzip, autoreconfHook, libpo6, libe, pkgconfig }:
 
 stdenv.mkDerivation rec {
   name = "busybee-${version}";
@@ -9,16 +8,14 @@ stdenv.mkDerivation rec {
     url = "https://github.com/rescrv/busybee/archive/releases/${version}.zip";
     sha256 = "0b51h1kmkf0s3d9y7wjqgp1pk1rk9i7n8bcgyj01kflzdgafbl0b";
   };
+
   buildInputs = [
-    autoconf
-    automake
+    autoreconfHook
     libe
     libpo6
-    libtool
     pkgconfig
     unzip
   ];
-  preConfigure = "autoreconf -i";
 
   meta = with stdenv.lib; {
     description = "A high-performance messaging layer";
diff --git a/pkgs/servers/nosql/hyperdex/default.nix b/pkgs/servers/nosql/hyperdex/default.nix
index 3986e49c4bcf..c375fb29626a 100644
--- a/pkgs/servers/nosql/hyperdex/default.nix
+++ b/pkgs/servers/nosql/hyperdex/default.nix
@@ -1,6 +1,6 @@
-{ stdenv, fetchurl, makeWrapper, unzip, autoconf, automake, libtool,
-  python, libsodium, pkgconfig, popt, glog, xz, json_c, gperf, yacc,
-  flex, pandoc, help2man, autoconf-archive, callPackage }:
+{ stdenv, fetchurl, makeWrapper, unzip, autoreconfHook, autoconf-archive
+, python, libsodium, pkgconfig, popt, glog, xz, json_c, gperf, yacc
+, flex, pandoc, help2man, callPackage }:
 
 assert stdenv.isLinux;
 
@@ -25,9 +25,8 @@ stdenv.mkDerivation rec {
   };
 
   buildInputs = [
-    autoconf
+    autoreconfHook
     autoconf-archive
-    automake
     busybee
     glog
     hyperleveldb
@@ -35,7 +34,6 @@ stdenv.mkDerivation rec {
     libe
     libmacaroons
     libpo6
-    libtool
     pkgconfig
     popt
     python
@@ -47,7 +45,6 @@ stdenv.mkDerivation rec {
     help2man
     pandoc
   ];
-  preConfigure = "autoreconf -fi";
 
   meta = with stdenv.lib; {
     description = "A scalable, searchable key-value store";
diff --git a/pkgs/servers/nosql/hyperdex/hyperleveldb.nix b/pkgs/servers/nosql/hyperdex/hyperleveldb.nix
index f57bbe4f4d24..1e3c3afe234e 100644
--- a/pkgs/servers/nosql/hyperdex/hyperleveldb.nix
+++ b/pkgs/servers/nosql/hyperdex/hyperleveldb.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, unzip, autoconf, automake, libtool }:
+{ stdenv, fetchurl, unzip, autoreconfHook }:
 
 stdenv.mkDerivation rec {
   name = "hyperleveldb-${version}";
@@ -8,8 +8,8 @@ stdenv.mkDerivation rec {
     url = "https://github.com/rescrv/HyperLevelDB/archive/releases/${version}.zip";
     sha256 = "0m5fwl9sc7c6m2zm3zjlxxg7f602gnaryikxgflahhdccdvvr56y";
   };
-  buildInputs = [ unzip autoconf automake libtool ];
-  preConfigure = "autoreconf -i";
+
+  buildInputs = [ unzip autoreconfHook ];
 
   meta = with stdenv.lib; {
     description = ''A fork of LevelDB intended to meet the needs of
diff --git a/pkgs/servers/nosql/hyperdex/libe.nix b/pkgs/servers/nosql/hyperdex/libe.nix
index f7e0d834bb44..dfce4c34a114 100644
--- a/pkgs/servers/nosql/hyperdex/libe.nix
+++ b/pkgs/servers/nosql/hyperdex/libe.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, unzip, autoconf, automake, libtool, libpo6, pkgconfig }:
+{ stdenv, fetchurl, unzip, autoreconfHook, libpo6, pkgconfig }:
 
 stdenv.mkDerivation rec {
   name = "libe-${version}";
@@ -8,8 +8,8 @@ stdenv.mkDerivation rec {
     url = "https://github.com/rescrv/e/archive/releases/${version}.zip";
     sha256 = "18xm0hcnqdf0ipfn19jrgzqsxij5xjbbnihhzc57n4v7yfdca1w3";
   };
-  buildInputs = [ unzip autoconf automake libtool libpo6 pkgconfig ];
-  preConfigure = "autoreconf -i";
+
+  buildInputs = [ unzip autoreconfHook libpo6 pkgconfig ];
 
   meta = with stdenv.lib; {
     description = "Library containing high-performance datastructures and utilities for C++";
diff --git a/pkgs/servers/nosql/hyperdex/libmacaroons.nix b/pkgs/servers/nosql/hyperdex/libmacaroons.nix
index 719b18db8681..016ee704e58c 100644
--- a/pkgs/servers/nosql/hyperdex/libmacaroons.nix
+++ b/pkgs/servers/nosql/hyperdex/libmacaroons.nix
@@ -1,5 +1,5 @@
-{ stdenv, fetchurl, unzip, autoconf, automake, libtool, 
-  pkgconfig, libsodium, python }:
+{ stdenv, fetchurl, unzip, autoreconfHook, pkgconfig, libsodium, python }:
+
 stdenv.mkDerivation rec {
   name = "libmacaroons-${version}";
   version = "0.3.0";
@@ -8,9 +8,9 @@ stdenv.mkDerivation rec {
     url = "https://github.com/rescrv/libmacaroons/archive/releases/${version}.zip";
     sha256 = "18c44424jri0p5la6jgrnlz5p937hk7ws2mldhzjwisqyf5qld43";
   };
-  buildInputs = [ unzip autoconf automake libtool python libsodium pkgconfig ];
-  preConfigure = "autoreconf -i";
-  
+
+  buildInputs = [ unzip autoreconfHook python libsodium pkgconfig ];
+
   meta = with stdenv.lib; {
     description = ''Macaroons are flexible authorization credentials that
         support decentralized delegation, attenuation, and verification.'';
diff --git a/pkgs/servers/nosql/hyperdex/libpo6.nix b/pkgs/servers/nosql/hyperdex/libpo6.nix
index fa68020b539c..70e46f453471 100644
--- a/pkgs/servers/nosql/hyperdex/libpo6.nix
+++ b/pkgs/servers/nosql/hyperdex/libpo6.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, unzip, autoconf, automake, libtool }:
+{ stdenv, fetchurl, unzip, autoreconfHook }:
 
 stdenv.mkDerivation rec {
   name = "libpo6-${version}";
@@ -8,8 +8,8 @@ stdenv.mkDerivation rec {
     url = "https://github.com/rescrv/po6/archive/releases/${version}.zip";
     sha256 = "17grzkh6aw1f68qvkhivbb6vwbm6jd41ysbfn88pypf5lczxrxly";
   };
-  buildInputs = [ unzip autoconf automake libtool ];
-  preConfigure = "autoreconf -i";
+
+  buildInputs = [ unzip autoreconfHook ];
 
   meta = with stdenv.lib; {
     description = "POSIX wrappers for C++";
diff --git a/pkgs/servers/nosql/hyperdex/replicant.nix b/pkgs/servers/nosql/hyperdex/replicant.nix
index f2df744e35f1..43c86e6c0c9a 100644
--- a/pkgs/servers/nosql/hyperdex/replicant.nix
+++ b/pkgs/servers/nosql/hyperdex/replicant.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, unzip, autoconf, automake, libtool, glog,
+{ stdenv, fetchurl, unzip, autoreconfHook, glog,
   hyperleveldb, libe, pkgconfig, popt, libpo6, busybee }:
 
 stdenv.mkDerivation rec {
@@ -9,21 +9,19 @@ stdenv.mkDerivation rec {
     url = "https://github.com/rescrv/Replicant/archive/releases/${version}.zip";
     sha256 = "1q3pdq2ndpj70yd1578bn4grlrp77gl8hv2fz34jpx34qmlalda4";
   };
+
   buildInputs = [
-    autoconf
-    automake
+    autoreconfHook
     busybee
     glog
     hyperleveldb
     libe
     libpo6
-    libtool
     pkgconfig
     popt
     unzip
   ];
-  preConfigure = "autoreconf -i";
-  
+
   meta = with stdenv.lib; {
     description = "A system for maintaining replicated state machines";
     homepage = https://github.com/rescrv/Replicant;
diff --git a/pkgs/servers/shellinabox/default.nix b/pkgs/servers/shellinabox/default.nix
index ed859ac344b8..0a651762f185 100644
--- a/pkgs/servers/shellinabox/default.nix
+++ b/pkgs/servers/shellinabox/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, autoconf, automake, libtool, pam, openssl, openssh, shadow, makeWrapper }:
+{ stdenv, fetchFromGitHub, autoreconfHook, pam, openssl, openssh, shadow, makeWrapper }:
 
 stdenv.mkDerivation rec {
   version = "2.19";
@@ -13,7 +13,7 @@ stdenv.mkDerivation rec {
 
   patches = [ ./shellinabox-minus.patch ];
 
-  buildInputs = [ autoconf automake libtool pam openssl openssh makeWrapper];
+  buildInputs = [ autoreconfHook pam openssl openssh makeWrapper ];
 
   # Disable GSSAPIAuthentication errors. Also, paths in certain source files are
   # hardcoded. Replace the hardcoded paths with correct paths.
@@ -23,7 +23,6 @@ stdenv.mkDerivation rec {
     substituteInPlace ./shellinabox/service.c --replace "/bin/login" "${shadow}/bin/login"
     substituteInPlace ./shellinabox/launcher.c --replace "/bin/login" "${shadow}/bin/login"
     substituteInPlace ./libhttp/ssl.c --replace "/usr/bin" "${openssl}/bin"
-    autoreconf -vfi
   '';
 
   postInstall = ''