about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorSymphorien Gibol <symphorien+git@xlumurb.eu>2018-09-01 15:08:44 +0200
committerSymphorien Gibol <symphorien+git@xlumurb.eu>2018-09-01 16:32:59 +0200
commit53744fe7dd3c0851ba88b2515550beccbd31a28e (patch)
tree70c413aafd25a96849f9be1b283d1ac86ef315b5 /pkgs/servers
parent083220867c71443b0473374e8abe871cecb8b7d9 (diff)
downloadnixlib-53744fe7dd3c0851ba88b2515550beccbd31a28e.tar
nixlib-53744fe7dd3c0851ba88b2515550beccbd31a28e.tar.gz
nixlib-53744fe7dd3c0851ba88b2515550beccbd31a28e.tar.bz2
nixlib-53744fe7dd3c0851ba88b2515550beccbd31a28e.tar.lz
nixlib-53744fe7dd3c0851ba88b2515550beccbd31a28e.tar.xz
nixlib-53744fe7dd3c0851ba88b2515550beccbd31a28e.tar.zst
nixlib-53744fe7dd3c0851ba88b2515550beccbd31a28e.zip
elasticsearch plugins: don't use lib.version
This is wrong and makes the hash change on each nixpkgs commit.
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/search/elasticsearch/plugins.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/pkgs/servers/search/elasticsearch/plugins.nix b/pkgs/servers/search/elasticsearch/plugins.nix
index b3141ee807d1..330a81a422c0 100644
--- a/pkgs/servers/search/elasticsearch/plugins.nix
+++ b/pkgs/servers/search/elasticsearch/plugins.nix
@@ -1,7 +1,5 @@
 { pkgs,  stdenv, fetchurl, unzip, elasticsearch-oss, javaPackages, elk6Version }:
 
-with pkgs.lib;
-
 let
   esPlugin = a@{
     pluginName,
@@ -18,7 +16,7 @@ let
       buildInputs = [ unzip ];
       meta = a.meta // {
         platforms = elasticsearch-oss.meta.platforms;
-        maintainers = (a.meta.maintainers or []) ++ [ maintainers.offline ];
+        maintainers = (a.meta.maintainers or []) ++ (with stdenv.lib.maintainers; [ offline ]);
       };
     });
 in {
@@ -31,14 +29,14 @@ in {
       url = "https://github.com/vhyza/elasticsearch-analysis-lemmagen/releases/download/v${version}/${name}-plugin.zip";
       sha256 = "1m4z05wixjrq4nlbdjyhvprkrwxjym8aba18scmzfn25fhbjgvkz";
     };
-    meta = {
+    meta = with stdenv.lib; {
       homepage = https://github.com/vhyza/elasticsearch-analysis-lemmagen;
       description = "LemmaGen Analysis plugin provides jLemmaGen lemmatizer as Elasticsearch token filter";
       license = licenses.asl20;
     };
   };
 
-  discovery-ec2 = esPlugin {
+  discovery-ec2 = esPlugin rec {
     name = "elasticsearch-discovery-ec2-${version}";
     pluginName = "discovery-ec2";
     version = "${elk6Version}";
@@ -46,7 +44,7 @@ in {
       url = "https://artifacts.elastic.co/downloads/elasticsearch-plugins/discovery-ec2/discovery-ec2-${elk6Version}.zip";
       sha256 = "1i7ksy69132sr84h51lamgq967yz3a3dw0b54nckxpqwad9pcpj0";
     };
-    meta = {
+    meta = with stdenv.lib; {
       homepage = https://github.com/elastic/elasticsearch/tree/master/plugins/discovery-ec2;
       description = "The EC2 discovery plugin uses the AWS API for unicast discovery.";
       license = licenses.asl20;
@@ -61,7 +59,7 @@ in {
       url = "mirror://maven/com/floragunn/search-guard-6/${version}/search-guard-6-${version}.zip";
       sha256 = "1r71h4h9bmxak1mq5gpm19xq5ji1gry1kp3sjmm8azy4ykdqdncx";
     };
-    meta = {
+    meta = with stdenv.lib; {
       homepage = https://github.com/floragunncom/search-guard;
       description = "Plugin to fetch data from JDBC sources for indexing into Elasticsearch";
       license = licenses.asl20;