about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorRobert Schütz <robert.schuetz@stud.uni-heidelberg.de>2018-06-05 09:37:30 +0200
committerRobert Schütz <robert.schuetz@stud.uni-heidelberg.de>2018-06-05 09:46:48 +0200
commit47a08c1918effcc44b8aa8c999a4a6d694e3b7f1 (patch)
treeb04df8799c1dc9aab3a64b53fc52b97b21f61180 /pkgs/servers
parentdd06ec2cf84c0c4b938f315ecd5c1c0e874ffd16 (diff)
downloadnixlib-47a08c1918effcc44b8aa8c999a4a6d694e3b7f1.tar
nixlib-47a08c1918effcc44b8aa8c999a4a6d694e3b7f1.tar.gz
nixlib-47a08c1918effcc44b8aa8c999a4a6d694e3b7f1.tar.bz2
nixlib-47a08c1918effcc44b8aa8c999a4a6d694e3b7f1.tar.lz
nixlib-47a08c1918effcc44b8aa8c999a4a6d694e3b7f1.tar.xz
nixlib-47a08c1918effcc44b8aa8c999a4a6d694e3b7f1.tar.zst
nixlib-47a08c1918effcc44b8aa8c999a4a6d694e3b7f1.zip
home-assistant: add voluptuous-serialize to propagatedBuildInputs
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/home-assistant/component-packages.nix6
-rw-r--r--pkgs/servers/home-assistant/default.nix4
2 files changed, 5 insertions, 5 deletions
diff --git a/pkgs/servers/home-assistant/component-packages.nix b/pkgs/servers/home-assistant/component-packages.nix
index abe57c2d57f9..e2acee87d1ab 100644
--- a/pkgs/servers/home-assistant/component-packages.nix
+++ b/pkgs/servers/home-assistant/component-packages.nix
@@ -228,7 +228,7 @@
     "comfoconnect" = ps: with ps; [  ];
     "config" = ps: with ps; [ aiohttp-cors ];
     "config.automation" = ps: with ps; [  ];
-    "config.config_entries" = ps: with ps; [  ];
+    "config.config_entries" = ps: with ps; [ voluptuous-serialize ];
     "config.core" = ps: with ps; [  ];
     "config.customize" = ps: with ps; [  ];
     "config.entity_registry" = ps: with ps; [  ];
@@ -402,7 +402,7 @@
     "http.real_ip" = ps: with ps; [  ];
     "http.static" = ps: with ps; [  ];
     "http.view" = ps: with ps; [  ];
-    "hue" = ps: with ps; [ aiohue voluptuous-serialize ];
+    "hue" = ps: with ps; [ aiohue ];
     "hue.bridge" = ps: with ps; [  ];
     "hue.config_flow" = ps: with ps; [  ];
     "hue.const" = ps: with ps; [  ];
@@ -459,7 +459,7 @@
     "light.hive" = ps: with ps; [  ];
     "light.homekit_controller" = ps: with ps; [  ];
     "light.homematic" = ps: with ps; [ pyhomematic ];
-    "light.hue" = ps: with ps; [ aiohue voluptuous-serialize ];
+    "light.hue" = ps: with ps; [ aiohue ];
     "light.hyperion" = ps: with ps; [  ];
     "light.iglo" = ps: with ps; [  ];
     "light.ihc" = ps: with ps; [  ];
diff --git a/pkgs/servers/home-assistant/default.nix b/pkgs/servers/home-assistant/default.nix
index 60b005ed54cc..fbc233398735 100644
--- a/pkgs/servers/home-assistant/default.nix
+++ b/pkgs/servers/home-assistant/default.nix
@@ -95,8 +95,8 @@ in with py.pkgs; buildPythonApplication rec {
   propagatedBuildInputs = [
     # From setup.py
     requests pyyaml pytz pip jinja2 voluptuous typing aiohttp async-timeout astral certifi attrs
-    # From http, frontend and recorder components
-    sqlalchemy aiohttp-cors hass-frontend
+    # From http, frontend, recorder and config.config_entries components
+    sqlalchemy aiohttp-cors hass-frontend voluptuous-serialize
   ] ++ componentBuildInputs ++ extraBuildInputs;
 
   checkInputs = [