about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorNick Cao <nickcao@nichi.co>2024-03-16 11:43:55 -0700
committerGitHub <noreply@github.com>2024-03-16 11:43:55 -0700
commit43c14122b3cc6233c55bf8bd49af503e23df2cbc (patch)
tree4381e23d3daa96919f79e45c4499e12904cc1eee /pkgs/servers
parent789f2af24983d988046a6d2329fe11bc85aae7a3 (diff)
parent56be60c27b83d08da2386cb387b0380e6ef6c775 (diff)
downloadnixlib-43c14122b3cc6233c55bf8bd49af503e23df2cbc.tar
nixlib-43c14122b3cc6233c55bf8bd49af503e23df2cbc.tar.gz
nixlib-43c14122b3cc6233c55bf8bd49af503e23df2cbc.tar.bz2
nixlib-43c14122b3cc6233c55bf8bd49af503e23df2cbc.tar.lz
nixlib-43c14122b3cc6233c55bf8bd49af503e23df2cbc.tar.xz
nixlib-43c14122b3cc6233c55bf8bd49af503e23df2cbc.tar.zst
nixlib-43c14122b3cc6233c55bf8bd49af503e23df2cbc.zip
Merge pull request #296319 from emilylange/laurel
laurel: 0.6.0 -> 0.6.1
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/monitoring/laurel/default.nix18
1 files changed, 3 insertions, 15 deletions
diff --git a/pkgs/servers/monitoring/laurel/default.nix b/pkgs/servers/monitoring/laurel/default.nix
index a667d1d442b1..22de6d4ebb6f 100644
--- a/pkgs/servers/monitoring/laurel/default.nix
+++ b/pkgs/servers/monitoring/laurel/default.nix
@@ -1,33 +1,21 @@
 { acl
 , fetchFromGitHub
-, fetchpatch
 , lib
 , rustPlatform
 }:
 
 rustPlatform.buildRustPackage rec {
   pname = "laurel";
-  version = "0.6.0";
+  version = "0.6.1";
 
   src = fetchFromGitHub {
     owner = "threathunters-io";
     repo = "laurel";
     rev = "refs/tags/v${version}";
-    hash = "sha256-lWVrp0ytomrQBSDuQCMFJpSuAuwjSYPwoE4yh/WO2ls=";
+    hash = "sha256-dGgBcugIQ3ZPnqyTw6wRMN2PZLm6GqobeFZ1/uzMKbs=";
   };
 
-  cargoHash = "sha256-GY7vpst+Epsy/x/ths6pwtGQgM6Bx0KI+NsCMFCBujE=";
-
-  cargoPatches = [
-    # Upstream forgot to bump the Cargo.lock before tagging the release.
-    # This patch is the first commit immediately after the tag fixing this mistake.
-    # Needs to be removed next release.
-    (fetchpatch {
-      name = "Cargo-lock-version-bump.patch";
-      url = "https://github.com/threathunters-io/laurel/commit/f38393d1098e8f75394f83ad3da5c1160fb96652.patch";
-      hash = "sha256-x+7p21X38KYqLclFtGnLO5nOHz819+XTaSPMvDbSo/I=";
-    })
-  ];
+  cargoHash = "sha256-8JNLssWTCfwrfQ/jg/rj7BUo9bCNCsM2RDwPI7cacRw=";
 
   nativeBuildInputs = [ rustPlatform.bindgenHook ];
   buildInputs = [ acl ];