about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorJohannes Schleifenbaum <johannes@js-webcoding.de>2022-02-23 11:54:22 +0100
committerJohannes Schleifenbaum <johannes@js-webcoding.de>2022-02-23 11:57:06 +0100
commit3eb688a189b75b7d6a064a53ee74b53bf5ae5bd4 (patch)
tree5fcf59c7971e04b2f9450c18825f2f138b29765f /pkgs/servers
parent916738cd273139a7da3018f1ca1d492cbf9b8c3d (diff)
downloadnixlib-3eb688a189b75b7d6a064a53ee74b53bf5ae5bd4.tar
nixlib-3eb688a189b75b7d6a064a53ee74b53bf5ae5bd4.tar.gz
nixlib-3eb688a189b75b7d6a064a53ee74b53bf5ae5bd4.tar.bz2
nixlib-3eb688a189b75b7d6a064a53ee74b53bf5ae5bd4.tar.lz
nixlib-3eb688a189b75b7d6a064a53ee74b53bf5ae5bd4.tar.xz
nixlib-3eb688a189b75b7d6a064a53ee74b53bf5ae5bd4.tar.zst
nixlib-3eb688a189b75b7d6a064a53ee74b53bf5ae5bd4.zip
matrix-synapse-plugins.matrix-synapse-mjolnir-antispam: 1.3.1 -> 1.3.2
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/matrix-synapse/plugins/mjolnir-antispam.nix31
1 files changed, 3 insertions, 28 deletions
diff --git a/pkgs/servers/matrix-synapse/plugins/mjolnir-antispam.nix b/pkgs/servers/matrix-synapse/plugins/mjolnir-antispam.nix
index 58b19586e4bf..014460ab2301 100644
--- a/pkgs/servers/matrix-synapse/plugins/mjolnir-antispam.nix
+++ b/pkgs/servers/matrix-synapse/plugins/mjolnir-antispam.nix
@@ -1,41 +1,16 @@
-{ lib, buildPythonPackage, fetchFromGitHub, matrix-synapse, fetchpatch }:
+{ lib, buildPythonPackage, fetchFromGitHub, matrix-synapse }:
 
 buildPythonPackage rec {
   pname = "matrix-synapse-mjolnir-antispam";
-  version = "1.3.1";
+  version = "1.3.2";
 
   src = fetchFromGitHub {
     owner = "matrix-org";
     repo = "mjolnir";
     rev = "v${version}";
-    sha256 = "05O7NgqlsVu4mdx1+0CZgBvwvBCWYg7nSFknJiXxuoc=";
+    sha256 = "HDfLndiFm9ayCmixuv4MYBbQ76mzCtTS+4UuBRdpP0E=";
   };
 
-  patches = [
-    #  Update legacy antispam plugin with newer types. Or it'll just ignore mjolnir 1.3.1 rules.
-    (fetchpatch {
-      url = "https://github.com/matrix-org/mjolnir/commit/eb8c5e08b4c2b78e6a796e38e826ac3b7e9dfbaf.patch";
-      sha256 = "sha256-rfFU45PfxR2YmNRU74eBI9M2hqBVZcNH0Sw8W/cavD4=";
-      stripLen = 1;
-    })
-    # Port to Synapse module API (needs Synapse >= 1.37.0)
-    (fetchpatch {
-      url = "https://github.com/matrix-org/mjolnir/commit/9c9bd0e02907412b5fa6b95844e9f53ac07b61fd.patch";
-      sha256 = "sha256-HR2OvqFnlQwRV7ezfOjseatjo+3P8i9PsV7D+hLD1Yo=";
-      stripLen = 1;
-      excludes = [
-        "README.md"
-        "mx-tester.yml"
-      ];
-    })
-    # Move glob_to_regex into the source
-    (fetchpatch {
-      url = "https://github.com/matrix-org/mjolnir/commit/6cb461fed424f07bf50a1fdc0693d40ed8bbee12.patch";
-      sha256 = "sha256-tqcKXNs+fxwPIvN5sJjdNgcz5KUVHiXgulLHR2redYk=";
-      stripLen = 1;
-    })
-  ];
-
   sourceRoot = "./source/synapse_antispam";
 
   propagatedBuildInputs = [ matrix-synapse ];