about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2020-12-26 04:20:00 +0000
committerMario Rodas <marsam@users.noreply.github.com>2020-12-26 04:20:00 +0000
commit39e9bcedeeb7973fef3cf6e947b7d0672e849d51 (patch)
tree68ed83c1e119d1a69db241e7109ca0e813766d4d /pkgs/servers
parent84917aa00bf23c88e5874c683abe05edb0ba4078 (diff)
downloadnixlib-39e9bcedeeb7973fef3cf6e947b7d0672e849d51.tar
nixlib-39e9bcedeeb7973fef3cf6e947b7d0672e849d51.tar.gz
nixlib-39e9bcedeeb7973fef3cf6e947b7d0672e849d51.tar.bz2
nixlib-39e9bcedeeb7973fef3cf6e947b7d0672e849d51.tar.lz
nixlib-39e9bcedeeb7973fef3cf6e947b7d0672e849d51.tar.xz
nixlib-39e9bcedeeb7973fef3cf6e947b7d0672e849d51.tar.zst
nixlib-39e9bcedeeb7973fef3cf6e947b7d0672e849d51.zip
xandikos: install man page
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/xandikos/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/pkgs/servers/xandikos/default.nix b/pkgs/servers/xandikos/default.nix
index 6bd3ebc4232c..515282c1dbcf 100644
--- a/pkgs/servers/xandikos/default.nix
+++ b/pkgs/servers/xandikos/default.nix
@@ -1,6 +1,7 @@
 { stdenv
 , fetchFromGitHub
 , python3Packages
+, installShellFiles
 }:
 
 python3Packages.buildPythonApplication rec {
@@ -24,10 +25,17 @@ python3Packages.buildPythonApplication rec {
     prometheus_client
   ];
 
+  nativeBuildInputs = [ installShellFiles ];
+
+  postInstall = ''
+    installManPage xandikos.1
+  '';
+
   meta = with stdenv.lib; {
     description = "Lightweight CalDAV/CardDAV server";
     homepage = "https://github.com/jelmer/xandikos";
     license = licenses.gpl3Plus;
+    changelog = "https://github.com/jelmer/xandikos/blob/v${version}/NEWS";
     maintainers = with maintainers; [ _0x4A6F ];
   };
 }