about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2023-12-07 06:01:00 +0000
committerGitHub <noreply@github.com>2023-12-07 06:01:00 +0000
commit32d842483f3773ec1cde181507bd77b405af046e (patch)
tree351a44c8193a79dff8e8c8ae6db284c21d17844b /pkgs/servers
parentfd7a8aedb05d043f27206beaf915d1f9397396cf (diff)
parent26a318452796c13502a1b3ec4aa2c352e8d15bbf (diff)
downloadnixlib-32d842483f3773ec1cde181507bd77b405af046e.tar
nixlib-32d842483f3773ec1cde181507bd77b405af046e.tar.gz
nixlib-32d842483f3773ec1cde181507bd77b405af046e.tar.bz2
nixlib-32d842483f3773ec1cde181507bd77b405af046e.tar.lz
nixlib-32d842483f3773ec1cde181507bd77b405af046e.tar.xz
nixlib-32d842483f3773ec1cde181507bd77b405af046e.tar.zst
nixlib-32d842483f3773ec1cde181507bd77b405af046e.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/monitoring/prometheus/atlas-exporter.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/pkgs/servers/monitoring/prometheus/atlas-exporter.nix b/pkgs/servers/monitoring/prometheus/atlas-exporter.nix
new file mode 100644
index 000000000000..ce40a93e66f8
--- /dev/null
+++ b/pkgs/servers/monitoring/prometheus/atlas-exporter.nix
@@ -0,0 +1,22 @@
+{ lib, buildGoModule, fetchFromGitHub }:
+
+buildGoModule rec {
+  pname = "atlas-exporter";
+  version = "1.0.4";
+
+  src = fetchFromGitHub {
+    owner = "czerwonk";
+    repo = "atlas_exporter";
+    rev = version;
+    sha256 = "sha256-vhUhWO7fQpUHT5nyxbT8AylgUqDNZRSb+EGRNGZJ14E=";
+  };
+
+  vendorHash = "sha256-tR+OHxj/97AixuAp0Kx9xQsKPAxpvF6hDha5BgMBha0=";
+
+  meta = with lib; {
+    description = "Prometheus exporter for RIPE Atlas measurement results ";
+    homepage = "https://github.com/czerwonk/atlas_exporter";
+    license = licenses.lgpl3;
+    maintainers = with maintainers; [ clerie ];
+  };
+}