about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2014-09-19 10:56:08 -0700
committerWilliam A. Kennington III <william@wkennington.com>2014-09-21 17:20:59 -0700
commit31220480d83a642f8bf6fe0529633c9460384666 (patch)
tree816642d7700126191bb3ba070c42229213a8c690 /pkgs/servers
parentbe2c1d79082e92e17c58566fe01cba9fa13857e5 (diff)
downloadnixlib-31220480d83a642f8bf6fe0529633c9460384666.tar
nixlib-31220480d83a642f8bf6fe0529633c9460384666.tar.gz
nixlib-31220480d83a642f8bf6fe0529633c9460384666.tar.bz2
nixlib-31220480d83a642f8bf6fe0529633c9460384666.tar.lz
nixlib-31220480d83a642f8bf6fe0529633c9460384666.tar.xz
nixlib-31220480d83a642f8bf6fe0529633c9460384666.tar.zst
nixlib-31220480d83a642f8bf6fe0529633c9460384666.zip
boost: Update depdendent packages
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/amqp/qpid-cpp/default.nix2
-rw-r--r--pkgs/servers/nosql/rethinkdb/default.nix8
-rw-r--r--pkgs/servers/rippled/default.nix8
3 files changed, 9 insertions, 9 deletions
diff --git a/pkgs/servers/amqp/qpid-cpp/default.nix b/pkgs/servers/amqp/qpid-cpp/default.nix
index 69c0a3dff41c..6a71994091d0 100644
--- a/pkgs/servers/amqp/qpid-cpp/default.nix
+++ b/pkgs/servers/amqp/qpid-cpp/default.nix
@@ -11,7 +11,7 @@ stdenv.mkDerivation rec {
     sha256 = "1c03yi19d5h5h78h37add9csmy0mzvvmvn7zkcalwszabdhsb5yk";
   };
 
-  buildInputs = [ cmake python boost libuuid ruby ];
+  buildInputs = [ cmake python boost boost.lib libuuid ruby ];
 
   # the subdir managementgen wants to install python stuff in ${python} and
   # the installation tries to create some folders in /var
diff --git a/pkgs/servers/nosql/rethinkdb/default.nix b/pkgs/servers/nosql/rethinkdb/default.nix
index 3694547c2d99..79fd61390e46 100644
--- a/pkgs/servers/nosql/rethinkdb/default.nix
+++ b/pkgs/servers/nosql/rethinkdb/default.nix
@@ -1,11 +1,11 @@
-{ stdenv, fetchurl, which, protobuf, gperftools, boost, zlib, python, m4 }:
+{ stdenv, fetchurl, which, protobuf, gperftools, boost, zlib, curl, python, m4 }:
 
 stdenv.mkDerivation rec {
-  name = "rethinkdb-1.12.4";
+  name = "rethinkdb-1.14.1";
 
   src = fetchurl {
     url = "http://download.rethinkdb.com/dist/${name}.tgz";
-    sha256 = "1dq2vbgms016ic2hifclm1m58i4804khkn0lnvz47rkm7i0564if";
+    sha256 = "0brsbb289hcsmipma4rsgrkqpqagwff2y6w46dvb25n95id65hx8";
   };
 
   preConfigure = ''
@@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
 
   configureFlags = "--lib-path ${gperftools}/lib";
 
-  buildInputs = [ protobuf zlib boost ];
+  buildInputs = [ protobuf boost boost.lib zlib curl ];
 
   nativeBuildInputs = [ which m4 python ];
 
diff --git a/pkgs/servers/rippled/default.nix b/pkgs/servers/rippled/default.nix
index 1325cebae405..d930c5b6a976 100644
--- a/pkgs/servers/rippled/default.nix
+++ b/pkgs/servers/rippled/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, scons, pkgconfig, openssl, protobuf, boost155, zlib}:
+{ stdenv, fetchurl, scons, pkgconfig, openssl, protobuf, boost, zlib}:
 
 stdenv.mkDerivation rec {
   name = "rippled-${version}";
@@ -11,9 +11,9 @@ stdenv.mkDerivation rec {
 
   patches = [ ./scons-env.patch ];
 
-  buildInputs = [ scons pkgconfig openssl protobuf boost155 zlib ];
+  buildInputs = [ scons pkgconfig openssl protobuf boost zlib ];
 
-  RIPPLED_BOOST_HOME = boost155.out;
+  RIPPLED_BOOST_HOME = boost.out;
   RIPPLED_ZLIB_HOME = zlib.out;
   buildPhase = "scons build/rippled";
 
@@ -29,4 +29,4 @@ stdenv.mkDerivation rec {
     license = stdenv.lib.licenses.isc;
     platforms = stdenv.lib.platforms.linux;
   };
-}
\ No newline at end of file
+}