about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorVladimír Čunát <v@cunat.cz>2023-12-01 07:33:49 +0100
committerVladimír Čunát <v@cunat.cz>2023-12-01 07:33:49 +0100
commit305cd929fd6c40435a4e46e0850c3c339b84390f (patch)
treeaf48b07cbe816861249b134f961a95d593407731 /pkgs/servers
parentbd3afbb69048c7acb07c9fdced5feaafc85b1175 (diff)
parentc44890cbd0106da23ac34d9d853ae5a162e9e39f (diff)
downloadnixlib-305cd929fd6c40435a4e46e0850c3c339b84390f.tar
nixlib-305cd929fd6c40435a4e46e0850c3c339b84390f.tar.gz
nixlib-305cd929fd6c40435a4e46e0850c3c339b84390f.tar.bz2
nixlib-305cd929fd6c40435a4e46e0850c3c339b84390f.tar.lz
nixlib-305cd929fd6c40435a4e46e0850c3c339b84390f.tar.xz
nixlib-305cd929fd6c40435a4e46e0850c3c339b84390f.tar.zst
nixlib-305cd929fd6c40435a4e46e0850c3c339b84390f.zip
Merge branch 'staging' into staging-next
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/monitoring/net-snmp/default.nix14
-rw-r--r--pkgs/servers/tvheadend/default.nix2
2 files changed, 9 insertions, 7 deletions
diff --git a/pkgs/servers/monitoring/net-snmp/default.nix b/pkgs/servers/monitoring/net-snmp/default.nix
index 638d7fad330c..8961bc549535 100644
--- a/pkgs/servers/monitoring/net-snmp/default.nix
+++ b/pkgs/servers/monitoring/net-snmp/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, fetchurl, fetchpatch, removeReferencesTo
+{ lib, stdenv, fetchurl, fetchpatch
 , file, openssl, perl, perlPackages, nettools
 , withPerlTools ? false }: let
 
@@ -45,7 +45,14 @@ in stdenv.mkDerivation rec {
     substituteInPlace testing/fulltests/support/simple_TESTCONF.sh --replace "/bin/netstat" "${nettools}/bin/netstat"
   '';
 
-  nativeBuildInputs = [ nettools removeReferencesTo file ];
+  postConfigure = ''
+    # libraries contain configure options. Mangle store paths out from
+    # ./configure-generated file.
+    sed -i include/net-snmp/net-snmp-config.h \
+      -e "/NETSNMP_CONFIGURE_OPTIONS/ s|$NIX_STORE/[a-z0-9]\{32\}-|$NIX_STORE/eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee-|g"
+  '';
+
+  nativeBuildInputs = [ nettools file ];
   buildInputs = [ openssl ]
     ++ lib.optional withPerlTools perlWithPkgs;
 
@@ -61,9 +68,6 @@ in stdenv.mkDerivation rec {
     done
     mkdir $dev/bin
     mv $bin/bin/net-snmp-config $dev/bin
-    # libraries contain configure options
-    find $lib/lib -type f -exec remove-references-to -t $bin '{}' +
-    find $lib/lib -type f -exec remove-references-to -t $dev '{}' +
   '';
 
   meta = with lib; {
diff --git a/pkgs/servers/tvheadend/default.nix b/pkgs/servers/tvheadend/default.nix
index 7c7b3124ceba..499a046663ae 100644
--- a/pkgs/servers/tvheadend/default.nix
+++ b/pkgs/servers/tvheadend/default.nix
@@ -102,8 +102,6 @@ in stdenv.mkDerivation {
   ];
 
   preConfigure = ''
-    patchShebangs ./configure
-
     substituteInPlace src/config.c \
       --replace /usr/bin/tar ${gnutar}/bin/tar