about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2014-09-05 00:45:55 +0400
committerMichael Raskin <7c6f434c@mail.ru>2014-09-06 12:44:32 +0400
commit2e33964a6a97b738764045960f4f87a328c2ae70 (patch)
tree1a714f75b689d207a847af5ec7cfb6cf374c945d /pkgs/servers
parent53fa51717658830f466b539a21d5401056b8adce (diff)
downloadnixlib-2e33964a6a97b738764045960f4f87a328c2ae70.tar
nixlib-2e33964a6a97b738764045960f4f87a328c2ae70.tar.gz
nixlib-2e33964a6a97b738764045960f4f87a328c2ae70.tar.bz2
nixlib-2e33964a6a97b738764045960f4f87a328c2ae70.tar.lz
nixlib-2e33964a6a97b738764045960f4f87a328c2ae70.tar.xz
nixlib-2e33964a6a97b738764045960f4f87a328c2ae70.tar.zst
nixlib-2e33964a6a97b738764045960f4f87a328c2ae70.zip
Fix leafnode by working around the check
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/news/leafnode/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/pkgs/servers/news/leafnode/default.nix b/pkgs/servers/news/leafnode/default.nix
index 23f236a9a34e..a3579aa83099 100644
--- a/pkgs/servers/news/leafnode/default.nix
+++ b/pkgs/servers/news/leafnode/default.nix
@@ -10,6 +10,11 @@ stdenv.mkDerivation rec {
 
   configureFlags = "--enable-runas-user=nobody";
 
+  preConfigure = ''
+    # configure uses id to check environment; we don't want this check
+    sed -re 's/^ID[=].*/ID="echo whatever"/' -i configure
+  '';
+
   postConfigure = ''
       # The is_validfqdn is far too restrictive, and only allows
       # Internet-facing servers to run.  In order to run leafnode via
@@ -24,6 +29,5 @@ stdenv.mkDerivation rec {
     description = "Leafnode implements a store & forward NNTP proxy";
     license = stdenv.lib.licenses.mit;
     platforms = stdenv.lib.platforms.unix;
-    broken = true; # The user check in the configure does not work in a chroot
   };
 }