about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorsuperherointj <5861043+superherointj@users.noreply.github.com>2024-02-14 09:36:10 -0300
committersuperherointj <5861043+superherointj@users.noreply.github.com>2024-02-19 18:39:57 -0300
commit10f2ace2cb92c78c359af8b06e95e358abd58a9f (patch)
tree1115fbb2ed17f5fe562cb3a2801037f25a590463 /pkgs/servers
parent1930ecaa743ad13353ea88424daf2c62e5071ce1 (diff)
downloadnixlib-10f2ace2cb92c78c359af8b06e95e358abd58a9f.tar
nixlib-10f2ace2cb92c78c359af8b06e95e358abd58a9f.tar.gz
nixlib-10f2ace2cb92c78c359af8b06e95e358abd58a9f.tar.bz2
nixlib-10f2ace2cb92c78c359af8b06e95e358abd58a9f.tar.lz
nixlib-10f2ace2cb92c78c359af8b06e95e358abd58a9f.tar.xz
nixlib-10f2ace2cb92c78c359af8b06e95e358abd58a9f.tar.zst
nixlib-10f2ace2cb92c78c359af8b06e95e358abd58a9f.zip
etcd: add k3s test
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/etcd/3.5.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/pkgs/servers/etcd/3.5.nix b/pkgs/servers/etcd/3.5.nix
index f02533ea9a14..530df4476ecb 100644
--- a/pkgs/servers/etcd/3.5.nix
+++ b/pkgs/servers/etcd/3.5.nix
@@ -1,4 +1,4 @@
-{ lib, buildGoModule, fetchFromGitHub, symlinkJoin, nixosTests }:
+{ lib, buildGoModule, fetchFromGitHub, symlinkJoin, nixosTests, k3s }:
 
 let
   version = "3.5.12";
@@ -67,7 +67,10 @@ symlinkJoin {
 
   passthru = {
     inherit etcdserver etcdutl etcdctl;
-    tests = { inherit (nixosTests) etcd etcd-cluster; };
+    tests = {
+      inherit (nixosTests) etcd etcd-cluster;
+      k3s = k3s.passthru.tests.etcd;
+    };
   };
 
   paths = [