about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2016-02-25 01:27:43 +0000
committerRobin Gloster <mail@glob.in>2016-02-25 01:27:43 +0000
commit0f4ecfad68f9ed35beaf9e26df22bb0fb799f645 (patch)
tree9852a66175cb79b186ac3c824fff9b77c9249d9c /pkgs/servers
parent56ceca9d46bd5d7001141df360742543c6204200 (diff)
downloadnixlib-0f4ecfad68f9ed35beaf9e26df22bb0fb799f645.tar
nixlib-0f4ecfad68f9ed35beaf9e26df22bb0fb799f645.tar.gz
nixlib-0f4ecfad68f9ed35beaf9e26df22bb0fb799f645.tar.bz2
nixlib-0f4ecfad68f9ed35beaf9e26df22bb0fb799f645.tar.lz
nixlib-0f4ecfad68f9ed35beaf9e26df22bb0fb799f645.tar.xz
nixlib-0f4ecfad68f9ed35beaf9e26df22bb0fb799f645.tar.zst
nixlib-0f4ecfad68f9ed35beaf9e26df22bb0fb799f645.zip
certificate-transparency: clean up and use newer clang
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/certificate-transparency/default.nix50
1 files changed, 24 insertions, 26 deletions
diff --git a/pkgs/servers/certificate-transparency/default.nix b/pkgs/servers/certificate-transparency/default.nix
index 80fae89c76d8..a7c2be4e2861 100644
--- a/pkgs/servers/certificate-transparency/default.nix
+++ b/pkgs/servers/certificate-transparency/default.nix
@@ -1,4 +1,7 @@
-{ stdenv, pkgs, ...}:
+{ stdenv, fetchFromGitHub, autoreconfHook, clang, pkgconfig
+, glog, gmock, gtest, google-gflags, gperftools, json_c, leveldb
+, libevent, libevhtp, openssl, protobuf, sqlite
+}:
 
 stdenv.mkDerivation rec {
   name = "certificate-transparency-${version}";
@@ -6,15 +9,7 @@ stdenv.mkDerivation rec {
   version = "2016-01-14";
   rev = "250672b5aef3666edbdfc9a75b95a09e7a57ed08";
 
-  meta = with stdenv.lib; {
-    homepage = https://www.certificate-transparency.org/;
-    description = "Auditing for TLS certificates.";
-    license = licenses.asl20;
-    platforms = platforms.unix;
-    maintainers = with maintainers; [ philandstuff ];
-  };
-
-  src = pkgs.fetchFromGitHub {
+  src = fetchFromGitHub {
     owner = "google";
     repo  = "certificate-transparency";
     rev   = rev;
@@ -22,13 +17,13 @@ stdenv.mkDerivation rec {
   };
 
   # need to disable regex support in evhtp or building will fail
-  libevhtp_without_regex = stdenv.lib.overrideDerivation pkgs.libevhtp
+  libevhtp_without_regex = stdenv.lib.overrideDerivation libevhtp
     (oldAttrs: {
-      cmakeFlags="-DEVHTP_DISABLE_REGEX:STRING=ON -DCMAKE_C_FLAGS:STRING=-fPIC";
+      cmakeFlags = "-DEVHTP_DISABLE_REGEX:STRING=ON";
     });
 
-  buildInputs = with pkgs; [
-    autoconf automake clang_34 pkgconfig
+  buildInputs = [
+    autoreconfHook clang pkgconfig
     glog gmock google-gflags gperftools gtest json_c leveldb
     libevent libevhtp_without_regex openssl protobuf sqlite
   ];
@@ -37,21 +32,24 @@ stdenv.mkDerivation rec {
     ./protobuf-include-from-env.patch
   ];
 
-  doCheck = false;
-
-  preConfigure = ''
-    ./autogen.sh
-    configureFlagsArray=(
-      CC=clang
-      CXX=clang++
-      GMOCK_DIR=${pkgs.gmock}
-      GTEST_DIR=${pkgs.gtest}
-    )
-  '';
+  configureFlags = [
+    "CC=clang"
+    "CXX=clang++"
+    "GMOCK_DIR=${gmock}"
+    "GTEST_DIR=${gtest}"
+  ];
 
   # the default Makefile constructs BUILD_VERSION from `git describe`
   # which isn't available in the nix build environment
   makeFlags = "BUILD_VERSION=${version}-${rev}";
 
-  protocFlags = "-I ${pkgs.protobuf}/include";
+  protocFlags = "-I ${protobuf}/include";
+
+  meta = with stdenv.lib; {
+    homepage = https://www.certificate-transparency.org/;
+    description = "Auditing for TLS certificates.";
+    license = licenses.asl20;
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ philandstuff ];
+  };
 }