about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2013-07-18 15:05:49 -0400
committerShea Levy <shea@shealevy.com>2013-07-18 15:05:49 -0400
commit0c3b84c850e09faa2ef0d05ace89e96ba03ed2ec (patch)
tree974743487eefecc06a0ba84ed06c585ab8e237ce /pkgs/servers
parent6d3329dc317256cb80fac35275438398d66204e5 (diff)
downloadnixlib-0c3b84c850e09faa2ef0d05ace89e96ba03ed2ec.tar
nixlib-0c3b84c850e09faa2ef0d05ace89e96ba03ed2ec.tar.gz
nixlib-0c3b84c850e09faa2ef0d05ace89e96ba03ed2ec.tar.bz2
nixlib-0c3b84c850e09faa2ef0d05ace89e96ba03ed2ec.tar.lz
nixlib-0c3b84c850e09faa2ef0d05ace89e96ba03ed2ec.tar.xz
nixlib-0c3b84c850e09faa2ef0d05ace89e96ba03ed2ec.tar.zst
nixlib-0c3b84c850e09faa2ef0d05ace89e96ba03ed2ec.zip
mongodb 2.4.5
Signed-off-by: Shea Levy <shea@shealevy.com>
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/nosql/mongodb/default.nix18
1 files changed, 4 insertions, 14 deletions
diff --git a/pkgs/servers/nosql/mongodb/default.nix b/pkgs/servers/nosql/mongodb/default.nix
index 612db162e5c5..11dff3244208 100644
--- a/pkgs/servers/nosql/mongodb/default.nix
+++ b/pkgs/servers/nosql/mongodb/default.nix
@@ -1,25 +1,15 @@
 { stdenv, fetchurl, scons, boost, v8, gperftools, pcre, snappy }:
 
-with stdenv.lib;
-
-let installerPatch = fetchurl {
-      url = "https://jira.mongodb.org/secure/attachment/18160/SConscript.client.patch";
-      sha256 = "0n60fh2r8i7m6g113k0iw4adc8jv2by4ahrd780kxg47kzfgw06a";
-    };
-
-in
-stdenv.mkDerivation rec {
-  name = "mongodb-2.4.3";
+let version = "2.4.5"; in stdenv.mkDerivation rec {
+  name = "mongodb-${version}";
 
   src = fetchurl {
-    url = http://downloads.mongodb.org/src/mongodb-src-r2.4.3.tar.gz;
-    sha256 = "1k653xmwphdk88z2byz5fglr8xcsm8nw13prls1rx16qnc6h1pb1";
+    url = "http://downloads.mongodb.org/src/mongodb-src-r${version}.tar.gz";
+    sha256 = "01c7lb3jdr51gy7459vg5rg002xxg0mj79vlhy54n50kr31cnxmm";
   };
 
   nativeBuildInputs = [ scons boost v8 gperftools pcre snappy ];
 
-  patches = [ installerPatch ];
-
   postPatch = ''
     substituteInPlace SConstruct \
         --replace "Environment( BUILD_DIR" "Environment( ENV = os.environ, BUILD_DIR" \