about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorAndrew Newman <deadloko@gmail.com>2019-05-08 10:43:00 +0300
committerAndrew Newman <deadloko@gmail.com>2019-05-08 10:43:00 +0300
commit0b5a5c52d6ac995d161405984e67dee49a8f2540 (patch)
treeabd0467dad7bab3986aa8a1616926c07cbf8b129 /pkgs/servers
parentd51e32404ca5aa43868a265c5f9425a63418118a (diff)
downloadnixlib-0b5a5c52d6ac995d161405984e67dee49a8f2540.tar
nixlib-0b5a5c52d6ac995d161405984e67dee49a8f2540.tar.gz
nixlib-0b5a5c52d6ac995d161405984e67dee49a8f2540.tar.bz2
nixlib-0b5a5c52d6ac995d161405984e67dee49a8f2540.tar.lz
nixlib-0b5a5c52d6ac995d161405984e67dee49a8f2540.tar.xz
nixlib-0b5a5c52d6ac995d161405984e67dee49a8f2540.tar.zst
nixlib-0b5a5c52d6ac995d161405984e67dee49a8f2540.zip
lighttpd: fix crosscompilation
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/lighttpd/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/pkgs/servers/http/lighttpd/default.nix b/pkgs/servers/http/lighttpd/default.nix
index 2993809c5563..318f291689f5 100644
--- a/pkgs/servers/http/lighttpd/default.nix
+++ b/pkgs/servers/http/lighttpd/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, pkgconfig, pcre, libxml2, zlib, bzip2, which, file
+{ stdenv, buildPackages, fetchurl, pkgconfig, pcre, libxml2, zlib, bzip2, which, file
 , openssl, enableMagnet ? false, lua5_1 ? null
 , enableMysql ? false, mysql ? null
 , enableLdap ? false, openldap ? null
@@ -28,8 +28,10 @@ stdenv.mkDerivation rec {
     sed -ire '/[$]self->{HOSTNAME} *=/i     if(length($name)==0) { $name = "127.0.0.1" }' tests/LightyTest.pm
   '';
 
+  depsBuildBuild = [ buildPackages.stdenv.cc ];
+
   nativeBuildInputs = [ pkgconfig ];
-  buildInputs = [ pcre libxml2 zlib bzip2 which file openssl ]
+  buildInputs = [ pcre pcre.dev libxml2 zlib bzip2 which file openssl ]
              ++ stdenv.lib.optional enableMagnet lua5_1
              ++ stdenv.lib.optional enableMysql mysql.connector-c
              ++ stdenv.lib.optional enableLdap openldap
@@ -45,6 +47,7 @@ stdenv.mkDerivation rec {
                 ++ stdenv.lib.optional enableExtendedAttrs "--with-attr";
 
   preConfigure = ''
+    export PATH=$PATH:${pcre.dev}/bin
     sed -i "s:/usr/bin/file:${file}/bin/file:g" configure
   '';