about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-01-21 21:06:27 -0500
committerShea Levy <shea@shealevy.com>2014-01-21 21:06:27 -0500
commitfd999ed57063786b8239566368cbc94e0843c5f8 (patch)
tree83e367ebe1e1794c3ad4c2684a6876bed72c0e62 /pkgs/os-specific
parentd18bc25b95eace4e090771d3e99834157aa32bb2 (diff)
downloadnixlib-fd999ed57063786b8239566368cbc94e0843c5f8.tar
nixlib-fd999ed57063786b8239566368cbc94e0843c5f8.tar.gz
nixlib-fd999ed57063786b8239566368cbc94e0843c5f8.tar.bz2
nixlib-fd999ed57063786b8239566368cbc94e0843c5f8.tar.lz
nixlib-fd999ed57063786b8239566368cbc94e0843c5f8.tar.xz
nixlib-fd999ed57063786b8239566368cbc94e0843c5f8.tar.zst
nixlib-fd999ed57063786b8239566368cbc94e0843c5f8.zip
Linux: Set passthru attr to contain full passthru
This fixes #1566, thanks @wizeman

Signed-off-by: Shea Levy <shea@shealevy.com>
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/generic.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/kernel/generic.nix b/pkgs/os-specific/linux/kernel/generic.nix
index 2e3520c61ce0..266e3fbd55b1 100644
--- a/pkgs/os-specific/linux/kernel/generic.nix
+++ b/pkgs/os-specific/linux/kernel/generic.nix
@@ -120,6 +120,8 @@ let
     features = lib.fold (x: y: (x.features or {}) // y) features kernelPatches;
 
     meta = kernel.meta // extraMeta;
+
+    passthru = kernel.passthru // (removeAttrs passthru [ "passthru" ]);
   };
 
   nativeDrv = lib.addPassthru kernel.nativeDrv passthru;