about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorRenaud <c0bw3b@users.noreply.github.com>2018-11-14 09:48:22 +0100
committerGitHub <noreply@github.com>2018-11-14 09:48:22 +0100
commitcde945a165f90cc9f3a102b81d84c343ec1c1076 (patch)
tree573065ae3e317fc435fe458e9184d8277192490c /pkgs/os-specific
parent4b5ffcb964b48c2754aa8964699b339840f507d3 (diff)
parentd81a96e601b352453ccc328cac42d13907b362c0 (diff)
downloadnixlib-cde945a165f90cc9f3a102b81d84c343ec1c1076.tar
nixlib-cde945a165f90cc9f3a102b81d84c343ec1c1076.tar.gz
nixlib-cde945a165f90cc9f3a102b81d84c343ec1c1076.tar.bz2
nixlib-cde945a165f90cc9f3a102b81d84c343ec1c1076.tar.lz
nixlib-cde945a165f90cc9f3a102b81d84c343ec1c1076.tar.xz
nixlib-cde945a165f90cc9f3a102b81d84c343ec1c1076.tar.zst
nixlib-cde945a165f90cc9f3a102b81d84c343ec1c1076.zip
Merge pull request #48044 from schneefux/pkg/fetchfromgithub
treewide: Use fetchFromGitHub instead of fetchurl
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/reptyr/default.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/pkgs/os-specific/linux/reptyr/default.nix b/pkgs/os-specific/linux/reptyr/default.nix
index 4b83e478dd1c..d8880542e518 100644
--- a/pkgs/os-specific/linux/reptyr/default.nix
+++ b/pkgs/os-specific/linux/reptyr/default.nix
@@ -1,11 +1,13 @@
-{ stdenv, fetchurl }:
+{ stdenv, fetchFromGitHub }:
 
 stdenv.mkDerivation rec {
   version = "0.6.2";
   name = "reptyr-${version}";
-  src = fetchurl {
-    url = "https://github.com/nelhage/reptyr/archive/reptyr-${version}.tar.gz";
-    sha256 = "07pfl0rkgm8m3f3jy8r9l2yvnhf8lgllpsk3mh57mhzdxq8fagf7";
+  src = fetchFromGitHub {
+    owner = "nelhage";
+    repo = "reptyr";
+    rev = "reptyr-${version}";
+    sha256 = "0yfy1p0mz05xg5gzp52vilfz0yl1sjjsvwn0z073mnr4wyam7fg8";
   };
 
   # Avoid a glibc >= 2.25 deprecation warning that gets fatal via -Werror.