about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2020-12-29 16:59:11 -0600
committerMatthew Bauer <mjbauer95@gmail.com>2020-12-29 17:03:34 -0600
commitc9c3dd4950bcd623c0db83e6ce871e3ce7c3adc2 (patch)
tree14cbe95366503ba448a976c47e40a686485d198d /pkgs/os-specific
parent46db54706358d84d4bb7eef9a61d28bb2aca7588 (diff)
downloadnixlib-c9c3dd4950bcd623c0db83e6ce871e3ce7c3adc2.tar
nixlib-c9c3dd4950bcd623c0db83e6ce871e3ce7c3adc2.tar.gz
nixlib-c9c3dd4950bcd623c0db83e6ce871e3ce7c3adc2.tar.bz2
nixlib-c9c3dd4950bcd623c0db83e6ce871e3ce7c3adc2.tar.lz
nixlib-c9c3dd4950bcd623c0db83e6ce871e3ce7c3adc2.tar.xz
nixlib-c9c3dd4950bcd623c0db83e6ce871e3ce7c3adc2.tar.zst
nixlib-c9c3dd4950bcd623c0db83e6ce871e3ce7c3adc2.zip
duti: set kernel to darwin18
Unfortunately, we can’t do arm64 multi-arch with the current nixpkgs
sdk, which duti assumes if your kernel is darwin20 (Big Sur). To fix
this, we can just hardcode to darwin18 which should be compatible with
Nixpkgs Darwin.

Fixes #105751
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/darwin/duti/default.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/pkgs/os-specific/darwin/duti/default.nix b/pkgs/os-specific/darwin/duti/default.nix
index 8c523d8a220a..c56dd20243be 100644
--- a/pkgs/os-specific/darwin/duti/default.nix
+++ b/pkgs/os-specific/darwin/duti/default.nix
@@ -12,7 +12,14 @@ stdenv.mkDerivation rec {
 
   nativeBuildInputs = [autoreconfHook];
   buildInputs = [darwin.apple_sdk.frameworks.ApplicationServices];
-  configureFlags = ["--with-macosx-sdk=/homeless-shelter"];
+  configureFlags = [
+    "--with-macosx-sdk=/homeless-shelter"
+
+    # needed to prevent duti from trying to guess our sdk
+    # NOTE: this is different than stdenv.hostPlatform.config!
+    "--host=x86_64-apple-darwin18"
+  ];
+
   meta = with lib; {
     description = "A command-line tool to select default applications for document types and URL schemes on Mac OS X";
     longDescription = ''